Can't view text/foo files in browser

RESOLVED DUPLICATE of bug 196078

Status

defect
RESOLVED DUPLICATE of bug 196078
18 years ago
3 years ago

People

(Reporter: jmd, Assigned: law)

Tracking

Trunk
mozilla1.0.1
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

()

I've seen this alot of places, it's getting real annoying.

There should at the least be an option in the helper to view it directly in
Mozilla, but text/anything-unknown should probably just default to being viewed
the same as text/plain.
-> docshell (perhaps?)
Assignee: darin → adamlock
Component: Networking: HTTP → Embedding: Docshell
QA Contact: tever → adamlock
Docshell doesn't care what the content type is, so long as a content viewer
exists to view it. Assuming the text/foo type can be changed somewhere in necko
it should display with no troubles. Presumably it would mean either changing the
content type on the channel or feeding the data through a simple stream
converter, plus some front end glue.

CC'ing Doug for ideas.
Let's see if XP Apps is a better fit.
Assignee: adamlock → pchen
Component: Embedding: Docshell → XP Apps
QA Contact: adamlock → sairuh
actually -> file handling
Assignee: pchen → law
Component: XP Apps → File Handling
Post 1.0 feature.
Target Milestone: --- → mozilla1.0.1

*** This bug has been marked as a duplicate of 57342 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
mass-verification of Duplicates.

mail search string for bugspam: SolarFlaresAreTheCause
Status: RESOLVED → VERIFIED
reopening. this is a dup of "view text/* in browser", not of "offer view in
browser in helper app dialog".
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 196078 ***
Status: REOPENED → RESOLVED
Closed: 17 years ago16 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.