Closing an invalid fd in WiFi

RESOLVED FIXED in Firefox 36, Firefox OS v2.0

Status

Firefox OS
Wifi
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: tkundu, Assigned: hchang)

Tracking

({crash})

unspecified
2.1 S8 (7Nov)
ARM
Gonk (Firefox OS)
crash
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0+, firefox34 wontfix, firefox35 wontfix, firefox36 fixed, b2g-v2.0 fixed, b2g-v2.0M fixed, b2g-v2.1 fixed, b2g-v2.2 fixed)

Details

(Whiteboard: [b2g-crash][caf-crash 335][caf priority: p1][CR 716601])

Attachments

(7 attachments, 5 obsolete attachments)

604.50 KB, text/plain
Details
569.82 KB, text/plain
Details
566.66 KB, text/plain
Details
687.43 KB, text/plain
Details
5.13 KB, patch
Details | Diff | Splinter Review
5.71 KB, patch
fabrice
: review+
vchang
: review+
Details | Diff | Splinter Review
5.74 KB, patch
Details | Diff | Splinter Review
Created attachment 8505730 [details]
stack trace

+++ This bug was initially created as a clone of Bug #1061993 +++

When using the patch from Bug 1057220 to catch all invalid fds being closed, we see a crash when operating the WiFi module

You can see the point of crash in the logs as, 

10-15 01:35:55.218   202   871 E libnoselect: -1 = close(194) failed. errno=9
[Blocking Requested - why for this release]:
Blocks: 1074290
No longer blocks: 1041241
blocking-b2g: --- → 2.1?
complete logcats is in [1]. 
[1] https://drive.google.com/file/d/0B1cSMS8_GuAENXR5U2pyR0F1YUk/view?usp=sharing


Please note crash timestamps is : 
"10-15 01:35:55.218   202   871 E libnoselect: -1 = close(194) failed. errno=9"
Flags: needinfo?(hchang)
Observed on: 

Device: msm8226
Gonk Version: AU_LINUX_GECKO_B2G_KK_3.6.01.04.00.000.076
Moz BuildID: 20140829000203
B2G Version: 2.1
Gecko Version: 32.0
Gaia:  http://git.mozilla.org/?p=releases/gaia.git;a=commit;h=5bf3b8cdea15e62ce7bf77a15085a18e24e33c44
Gecko: http://git.mozilla.org/?p=releases/gecko.git;a=commit;h=f2ab70e9ab18439dae25e6eb21f186708b2888de
Patches: bug 1050751
(Assignee)

Comment 5

4 years ago
(In reply to cafbot (PoC: ggrisco) from comment #4)
> Observed on: 
> 
> Device: msm8226
> Gonk Version: AU_LINUX_GECKO_B2G_KK_3.6.01.04.00.000.076
> Moz BuildID: 20140829000203
> B2G Version: 2.1
> Gecko Version: 32.0
> Gaia: 
> http://git.mozilla.org/?p=releases/gaia.git;a=commit;
> h=5bf3b8cdea15e62ce7bf77a15085a18e24e33c44
> Gecko:
> http://git.mozilla.org/?p=releases/gecko.git;a=commit;
> h=f2ab70e9ab18439dae25e6eb21f186708b2888de
> Patches: bug 1050751

The patch for Bug 1061993 seems not in the gecko you use [1].

[1] http://git.mozilla.org/?p=releases/gecko.git;a=blob;f=dom/network/src/NetUtils.cpp;h=87151b361e3f7f3f3b295e69f1e073183e98fea9;hb=f2ab70e9ab18439dae25e6eb21f186708b2888de#l95
Flags: needinfo?(hchang)

Comment 6

4 years ago
Hi Tapas, can you check for comment 5 ? Thanks.
Flags: needinfo?(tkundu)

Updated

4 years ago
Blocks: 1041241
crash + FC and CC blocker = 2.1+
blocking-b2g: 2.1? → 2.1+
(In reply to howie [:howie] from comment #6)
> Hi Tapas, can you check for comment 5 ? Thanks.

We have also seen it in 

https://www.codeaurora.org/cgit/quic/lf/b2g/mozilla/gaia/commit/?h=mozilla/v2.1&id=f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
https://www.codeaurora.org/cgit/quic/lf/b2g/mozilla/gecko/commit/?h=mozilla/v2.1&id=db7fce920e7d782d9f601384dc95924abcdaeeb8

We raised this bug for v2.1 FFOS. Comment 4 is not applicable for v2.1 FFOS.
Flags: needinfo?(tkundu)
Flags: needinfo?(hochang)
Flags: needinfo?(hchang)
(In reply to Tapas[:tkundu on #b2g/gaia/memshrink/gfx] (always NI me) from comment #8)
> https://www.codeaurora.org/cgit/quic/lf/b2g/mozilla/gaia/commit/?h=mozilla/
> v2.1&id=f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
> https://www.codeaurora.org/cgit/quic/lf/b2g/mozilla/gecko/commit/?h=mozilla/
> v2.1&id=db7fce920e7d782d9f601384dc95924abcdaeeb8
> 

The patch for Bug 1061993 has already landed in ^^ .
For more clarifications:

logs in Comment 0, Comment 2 and Comment 3 are collected on v2.1 FFOS build [1] which already has fix from bug 1061993
 

[1] See Comment 8 for exact v2.1 gaia/gecko SHA1 .
(In reply to Tapas[:tkundu on #b2g/gaia/memshrink/gfx] (always NI me) from comment #10)
> For more clarifications:
> 
> logs in Comment 0, Comment 2 and Comment 3 are collected on v2.1 FFOS build
> [1] which already has fix from bug 1061993
>  
> 
> [1] See Comment 8 for exact v2.1 gaia/gecko SHA1 .

Thanks for clarifying. Lets get Henry's input here.
Flags: needinfo?(hchang)

Comment 12

4 years ago
Observed on: 

Device: msm8226
Gonk Version: AU_LINUX_GECKO_B2G_KK_2.0.01.04.00.114.109
Moz BuildID: 20141011000201
B2G Version: 2.1
Gecko Version: 34.0a2
Gaia:  http://git.mozilla.org/?p=releases/gaia.git;a=commit;h=f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: http://git.mozilla.org/?p=releases/gecko.git;a=commit;h=db7fce920e7d782d9f601384dc95924abcdaeeb8
Patches: bug 1075077, bug 1070431, bug 1082234, bug 1076327, bug 1081528, bug 1074419
Observed on: 

Device: msm8226
Gonk Version: AU_LINUX_GECKO_B2G_KK_2.0.01.04.00.114.109
Moz BuildID: 20141011000201
B2G Version: 2.1
Gecko Version: 34.0a2
Gaia:  http://git.mozilla.org/?p=releases/gaia.git;a=commit;h=f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: http://git.mozilla.org/?p=releases/gecko.git;a=commit;h=db7fce920e7d782d9f601384dc95924abcdaeeb8
Patches: bug 1075077, bug 1070431, bug 1082234, bug 1076327, bug 1081528, bug 1074419

Comment 14

4 years ago
Henry is working on this.
Assignee: nobody → hchang
(Assignee)

Comment 15

4 years ago
Created attachment 8506657 [details] [diff] [review]
Bug1083449.patch

Probably ifc_enable/ifc_disable needs to be protected as well.
It's worthy of giving a try. Thansk!
Flags: needinfo?(hchang)

Updated

4 years ago
Flags: needinfo?(hochang)
Flags: needinfo?(dhirnyj)

Comment 16

4 years ago
Any update?

Comment 17

4 years ago
(In reply to Ken Chang[:ken] from comment #16)
> Any update?

The patch from attachment 8506657 [details] [diff] [review] has been landed internally and we're awaiting feedback from the test team
Flags: needinfo?(dhirnyj)
(Assignee)

Updated

4 years ago
Attachment #8506657 - Flags: review?(vchang)
Comment on attachment 8506657 [details] [diff] [review]
Bug1083449.patch

Review of attachment 8506657 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.
Attachment #8506657 - Flags: review?(vchang) → review+
henry, can we please land this asap so this can get uplifted, given the r+ ?
Flags: needinfo?(hchang)
Observed on: 

Device: msm8226
Gonk Version: AU_LINUX_GECKO_B2G_KK_2.0.01.04.00.114.121
Moz BuildID: 20141026001201
B2G Version: 2.1
Gecko Version: 34.0
Gaia:  http://git.mozilla.org/?p=releases/gaia.git;a=commit;h=c97463d61f45513a2123b19610386ddbfc916819
Gecko: http://git.mozilla.org/?p=releases/gecko.git;a=commit;h=9d2ff8f6528e1bf1e18252a479e2c3ccf06201df
Patches: bug 1070431, bug 1083449
(Assignee)

Comment 21

4 years ago
Created attachment 8512462 [details] [diff] [review]
Bug1083449 (r+'d, added reviewer's name)
Attachment #8506657 - Attachment is obsolete: true
Flags: needinfo?(hchang)
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Created attachment 8512895 [details]
.extra file logs

(In reply to Danylo Hirnyj from comment #17)
> (In reply to Ken Chang[:ken] from comment #16)
> > Any update?
> 
> The patch from attachment 8506657 [details] [diff] [review] has been landed
> internally and we're awaiting feedback from the test team

We have seen this issue again with fix from attachment 8506657 [details] [diff] [review]

Stack trace is same and crash timestamp is : 

10-28 09:33:41.311   207   207 E GeckoConsole: Content JS LOG at dummy file:599 in GaiaDataLayer.disableWiFi/<: wifi enabled status: true


Full logcat logs : https://drive.google.com/file/d/0B1cSMS8_GuAEUFZUUEVBaTdNMzQ/view?usp=sharing
Flags: needinfo?(hchang)
NI :henry to check this asap.
(Assignee)

Comment 27

4 years ago
(In reply to Tapas[:tkundu on #b2g/gaia/memshrink/gfx] (always NI me) from comment #24)
> Created attachment 8512895 [details]
> .extra file logs
> 
> (In reply to Danylo Hirnyj from comment #17)
> > (In reply to Ken Chang[:ken] from comment #16)
> > > Any update?
> > 
> > The patch from attachment 8506657 [details] [diff] [review] has been landed
> > internally and we're awaiting feedback from the test team
> 
> We have seen this issue again with fix from attachment 8506657 [details] [diff] [review]
> [diff] [review]
> 
> Stack trace is same and crash timestamp is : 
> 
> 10-28 09:33:41.311   207   207 E GeckoConsole: Content JS LOG at dummy
> file:599 in GaiaDataLayer.disableWiFi/<: wifi enabled status: true
> 
> 
> Full logcat logs :
> https://drive.google.com/file/d/0B1cSMS8_GuAEUFZUUEVBaTdNMzQ/view?usp=sharing

Hmmm, were you doing gaia-ui-test? (from "GaiaDataLayer.disableWiFi")?
If yes, I would expect we can reproduce it and gdb it! It would be helpful!
Flags: needinfo?(hchang)

Updated

4 years ago
Flags: needinfo?(tkundu)
(Assignee)

Comment 28

4 years ago
Oops how stupid I was. There would be 2 instances of NetUtils but not 1.
Those instances should share the same mutex ...

[1] http://hg.mozilla.org/releases/mozilla-b2g34_v2_1/file/318019f80a8e/dom/wifi/WifiUtils.cpp#l390
[2] http://hg.mozilla.org/releases/mozilla-b2g34_v2_1/file/318019f80a8e/dom/system/gonk/NetworkUtils.cpp#l1017
(Assignee)

Comment 29

4 years ago
(In reply to Henry Chang [:henry] from comment #28)
> Oops how stupid I was. There would be 2 instances of NetUtils but not 1.
> Those instances should share the same mutex ...
> 
> [1]
> http://hg.mozilla.org/releases/mozilla-b2g34_v2_1/file/318019f80a8e/dom/wifi/
> WifiUtils.cpp#l390
> [2]
> http://hg.mozilla.org/releases/mozilla-b2g34_v2_1/file/318019f80a8e/dom/
> system/gonk/NetworkUtils.cpp#l1017

which means patch for Bug 1061993 fixed nothing. Will attach another patch
to use a shared mutex instead of a per instance mutex.
(Assignee)

Comment 30

4 years ago
Created attachment 8513256 [details] [diff] [review]
Bug 1083449 (the REAL patch! for v2.1)
(Assignee)

Comment 31

4 years ago
Comment on attachment 8513256 [details] [diff] [review]
Bug 1083449 (the REAL patch! for v2.1)

Ask vchang as well as chuck for review to prevent my making another
stupid mistake ... Thanks!
Attachment #8513256 - Attachment description: Bug1083449.patch → Bug 1083449 (the REAL patch!)
Attachment #8513256 - Flags: review?(vchang)
Attachment #8513256 - Flags: review?(chulee)
Comment on attachment 8513256 [details] [diff] [review]
Bug 1083449 (the REAL patch! for v2.1)

Review of attachment 8513256 [details] [diff] [review]:
-----------------------------------------------------------------

Nice Job!
Attachment #8513256 - Flags: review?(chulee) → review+
(In reply to Henry Chang [:henry] from comment #27)
> (In reply to Tapas[:tkundu on #b2g/gaia/memshrink/gfx] (always NI me) from
>  .....
> Hmmm, were you doing gaia-ui-test? (from "GaiaDataLayer.disableWiFi")?
> If yes, I would expect we can reproduce it and gdb it! It would be helpful!

I wish I can do that . But its not easy to do this in our current stability setup. But I am landing your patch from Comment 31 and I will confirm you asap.
Attachment #8513256 - Flags: review?(vchang) → review+
(Assignee)

Comment 35

4 years ago
(In reply to Tapas[:tkundu on #b2g/gaia/memshrink/gfx] (always NI me) from comment #33)
> (In reply to Henry Chang [:henry] from comment #27)
> > (In reply to Tapas[:tkundu on #b2g/gaia/memshrink/gfx] (always NI me) from
> >  .....
> > Hmmm, were you doing gaia-ui-test? (from "GaiaDataLayer.disableWiFi")?
> > If yes, I would expect we can reproduce it and gdb it! It would be helpful!
> 
> I wish I can do that . But its not easy to do this in our current stability
> setup. But I am landing your patch from Comment 31 and I will confirm you
> asap.


The patch has gotten reviewed. I am going to flag checkin-needed first
since it's definitely a necessary patch no matter it fixes this crash or not.
Thanks :)
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
(Assignee)

Comment 37

4 years ago
The most recent checkin-needed is for attachment 8513305 [details] [diff] [review].
The try run result can be found in comment 36.
https://hg.mozilla.org/mozilla-central/rev/081e3f27b664
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S8 (7Nov)
Please request b2g34 approval on whatever needs to land on v2.1 here.
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → fixed
status-firefox34: --- → wontfix
status-firefox35: --- → wontfix
status-firefox36: --- → fixed
Flags: needinfo?(hchang)
We are not seeing this issue anymore in FFOS 2.1 after landing fix from Comment 31
Flags: needinfo?(tkundu)
(Assignee)

Updated

4 years ago
Attachment #8513256 - Attachment description: Bug 1083449 (the REAL patch!) → Bug 1083449 (the REAL patch! for v2.1)
Flags: needinfo?(hchang)
(Assignee)

Comment 43

4 years ago
Comment on attachment 8513256 [details] [diff] [review]
Bug 1083449 (the REAL patch! for v2.1)

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Wifi
User impact if declined: B2G will crash while repeatedly enable/disable wifi
Testing completed: Yes
Risk to taking this patch (and alternatives if risky): No
String or UUID changes made by this patch: No
Attachment #8513256 - Flags: approval-mozilla-b2g34?

Updated

4 years ago
Attachment #8513256 - Flags: approval-mozilla-b2g34? → approval-mozilla-b2g34+
(Assignee)

Comment 46

4 years ago
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #45)
> Backed out for B2G debug cpptest segfaults.
> https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/dc11764d6c3f
> 
> https://treeherder.mozilla.org/ui/logviewer.html#?job_id=24883&repo=mozilla-
> b2g34_v2_1

Hi Ryan,

Was the segfaults caused by only this patch or a bunch of patches?
Thanks!
Yours was the only one that needed backing out for them to go away.
Unable to verify this bug and its dependency as it is a back-end issue.
QA Whiteboard: [QAnalyst-Triage?][QAnalyst-verify-]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][QAnalyst-verify-] → [QAnalyst-Triage+][QAnalyst-verify-]
Flags: needinfo?(ktucker)
(Assignee)

Comment 49

4 years ago
According to the following warning message:

09:34:37     INFO -  [1093] WARNING: XPCOM objects created/destroyed from static ctor/dtor: file ../../../gecko/xpcom/base/nsTraceRefcnt.cpp, line 148
09:34:37     INFO -  Segmentation fault

I suspect it's due to WifiProxyService or NetworkWorker is created 
in the static ctor, which caused uninitialized mutex to be referenced.
Figuring out how to run cpp unit test locally to verify my guess.
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #45)
> Backed out for B2G debug cpptest segfaults.
> https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/dc11764d6c3f
> 
> https://treeherder.mozilla.org/ui/logviewer.html#?job_id=24883&repo=mozilla-
> b2g34_v2_1

We are again hitting same issue after backing our this change :(
Status: RESOLVED → REOPENED
Flags: needinfo?(hchang)
Resolution: FIXED → ---
(Assignee)

Comment 51

4 years ago
(In reply to Tapas[:tkundu on #b2g/gaia/memshrink/gfx] (always NI me) from comment #50)
> (In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #45)
> > Backed out for B2G debug cpptest segfaults.
> > https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/dc11764d6c3f
> > 
> > https://treeherder.mozilla.org/ui/logviewer.html#?job_id=24883&repo=mozilla-
> > b2g34_v2_1
> 
> We are again hitting same issue after backing our this change :(

It's totally expected :(

I am striving on getting the patch pass the cpp unit test on 2.1
to land it back. Please waiting for my good news! Thanks!
Flags: needinfo?(hchang)
Observed on: 

Device: msm8226
Gonk Version: AU_LINUX_GECKO_B2G_KK_2.0.01.04.00.114.129
Moz BuildID: 20141105001204
B2G Version: 2.1
Gecko Version: 34.0
Gaia:  http://git.mozilla.org/?p=releases/gaia.git;a=commit;h=154da5e17029a51002d5d9b7df39563d509edde6
Gecko: http://git.mozilla.org/?p=releases/gecko.git;a=commit;h=3b31ab3658aee0c3dc459f25bc10cb28826f8876
Patches: bug 1089706, bug 1070431, bug 1093278
(Assignee)

Comment 53

4 years ago
New findings:

Have run cpp unit test locally and found it crashed on destroying 
static/global object, which is very likely the static mozilla::Mutex.
But I cannot explain why it doesn't occur on release build and m-c.

I/DEBUG   (   37):          #00  pc 003a2358  /data/local/tests/cppunittests/b/libxul.so
I/DEBUG   (   37):          #01  pc 003a2410  /data/local/tests/cppunittests/b/libxul.so
I/DEBUG   (   37):          #02  pc 0033e8dc  /data/local/tests/cppunittests/b/libxul.so
I/DEBUG   (   37):          #03  pc 0001ec02  /system/lib/libc.so (__cxa_finalize)
I/DEBUG   (   37):          #04  pc 0001ef9c  /system/lib/libc.so (exit)
I/DEBUG   (   37):          #05  pc 0001ef9c  /system/lib/libc.so (exit)
I/DEBUG   (   37):          #06  pc 0001ef9c  /system/lib/libc.so (exit)
I/DEBUG   (   37):          #07  pc 0001ef9c  /system/lib/libc.so (exit)
(Assignee)

Comment 54

4 years ago
Created attachment 8520393 [details] [diff] [review]
Bug1083449.patch (fixes cppunittest crash)

This patch provides basic idea of how to fix the cppunittest crash. Just attach first not fully tested yet.
(Assignee)

Comment 55

4 years ago
Created attachment 8520460 [details] [diff] [review]
Bug1083449.patch (to fix cppunittest crash)
Attachment #8520393 - Attachment is obsolete: true
(Assignee)

Comment 56

4 years ago
Created attachment 8520467 [details] [diff] [review]
Bug1083449.patch (to fix cppunittest crash, for 2.1)

Hi Vincent, Fabrice,

Could you please review this patch regarding using a static bare PRLock
instead of static mozilla::Mutex? I found the destruction of static 
mozilla::Mutex would cause the cppunittest to crash because of the 
XPCOM shutdown timing issue.

I am not sure if my current approach is the best one but it does fix the
and does protect potential concurrent ifc_* function calls. Do you have any
idea? Thanks!
Attachment #8520460 - Attachment is obsolete: true
Attachment #8520467 - Flags: review?(vchang)
Attachment #8520467 - Flags: review?(fabrice)
(Assignee)

Updated

4 years ago
Attachment #8520467 - Attachment description: Bug1083449.patch (to fix cppunittest crash) → Bug1083449.patch (to fix cppunittest crash, for 2.1)
(Assignee)

Comment 57

4 years ago
Hi Tapas,

Could you please try the attachment 8520467 [details] [diff] [review] out? Thanks!
Flags: needinfo?(tkundu)
(In reply to Henry Chang [:henry] from comment #57)
> Hi Tapas,
> 
> Could you please try the attachment 8520467 [details] [diff] [review] out?
> Thanks!

We have asked our test team to confirm. We will update asap. Thanks for your help
(In reply to Henry Chang [:henry] from comment #57)
> Hi Tapas,
> 
> Could you please try the attachment 8520467 [details] [diff] [review] out?
> Thanks!

Is this patch also applicable for v2.0 ?
Flags: needinfo?(hchang)
Attachment #8520467 - Flags: review?(fabrice) → review+
(Assignee)

Comment 60

4 years ago
Hi Ryan,

How can I have a try run on v2_1? Is it okay to simply "push -f try"?
Thanks!
Flags: needinfo?(hchang) → needinfo?(ryanvm)
Yes, any tests that would normally run on b2g34_v2_1 should run fine on Try. Your simplest option is probably just going with |try: -b do -p emulator,emulator-jb,emulator-kk -u all -t none|, which I would expect to work fine.
Flags: needinfo?(ryanvm)
(Assignee)

Comment 62

4 years ago
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #61)
> Yes, any tests that would normally run on b2g34_v2_1 should run fine on Try.
> Your simplest option is probably just going with |try: -b do -p
> emulator,emulator-jb,emulator-kk -u all -t none|, which I would expect to
> work fine.

Thanks Ryan! I was afraid of pushing too many commits to try at first :p
I will give it try. Thanks!
(Assignee)

Comment 63

4 years ago
(In reply to Tapas[:tkundu on #b2g/gaia/memshrink/gfx] (always NI me) from comment #59)
> (In reply to Henry Chang [:henry] from comment #57)
> > Hi Tapas,
> > 
> > Could you please try the attachment 8520467 [details] [diff] [review] out?
> > Thanks!
> 
> Is this patch also applicable for v2.0 ?

Not directly applicable since the location of source files are different.
(Assignee)

Comment 64

4 years ago
The cpp unit test passed!

https://tbpl.mozilla.org/?tree=Try&rev=16843bbd1967
Comment on attachment 8520467 [details] [diff] [review]
Bug1083449.patch (to fix cppunittest crash, for 2.1)

Review of attachment 8520467 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thank you.
Attachment #8520467 - Flags: review?(vchang) → review+
(In reply to Henry Chang [:henry] from comment #63)
> (In reply to Tapas[:tkundu on #b2g/gaia/memshrink/gfx] (always NI me) from
> comment #59)
> > (In reply to Henry Chang [:henry] from comment #57)
> > > Hi Tapas,
> > > 
> > > Could you please try the attachment 8520467 [details] [diff] [review] out?
> > > Thanks!
> > 
> > Is this patch also applicable for v2.0 ?
> 
> Not directly applicable since the location of source files are different.

Do you think that this issue can also happen in v2.0 because of this bug ? If so then please land a patch for v2.0 too . 

Thanks a lot for your help
Flags: needinfo?(tkundu)
Flags: needinfo?(tkundu)
Flags: needinfo?(hchang)
(Assignee)

Comment 67

4 years ago
(In reply to Tapas[:tkundu on #b2g/gaia/memshrink/gfx] (always NI me) from comment #66)
> (In reply to Henry Chang [:henry] from comment #63)
> > (In reply to Tapas[:tkundu on #b2g/gaia/memshrink/gfx] (always NI me) from
> > comment #59)
> > > (In reply to Henry Chang [:henry] from comment #57)
> > > > Hi Tapas,
> > > > 
> > > > Could you please try the attachment 8520467 [details] [diff] [review] out?
> > > > Thanks!
> > > 
> > > Is this patch also applicable for v2.0 ?
> > 
> > Not directly applicable since the location of source files are different.
> 
> Do you think that this issue can also happen in v2.0 because of this bug ?
> If so then please land a patch for v2.0 too . 
> 
> Thanks a lot for your help

I think it will. I will prepare a patch first and land it until
your latest test result. Thanks!
Flags: needinfo?(hchang)
(Assignee)

Comment 68

4 years ago
Created attachment 8522786 [details] [diff] [review]
Bug1083449.patch (to fix cppunittest crash, for 2.0)
(Assignee)

Comment 69

4 years ago
Hi Tapas,

Do you have any update? I will land the patch (both 2.0/2.1) 
once upon it works fine from your side. Thanks!
(In reply to Henry Chang [:henry] from comment #69)
> Hi Tapas,
> 
> Do you have any update? I will land the patch (both 2.0/2.1) 
> once upon it works fine from your side. Thanks!

Hi Henry,

We are still waiting for update from test team.
(In reply to Tapas[:tkundu on #b2g/gaia/memshrink/gfx] (always NI me) from comment #70)
> (In reply to Henry Chang [:henry] from comment #69)
> > Hi Tapas,
> > 
> > Do you have any update? I will land the patch (both 2.0/2.1) 
> > once upon it works fine from your side. Thanks!
> 
> Hi Henry,
> 
> We are still waiting for update from test team.

We still waiting updates from Test team. Please land this patch for both v2.0 and v2.1 if you are "OK" with it.

We will create new bug if we see this issue again .
Flags: needinfo?(tkundu) → needinfo?(hchang)
(Assignee)

Comment 72

4 years ago
Comment on attachment 8520467 [details] [diff] [review]
Bug1083449.patch (to fix cppunittest crash, for 2.1)

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Wifi
User impact if declined: Toggling wifi would cause b2g to crash.
Testing completed: Yes
Risk to taking this patch (and alternatives if risky): No
String or UUID changes made by this patch: No
Flags: needinfo?(hchang)
Attachment #8520467 - Flags: approval-mozilla-b2g34?
(Assignee)

Comment 73

4 years ago
(In reply to Tapas[:tkundu on #b2g/gaia/memshrink/gfx] (always NI me) from comment #71)
> (In reply to Tapas[:tkundu on #b2g/gaia/memshrink/gfx] (always NI me) from
> comment #70)
> > (In reply to Henry Chang [:henry] from comment #69)
> > > Hi Tapas,
> > > 
> > > Do you have any update? I will land the patch (both 2.0/2.1) 
> > > once upon it works fine from your side. Thanks!
> > 
> > Hi Henry,
> > 
> > We are still waiting for update from test team.
> 
> We still waiting updates from Test team. Please land this patch for both
> v2.0 and v2.1 if you are "OK" with it.
> 
> We will create new bug if we see this issue again .

Got it! By the way, are you also testing the patch on 2.0?
Thanks.
(In reply to Henry Chang [:henry] from comment #73)
> (In reply to Tapas[:tkundu on #b2g/gaia/memshrink/gfx] (always NI me) from
> comment #71)
> > (In reply to Tapas[:tkundu on #b2g/gaia/memshrink/gfx] (always NI me) from
> > comment #70)
> > > (In reply to Henry Chang [:henry] from comment #69)
> > > > Hi Tapas,
> > > > 
> > > > Do you have any update? I will land the patch (both 2.0/2.1) 
> > > > once upon it works fine from your side. Thanks!
> > > 
> > > Hi Henry,
> > > 
> > > We are still waiting for update from test team.
> > 
> > We still waiting updates from Test team. Please land this patch for both
> > v2.0 and v2.1 if you are "OK" with it.
> > 
> > We will create new bug if we see this issue again .
> 
> Got it! By the way, are you also testing the patch on 2.0?
> Thanks.

No . Please also land this patch in v2.0 if you are "OK" with it .
Flags: needinfo?(hchang)

Updated

4 years ago
Attachment #8520467 - Flags: approval-mozilla-b2g34? → approval-mozilla-b2g34+
Henry this needs to land on central still, so NI you to help with that.
(Assignee)

Comment 76

4 years ago
(In reply to bhavana bajaj [:bajaj] from comment #75)
> Henry this needs to land on central still, so NI you to help with that.

Since the threading model has changed on central, this patch is not
needed anymore and only applicable for 2.0/2.1. Bug 1098192 is tracking 
this. Thanks!
Flags: needinfo?(hchang)
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
(Assignee)

Comment 77

4 years ago
checkin-needed for Attachment 8520467 [details] [diff] (patch for 2.1). 2.0 is still under testing. Thanks!
(Assignee)

Comment 78

4 years ago
Comment on attachment 8522786 [details] [diff] [review]
Bug1083449.patch (to fix cppunittest crash, for 2.0)

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Wifi
User impact if declined: Toggling Wifi would cause b2g to crash
Testing completed: Yes
Risk to taking this patch (and alternatives if risky): No
String or UUID changes made by this patch: No
Attachment #8522786 - Flags: approval-mozilla-b2g30?
Comment on attachment 8522786 [details] [diff] [review]
Bug1083449.patch (to fix cppunittest crash, for 2.0)

[Triage Comment]

Switching the approval to b2g32.
Attachment #8522786 - Flags: approval-mozilla-b2g30? → approval-mozilla-b2g32+

Updated

4 years ago
blocking-b2g: 2.1+ → 2.0+
*Please* don't reopen bugs for release branch backouts. We have uplift bug queries that depend on bug resolution and doing so causes uplifts to be missed (as happened here). Status flags are the correct way to track uplifts.
Flags: needinfo?(tkundu)
Attachment #8512462 - Attachment is obsolete: true
Attachment #8513256 - Attachment is obsolete: true
https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/c5a3f8d101d4
https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: affected → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #80)
> *Please* don't reopen bugs for release branch backouts. We have uplift bug
> queries that depend on bug resolution and doing so causes uplifts to be
> missed (as happened here). Status flags are the correct way to track uplifts.

Thanks for clarifying :)
Flags: needinfo?(tkundu)
You need to log in before you can comment on or make changes to this bug.