On Linux using Firefox 33 the menubar is dark on bright-text lightweight themes (LWT)

VERIFIED FIXED in Firefox 34

Status

()

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: tim, Assigned: Gijs)

Tracking

({regression})

32 Branch
Firefox 36
x86
Linux
Points:
2
Dependency tree / graph
Bug Flags:
firefox-backlog +
in-testsuite -
qe-verify +

Firefox Tracking Flags

(firefox33 wontfix, firefox34+ verified, firefox35 verified, firefox36 verified)

Details

Attachments

(4 attachments)

Posted image firefox33-0.png
User Agent: Mozilla/5.0 (X11; Linux i686; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

Upgraded from Firefox version 32.0.3 32 bit version for Linux to Firefox version 33.0 32 bit version for linux


Actual results:

The Firefox menu font colour is always black, so when you have a theme with a dark colour they menu items can not be seen (Theme being used is Blue Mozilla Firefox, however the same is true for any dark coloured theme.) This issue does not affect the Firefox version 33.0 32 bit version for Windows.


Expected results:

In the Firefox version 32.0.3 32 bit version for Linux the menu font changes to white with the same theme (Blue Mozilla Firefox, but also confirmed with other dark coloured themed.)
Posted image firefox32-0-3.png
Showing it working correctly in Firefox version 32.0.3 32 bit for Linux
Dão, do you have ideas what broke here?
Flags: needinfo?(dao)
Component: Untriaged → Theme
Summary: Firefox 33.0 Linux 32 bit version Menu font is always black colour → Firefox 33.0 Linux 32 bit version menubar is dark on bright-text lightweight themes (LWT)
Maybe caused by bug 1037411? I can't seem to reproduce this in a recent nightly build, though. Is this broken on 34 beta?
Flags: needinfo?(dao)
(In reply to Dão Gottwald [:dao] from comment #3)
> Maybe caused by bug 1037411? I can't seem to reproduce this in a recent
> nightly build, though. Is this broken on 34 beta?

I can repro on both nightly and 34 beta using the space fantasy lwt that we ship.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 1037411
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
[Tracking Requested - why for this release]: prominently user-visible regression

Marco, I picked this up because ^ and it was small; I'm waiting for feedback for bug 1074520, and I'm still investigating the other Linux bug I have. I'll have a patch for the yosemite one shortly.
Iteration: --- → 36.1
Points: --- → 2
Flags: qe-verify+
Flags: needinfo?(mmucci)
Flags: in-testsuite-
Flags: firefox-backlog+
Added to IT 36.1
Flags: needinfo?(mmucci)
Gijs - This looks like a trivial fix. We'll take it in 34 when it's ready. We are likely spinning a 33.0.1 point release on Monday. Do you want to propose this as a ride along?
Flags: needinfo?(gijskruitbosch+bugs)
Comment on attachment 8507235 [details] [diff] [review]
don't set color for menubar when lwtheme is in use,

Looks like you could just add color: inherit to the existing menubar:-moz-lwtheme, toolbar:-moz-lwtheme rule. I'd prefer that.
Attachment #8507235 - Flags: review?(dao) → review+
(In reply to Lawrence Mandel [:lmandel] from comment #9)
> Gijs - This looks like a trivial fix. We'll take it in 34 when it's ready.
> We are likely spinning a 33.0.1 point release on Monday. Do you want to
> propose this as a ride along?

I'm not comfortable enough that this won't regress things (esp. considering the thing that regressed this seemed trivially simple and did regress something) to want to land this on release before Monday with almost no baking elsewhere. I also think the number of people affected (using dark lightweight themes on Linux, with the menubar turned on) is low enough that this can wait, at least until November.

(In reply to Dão Gottwald [:dao] from comment #10)
> Comment on attachment 8507235 [details] [diff] [review]
> don't set color for menubar when lwtheme is in use,
> 
> Looks like you could just add color: inherit to the existing
> menubar:-moz-lwtheme, toolbar:-moz-lwtheme rule. I'd prefer that.

Done.

remote:   https://hg.mozilla.org/integration/fx-team/rev/59ee437c92c6
Flags: needinfo?(gijskruitbosch+bugs)
(In reply to :Gijs Kruitbosch from comment #11)
> I'm not comfortable enough that this won't regress things (esp. considering
> the thing that regressed this seemed trivially simple and did regress
> something) to want to land this on release before Monday with almost no
> baking elsewhere. I also think the number of people affected (using dark
> lightweight themes on Linux, with the menubar turned on) is low enough that
> this can wait, at least until November.

This is exactly why I ask. Thank you for taking a conservative approach.
https://hg.mozilla.org/mozilla-central/rev/59ee437c92c6
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 36
Approval Request Comment
[Feature/regressing bug #]: bug 1037411
[User impact if declined]: dark lightweight themes have an unreadable menubar on Linux
[Describe test coverage new/current, TBPL]: nope :-(
[Risks and why]: more bugs with menubar readability? Fairly low, should only affect linux users with the menubar turned on and using lightweight themes
[String/UUID change made/needed]: nope
Attachment #8509434 - Flags: review+
Attachment #8509434 - Flags: approval-mozilla-beta?
Attachment #8509434 - Flags: approval-mozilla-aurora?
Comment on attachment 8509434 [details] [diff] [review]
1083668-landed.patch

Beta+
Aurora+
Attachment #8509434 - Flags: approval-mozilla-beta?
Attachment #8509434 - Flags: approval-mozilla-beta+
Attachment #8509434 - Flags: approval-mozilla-aurora?
Attachment #8509434 - Flags: approval-mozilla-aurora+
QA Contact: camelia.badau
Duplicate of this bug: 1087800
Summary: Firefox 33.0 Linux 32 bit version menubar is dark on bright-text lightweight themes (LWT) → On Linux using Firefox 33 the menubar is dark on bright-text lightweight themes (LWT)
Do we take things like this on alder? Single rule of CSS, has baked for a while now, and people file dupes...
Flags: needinfo?(dolske)
Also broken is SeaMonkey 2.30 on Linux. I reported that here, however never updated the bug description to specify Firefox AND SeaMonkey.

https://bugzilla.mozilla.org/show_bug.cgi?id=1087800
(In reply to :Gijs Kruitbosch from comment #18)
> Do we take things like this on alder? Single rule of CSS, has baked for a
> while now, and people file dupes...

No, alder was only for 11/9 release staging (and merged to mozilla-release yesterday, so it's basically dead now). You could nom it lest there be another round of builds or another 33.1.x, but at this point I'd be inclined to just let it ride with 34's release in a few weeks. Especially since this took 3 months to be noticed.
Flags: needinfo?(dolske)
Verified fixed on Ubuntu 12.04 32-bit using the Space Fantasy lwtheme on:
- Latest Nightly, build ID: 20141116030212;
- Firefox 35.0a2, build ID: 20141116004002;
- Firefox 34 beta 9, build ID: 20141114133026.
Status: RESOLVED → VERIFIED
QA Contact: camelia.badau → cornel.ionce
Has this also been addressed in SeaMonkey 2.30 on Linux?
I noticed this issue resolved in at least Firefox. Official Mozilla Firefox 34.0.5 via UbuntuZilla.

SeaMonkey has not rev'ed yet, so cannot speak if it has been resolved there as well or not.
As of the Official SeaMonkey 2.31 via UbuntuZilla, I am please to report that this bug has been resolved in both Firefox and SeaMonkey. Thank you very much! :-)
No longer depends on: 1100350
You need to log in before you can comment on or make changes to this bug.