Firefox OS refuses to build with make 4.0 (Fedora 21 alpha, Ubuntu 14.10)

RESOLVED DUPLICATE of bug 1031593

Status

defect
RESOLVED DUPLICATE of bug 1031593
5 years ago
5 years ago

People

(Reporter: brion, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140918134241

Steps to reproduce:

On Fedora 21 alpha:

$ ./config.sh flatfish
$ GAIA_DEVICE_TYPE=tablet B2G_SYSTEM_APPS=1 B2G_UPDATER=1 ./build.sh



Actual results:

build/core/main.mk:45: ********************************************************************************
build/core/main.mk:46: *  You are using version 4.0 of make.
build/core/main.mk:47: *  Android can only be built by versions 3.81 and 3.82.
build/core/main.mk:48: *  see https://source.android.com/source/download.html
build/core/main.mk:49: ********************************************************************************
build/core/main.mk:50: *** stopping.  Stop.



Expected results:

Should either work, or die out in config.sh with a version check if it really matters.
This happens on Ubuntu 14.10, too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Firefox OS refuses to build with make 4.0 (Fedora 21 alpha) → Firefox OS refuses to build with make 4.0 (Fedora 21 alpha, Ubuntu 14.10)
( http://bradb.net/building-firefox-os-for-the-flatfish-tablet-from-ubuntu/ has some steps to work around this on Ubuntu 14.10, FWIW.)
There is an apparently abandoned patch here with commentary that suggests make 4.0 works if you remove the check:
 
https://gerrit.paranoidandroid.co/#/c/108/

I have no clue as to why this was abandoned though.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1031593
You need to log in before you can comment on or make changes to this bug.