Closed Bug 1084527 Opened 8 years ago Closed 8 years ago

Reference to undefined property child.qName

Categories

(Chat Core :: XMPP, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: aleth, Assigned: aleth)

References

Details

Attachments

(1 file)

resource:///modules/xmpp-xml.jsm, line 216: ReferenceError: reference to undefined property child.qName

There are two possible approaches to this
1) check ("qname" in child)
2) throw if an XML node is created without a valid qName

Not sure off-hand which is correct.
Duplicate of this bug: 955715
Attached patch qname.diffSplinter Review
This happens for text nodes, which have no qName.
Assignee: nobody → aleth
Status: NEW → ASSIGNED
Attachment #8507501 - Flags: review?(clokep)
Comment on attachment 8507501 [details] [diff] [review]
qname.diff

Review of attachment 8507501 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks! Is anything here worth adding comments to?
Attachment #8507501 - Flags: review?(clokep) → review+
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/ce8c62cb7b7c
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 1.6
You need to log in before you can comment on or make changes to this bug.