treeherder's bugzilla comments for intermittent orange don't include the build time

RESOLVED FIXED

Status

Tree Management
Treeherder
P2
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: dbaron, Assigned: emorley)

Tracking

({regression})

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
treeherder's bugzilla comments for intermittent orange don't include the time that the build started.  This is generally useful when tracking down a new intermittent orange, since the starring of builds isn't necessarily in the order they happened, so we can use the timestamps to find the one that was actually the first one.

It seems to me that this timestamp could replace the "submit_timestamp" that's currently in treeherder's bugzilla comments, since that timestamp matches the timestamp of the bugzilla comment itself.

See, for example, bug 1084118, which is where I wanted this data.
(Reporter)

Comment 1

3 years ago
(And this is a regression relative to TBPL, which included the time on the third line; see bug 1084118 comment 3, which was made from TBPL.)
(Assignee)

Comment 2

3 years ago
Agreed.

I think the reason Mauro implemented it like this, is that Treeherder now supports classifying failures before the job has completed - or even started (to reduce the whac-a-mole effect when 5 pushes in a row are known to be broken) - and these jobs don't have a start time. However the correct workaround is just to either display "Not started" in the bug comment, or omit the line entirely.
Blocks: 1059400, 1048354
Priority: -- → P2
(Assignee)

Updated

3 years ago
No longer blocks: 1059400
Keywords: regression
(Assignee)

Updated

3 years ago
Assignee: nobody → emorley
<3

FWIW, I'm not sure that the reasoning in comment 2 really holds up anyway. When are we ever going to pre-star an intermittent? I don't think we've been upgraded to ESP quite yet :P

Realistically, pre-starring is basically exclusively for bustage situations where TH isn't going to be commenting in a bug anyway.
(Assignee)

Comment 4

3 years ago
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #3)
> FWIW, I'm not sure that the reasoning in comment 2 really holds up anyway.
> When are we ever going to pre-star an intermittent? I don't think we've been
> upgraded to ESP quite yet :P
> 
> Realistically, pre-starring is basically exclusively for bustage situations
> where TH isn't going to be commenting in a bug anyway.

Unlike TBPL, treeherder sends bug comments for any arbitrary bug number entered (a good thing), and whilst most mass-bustage scenarios (ie the times when someone would pre-star) won't have a bug number, some will - eg infra.

That said, it's very much an edge case and shouldn't block this bug, especially given how easy it is to work around it.
I generally don't use the bug number field for infra issues explicitly to avoid spamming the bug.
(Assignee)

Updated

3 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 6

3 years ago
Created attachment 8548896 [details] [review]
Use start_time instead of classification time in bug comments

Previously classifying failures with a bug number would add a comment to the bug that listed the datetime of classification. However this is redundant, since it's virtually the same as the datetime of the bug comment itself. Instead, it's more useful to list the job start time.

Only classifications for completed jobs are submitted to Bugzilla, so we do not need to add handling for pending jobs, that do not have a start time.
Attachment #8548896 - Flags: review?(mdoglio)
(Assignee)

Comment 7

3 years ago
(In reply to Ed Morley [:edmorley] from comment #6)
> Only classifications for completed jobs are submitted to Bugzilla, so we do
> not need to add handling for pending jobs, that do not have a start time.

https://github.com/mozilla/treeherder-service/blob/f5aa1d3a9fd16e59b89983952aace3e0cfc6287d/treeherder/model/derived/jobs.py#L589
Attachment #8548896 - Flags: review?(mdoglio) → review+

Comment 8

3 years ago
Commit pushed to master at https://github.com/mozilla/treeherder-service

https://github.com/mozilla/treeherder-service/commit/33475f12d3fe48280fed1db324d67bd0deb4fa34
Bug 1085100 - Use start_time instead of classification time in bug comments

Previously classifying failures with a bug number would add a comment to
the bug that listed the datetime of classification. However this is
redundant, since it's virtually the same as the datetime of the bug
comment itself. Instead, it's more useful to list the job start time.

Only classifications for completed jobs are submitted to Bugzilla, so we
do not need to add handling for pending jobs, that do not have a start
time.
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

3 years ago
In production :-)
You need to log in before you can comment on or make changes to this bug.