Awesome Bar: Firefox suggests "[keyword] – Search with [default search engine]" when entering "[keyword][space]", but loads the search engine related to the keyword

VERIFIED FIXED in Firefox 36

Status

()

Firefox
Location Bar
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: pollti, Unassigned)

Tracking

35 Branch
Firefox 36
x86_64
Windows 7
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +
in-testsuite +
qe-verify +

Firefox Tracking Flags

(firefox36 verified, firefox37 verified)

Details

(Reporter)

Description

3 years ago
When I have Google as default search engine and the keyword "y" for yahoo search in Firefox 35 or 36:
1. Enter "y " in the Awesome Bar.
   ➔ Firefox shows "y – Search with Google" as a first suggestion
2. When I press Enter or click on the suggestion, Firefox loads yahoo.com
So while confusing, this would the right behavior.

Search engine aliases only work if you are actually searching for something, like "y some thing", if you type just "y " there's nothing to search and thus we just do a plain search for "y" with the default engine.

The fact we open yahoo though is very wrong.
Blocks: 995091
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: qe-verify+
Flags: in-testsuite?
Flags: firefox-backlog+
(In reply to Marco Bonardo [::mak] (needinfo? me) from comment #1)
> So while confusing, this would the right behavior.

Not entirely... it's showing one thing, but doing the other. Bug 1067903 will fix this - it's an inconsistency between what docshell uri fixup does (old and broken, no longer wanted), and what our heuristics (new and shiny, intended implementation) does.
Depends on: 1067903
QA Contact: andrei.vaida
Blair, you said bug 1067903 was going to fix this. Did it do?
Flags: needinfo?(bmcbride)
well, looks like it did. now "y " searches in google like the special row suggests.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(bmcbride)
Resolution: --- → FIXED

Updated

3 years ago
Iteration: --- → 37.1
Target Milestone: --- → Firefox 36
Flags: in-testsuite? → in-testsuite+
Verified fixed on Nightly 37.0a1 (2014-12-01) and Aurora 36.0a2 (2014-12-01) using Windows 7 64-bit, Ubuntu 12.04 LTS 32-bit.
Status: RESOLVED → VERIFIED
status-firefox36: --- → verified
status-firefox37: --- → verified
You need to log in before you can comment on or make changes to this bug.