Closed Bug 1085386 Opened 5 years ago Closed 5 years ago

Back button does not close the settings page on Search Activity

Categories

(Firefox for Android Graveyard :: Search Activity, defect)

ARM
Android
defect
Not set

Tracking

(firefox35 verified, firefox36 verified, fennec35+)

VERIFIED FIXED
Firefox 36
Tracking Status
firefox35 --- verified
firefox36 --- verified
fennec 35+ ---

People

(Reporter: cos_flaviu, Assigned: Margaret)

References

Details

Attachments

(1 file)

Environment: 
Device: Asus Transformer Tab (Android 4.0.3);
Build: Nightly 36.0a1 (2014-10-20);

Steps to reproduce:
1. Launch Search Activity;
2. Go to settings;
3. Tap on the upper left button to exit settings;

Expected result:
Settings menu is closed and the Search Activity is displayed.

Actual result:
Nothing happens when tapping on the back button located on the upper left side of the screen.

Notes:
Not reproducible on Motorola Razr (Andrid 4.1.2).
Tablet issue? I couldn't reproduce this on my Nexus 5 here. I don't have a Nexus 7 on me today to try that out.
Reproduced on my Samsung Galaxy S2, Android 4.0.3.  margaret cannot reproduce on her Android 4.4.2 device.
tracking-fennec: --- → ?
tracking-fennec: ? → 35+
kbrosnan, can you see if there's a device in the SF office where this is happening?
Assignee: nobody → margaret.leibovic
Flags: needinfo?(kbrosnan)
Keywords: qawanted
I think liuche has this device.
Flags: needinfo?(kbrosnan) → needinfo?(liuche)
I couldn't reproduce on an SII 2.3, Nexus 4 4.4.4, or Galaxy Nexus 4.3.
Flags: needinfo?(liuche)
I was referring to the tablet with the attached keyboard that normally lives under your monitor. I believe that is the exact model of device that this bug was reported against.
It looks like newer versions of Android take care of this for you, while older versions don't. I tested this on a Transformer running 4.0.3 (where the bug was present) and an N4 running 4.4.4 (where the bug wasn't present), and they both work fine with this patch applied.
Attachment #8522575 - Flags: review?(liuche)
Comment on attachment 8522575 [details] [diff] [review]
Finish preference activity when hitting action bar "up" button

Review of attachment 8522575 [details] [diff] [review]:
-----------------------------------------------------------------

Great, lgtm!
Attachment #8522575 - Flags: review?(liuche) → review+
Comment on attachment 8522575 [details] [diff] [review]
Finish preference activity when hitting action bar "up" button

Approval Request Comment
[Feature/regressing bug #]: search activity
[User impact if declined]: "up" button in search activity preferences won't work on some devices
[Describe test coverage new/current, TBPL]: no automated tests, tested locally on multiple devices, just landed on m-c
[Risks and why]: low-risk, adds simple logic to handle a click on a button
[String/UUID change made/needed]: none
Attachment #8522575 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/885334253d3a
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 36
Attachment #8522575 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Can I pick up this issue?
(In reply to Sudhir from comment #12)
> Can I pick up this issue?

Hi Sudhir, this issue is fixed already (you can see that in the status field at the top of the bug), but there's a list of good starter bugs here if you're looking for something else to fix:
http://www.joshmatthews.net/bugsahoy/?mobile=1&simple=1
Hi Margaret,

I am looking for bugs to test in Firefox-Android. I have picked up this bug for fixed bugs. Please let me know if there any.
Keywords: qawanted
Verified as fixed in builds:
Firefox for Android 36.0a2 (2014-12-04);
Firefox for Android 35 Beta 1 build 2;

Device: Asus Transformer Tab (Android 4.0.3).
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.