Save All... attachments should remember the last saved folder name

RESOLVED FIXED in mozilla1.2alpha

Status

SeaMonkey
MailNews: Message Display
P2
normal
RESOLVED FIXED
17 years ago
13 years ago

People

(Reporter: Roy Yokoyama, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
mozilla1.2alpha
x86
Windows 2000
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
1) in mail/new, highlight on a mail with attachment
2 [details] [diff] [review]) right mouse button click on attachment and select "Save All.." context menu
3) Select a folder to save the attachments and click "OK"
4) repeat the step #2 again
5) mail/news should highlighted(retained) the last saved foldername.

Comment 1

16 years ago
Confirm that this happens with "Save As" as well.

Comment 2

16 years ago
*** Bug 109804 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Status: NEW → ASSIGNED
Keywords: nsbeta1

Comment 3

16 years ago
Dup of 115148? Since all save dialog files to remember last used directory.
accepting, I'm going to fix all these related bugs at once.
Target Milestone: --- → mozilla0.9.8
I've got a fix for part of this, but the fix for save all isn't working.  the 
file picker code isn't respecting when I call SetDisplayDirectory() before I do 
show.
Summary: Save All... attachments should remember the last saved folder name → Save & Save All... attachments should remember the last saved folder name
Created attachment 64090 [details] [diff] [review]
fix for this, and the compose attach scenario
I've landed my piece of code for this, r/sr=bienvenu.

these scenarios work:
saving a single attachment
saving a message as a file

but the "Save All Attachments" scenario doesn't work, as there is a folder
picker problem.

I'll keep this open until I fix that issue.
Depends on: 118916
Summary: Save & Save All... attachments should remember the last saved folder name → Save Attachme & Save Message As File & Save All... attachments should remember the last saved folder name
moving "Save Attachment & Save Message As File" to another bug, since they are
fixed.

only "Save All..." is broken, because of bug #118916
Summary: Save Attachme & Save Message As File & Save All... attachments should remember the last saved folder name → Save All... attachments should remember the last saved folder name
moving out to 1.0.1
Target Milestone: mozilla0.9.8 → mozilla1.0.1

Comment 10

16 years ago
If 118916 gets fixed we'll take any changes, if any, that we need for this.
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P2
Target Milestone: mozilla1.0.1 → mozilla1.2

Updated

16 years ago
QA Contact: esther → trix

Comment 11

16 years ago
This happens also when saving multiple images (from different windows) to disk.
This is very annoying.

Updated

16 years ago
Blocks: 122274
Keywords: nsbeta1+ → nsbeta1-
No longer blocks: 122274

Comment 12

16 years ago
*** Bug 156384 has been marked as a duplicate of this bug. ***
QA Contact: trix → stephend

Updated

15 years ago
Depends on: 89325

Comment 13

15 years ago
*** Bug 179034 has been marked as a duplicate of this bug. ***

Comment 14

14 years ago
On my 2004041809 this seems to work ?!
Product: Browser → Seamonkey

Comment 15

13 years ago
This was already fixed and is WFM. The pref messenger.save.dir is used for that.

see bug 115148 comment 43
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.