crash in nsINode::NodePrincipal() when called on null from XMLDocument::Load

RESOLVED DUPLICATE of bug 1084513

Status

()

--
critical
RESOLVED DUPLICATE of bug 1084513
4 years ago
4 years ago

People

(Reporter: lizzard, Assigned: reuseme2600)

Tracking

({crash, topcrash-win})

34 Branch
x86
Windows NT
crash, topcrash-win
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

This bug was filed from the Socorro interface and is 
report bp-0dad1d2c-9882-4cba-9bee-ab0482141019.
=============================================================

This is currently the #2 top crash for 34.0b1 with 2195/43672 crashes in the last 7 days.   While there is an older bug open associated with this signature, I think this is a different crash. 

From the crash times and the comments, it's clearly a startup crash that people are seeing once they update to 34.0b1. 


Crashing thread:

0 	xul.dll 	nsINode::NodePrincipal() 	content/base/public/nsINode.h
1 	xul.dll 	mozilla::dom::XMLDocument::Load(nsAString_internal const&, mozilla::ErrorResult&) 	dom/xml/XMLDocument.cpp
2 	xul.dll 	mozilla::dom::XMLDocumentBinding::load 	obj-firefox/dom/bindings/XMLDocumentBinding.cpp
3 	xul.dll 	mozilla::dom::GenericBindingMethod(JSContext*, unsigned int, JS::Value*) 	dom/bindings/BindingUtils.cpp
4 	mozjs.dll 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/vm/Interpreter.cpp
5 	mozjs.dll 	Interpret 	js/src/vm/Interpreter.cpp
[Tracking Requested - why for this release]:  Crashes are bad

This is a regression from bug 1057518.  In particular, this line:

  if (callingDoc->NodePrincipal() != principal) {

callingDoc can be null.
Assignee: nobody → tvyas
Blocks: 1057518
status-firefox34: --- → affected
status-firefox35: --- → affected
status-firefox36: --- → affected
tracking-firefox34: --- → ?
tracking-firefox35: --- → ?
tracking-firefox36: --- → ?
Summary: crash in nsINode::NodePrincipal() → crash in nsINode::NodePrincipal() when called on null from XMLDocument::Load

Comment 2

4 years ago
This is a dup

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1084513
Clearing flags on the dup.
status-firefox34: affected → ---
status-firefox35: affected → ---
status-firefox36: affected → ---
tracking-firefox34: ? → ---
tracking-firefox35: ? → ---
tracking-firefox36: ? → ---
You need to log in before you can comment on or make changes to this bug.