Closed Bug 1085787 Opened 5 years ago Closed 5 years ago

[Graphics] Control panel of the built-in media player is gone

Categories

(Core :: DOM: Core & HTML, defect, critical)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1086996
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected

People

(Reporter: ethan, Assigned: bholley)

References

Details

(Keywords: regression, smoketest, testcase)

Attachments

(1 file)

Device  : Flame
OS      : 2.2
Platform: 36.0a1

While a video is being played in the browser or youtube app, the control panel
is not shown by touching the screen.
Originally this bug only occurs in full screen mode (bug 1082330), it happens
in normal mode in recent gecko build.

I believe this is a regression bug.
My gecko build on 2014/10/17 doesn't have this issue.
Howie, please pay attention to this bug. Its consequence is critical.
Severity: normal → critical
Thanks Ethan. Nominate as blocking 2.2. qawanted to branch check.
blocking-b2g: --- → 2.2?
Keywords: qawanted
Sync to latest build, and I can also reproduce it. When I checked bug 1082330 last week, I didn't see this issue. Apparently this is a regression. Mark regressionwindow-wanted for tracking.
Branch check results:

This issue occurs on Flame 2.2 central.

Observed behavior: While playing an youtube video, tapping on the video does NOT show related controls.

Device: Flame 2.2 Master (shallow flash)
BuildID: 20141021064810
Gaia: 3ec94f448bb5c1c9c264896685c6ef77ab718c87
Gecko: fe1513fc09f6
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

--------

This issue does NOT occur on Flame 2.1 and Flame 2.0. Video controls are displayed when tapping on an actively playing youtube video.

Device: Flame 2.1 (shallow flash)
BuildID: 20141021065812
Gaia: f896470b694e3e76e39c5d48f1428b847a10b8fd
Gecko: 73aadf193e94
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0 (shallow flash)
BuildID: 20141020233820
Gaia: 63b56a7a7453726b9e12ad1afe02c68c83c5aeca
Gecko: 40584eecdc75
Version: 32.0 (2.0)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

--------

Looking for a regression window now.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawantedregression
QA Contact: pcheng
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
mozilla-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20141018001815
Gaia: 1daf2dadcd0d554c733661a4c0be1b82001e9da0
Gecko: acce1a807efb
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20141018020314
Gaia: 1daf2dadcd0d554c733661a4c0be1b82001e9da0
Gecko: 2681f9b134c2
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Gaia is the same.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=acce1a807efb&tochange=2681f9b134c2

Possibly caused by Bug 1081990?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Possibly caused by Bug 1081990? can you take a look Bobby?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(bobbyholley)
(In reply to Joshua Mitchell [:Joshua_M] from comment #6)
> Possibly caused by Bug 1081990? can you take a look Bobby?

At present, I don't have enough information.

Can someone attach a logcat? If the new security restrictions in bug 1081990 are involved, you should see an exception or warning indicating the JS file/line causing the error.
Reporter - can you attach a log-cat of this issue?
Flags: needinfo?(ettseng)
QA Contact: pcheng
See Also: → 1086265
Looks like around the time I start tapping the screen for the controls:

W/Browser ( 1250): [JavaScript Error: "Error: Permission denied to pass object to privileged code"]
E/GeckoConsole(  206): Content JS ERROR: Couldnt find app for: http://m.youtube.com/ 
E/GeckoConsole(  206):     at Places.prototype.takeScreenshot (app://system.gaiamobile.org/gaia_build_defer_index.js:196:51)
E/GeckoConsole(  206):     at Places.prototype.screenshotRequested/this.screenshotQueue[url]< (app://system.gaiamobile.org/gaia_build_defer_index.js:195:191)
Duplicate of this bug: 1086265
Assignee: nobody → bobbyholley
Flags: needinfo?(bobbyholley)
Android and B2G share the same #touchControls binding, so this is almost certainly going to be fixed by the same patch as bug 1086996.
Depends on: 1086996
Component: Graphics → DOM
Thanks, Bobby.
This bug is verified fixed on the latest Flame v2.2.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(ettseng)
Resolution: --- → DUPLICATE
Duplicate of bug: 1086996
blocking-b2g: 2.2? → ---
Keywords: qablocker
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.