Closed Bug 1086265 Opened 5 years ago Closed 5 years ago

Video controls don't show up anymore when playing video in browser (test_browser_play_youtube_video timeout)

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

x86
macOS
defect
Not set

Tracking

(b2g-v2.1 unaffected, b2g-v2.2 affected)

RESOLVED DUPLICATE of bug 1085787
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected

People

(Reporter: martijn.martijn, Unassigned)

References

()

Details

(Keywords: regression, smoketest, testcase, Whiteboard: [fromAutomation])

This is causing test_browser_play_youtube_video to timeout on jenkins:
http://jenkins1.qa.scl3.mozilla.com/job/flame-kk-319.b2g-inbound.ui.functional.smoke/656/testReport/test_browser_play_youtube_video/TestYouTube/test_play_youtube_video/

Steps to reproduce:
- Go to http://people.mozilla.org/~mwargers/tests/videos/atomicplayboy.webm
- It autoplays, now tap on the video

Expected result:
- Video controls should appear

Actual result:
- Video controls don't appear
This issue reproduces on YouTube also:

STR:
1 Open http://m.youtube.com/watch?v=5MzuGWFIfio
2. tap to play
3. Tap to see the controls while the video is playing

Actual:
3. the video controls are not visible

Expected:
3. The video controls should be visible


Environmental Variables:

Gaia-Rev        dc496d04907dd314f9736ff78bab3bd27156f79a
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/f2d7d694aae5
Build-ID        20141020160202
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141020.191459
FW-Date         Mon Oct 20 19:15:10 EDT 2014
Bootloader      L1TC00011880

It also reprodeces on V184

Reproducible manually: YES

Repro frequency: 5/5

Regresion range:

  Last good:
      Device firmware (date) 	18 Oct 2014 21:57:57
      Device firmware (incremental) 	eng.cltbld.20141019.005742
      Device firmware (release) 	4.4.2
      Device identifier 	flame
      Gaia date 	18 Oct 2014 21:08:10
      Gaia revision 	7b7ccc4101e0
      Gecko build 	20141018213312
      Gecko revision 	e4b851ca5f53
      Gecko version 	36.0a1

  First Bad:
      Device firmware (date) 	19 Oct 2014 02:13:54
      Device firmware (incremental) 	eng.cltbld.20141019.051344
      Device firmware (release) 	4.4.2
      Device identifier 	flame
      Gaia date 	19 Oct 2014 01:26:13
      Gaia revision 	0ca9aec27612
      Gecko build 	20141019015312
      Gecko revision 	5531858427a8
      Gecko version 	36.0a1


Attachments:
  Logcat:
   We are seeing in logcat:
     W/Browser ( 2927): [JavaScript Error: "Error: Permission denied to pass object to privileged code"]
Keywords: qablocker, qaurgent
Whiteboard: [fromAutomation]
blocking-b2g: --- → 2.2?
We are seeing this on Flame 2.2 with a repro rate of 5/5.
YouTube controls are not accessible when streaming in the browser.

Adding Smoketest keyword.

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141021040206
Gaia: 457a54fc3200b80e4f5e1cd3acaa062309230732
Gecko: 29fbfc1b31aa
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 36.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Note: This issue occurs on both v180 and v188 firmware base

Link to failed Smoketest case: https://moztrap.mozilla.org/manage/case/6073/

--------------------------------------------

This issue is NOT occurring in Flame 2.1.
YouTube controls are accessible normally in the browser.

Environmental Variables:
Device: Flame 2.1
BuildID: 20141021001201
Gaia: e458f5804c0851eb4e93c9eb143fe044988cecda
Gecko: ee86921a986f
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: smoketest
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: ckreinbring
See Bug 1085787 for Regression Window.
See Also: → 1085787
QA Contact: ckreinbring
This seems to be a duplicate of bug 1085787.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1085787
blocking-b2g: 2.2? → ---
Keywords: qablocker
You need to log in before you can comment on or make changes to this bug.