[Contacts] Wrong message opening contact list (pick activity) if no contacts are stored in the device.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: Javier de Prado, Assigned: Jose Manuel Cantera)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

unspecified
2.2 S4 (23jan)
x86
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master fixed)

Details

(Whiteboard: [Test-Run1][mobile app][p=1])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8508606 [details]
2014-10-21-13-14-11.png

Tested on flame (Gecko-b3429ef.Gaia-c6c6116) and fireE (firee-kk-v2.0-SW2E3-1)
Loop version: 1.1 , 2168965
English and Spanish.

STR:
1.- Clear contact list.
2.- Open loop app and push the icon to open contact list.

ACTUAL RESULT: (see attachment) Message "Cannot add to contact as your contact list is empty"
EXPECTED RESULT: Something like "Your contact list is empty"
We are showing a message from FxOS, as we are delegating to the OS the pick activity handling so I don't think it could have a simple solution... Anyway, setting ni to Borja to conform it.

Besides we are already in string freeze so no more string changes should be included for v1.1 branch.
Flags: needinfo?(borja.bugzilla)
Nothing to do here from our side, it lives in contacts app and it shows this message. Although we can know if the contact list is empty and could show the correct message instead of contacts app. But :) I don't know if the issue about Moz contacts permissions was fixed or not. And also, we cannot add new strings at that moment. Then sadly I can say that this won't be fixed for Loop, at least for version 1.1
Component: Gaia::Loop → Gaia::Contacts
Flags: needinfo?(borja.bugzilla)
(Assignee)

Updated

3 years ago
Assignee: nobody → jmcf
Target Milestone: --- → 2.1 S7 (24Oct)
(Assignee)

Updated

3 years ago
Target Milestone: 2.1 S7 (24Oct) → 2.1 S8 (7Nov)
(Assignee)

Updated

3 years ago
Summary: [Loop] Wrong message opening contact list if no contacts are stored in the device. → [Contacts] Wrong message opening contact list (pick activity) if no contacts are stored in the device.
Thanks a lot JM for taking care of this!
(Assignee)

Updated

3 years ago
Depends on: 1087979
Blocks: 1088993
Whiteboard: [Test-Run1][mobile app] → [Test-Run1][mobile app][p=1]
(Assignee)

Comment 4

3 years ago
As per bug 1087979 comment 5 we will need a new visual design in order to address this use case.
Flags: needinfo?(fshih)
Flags: needinfo?(cawang)
This bug is depending on bug 1087979. I'm waiting for the string suggestion (need to unify the string with other APP pickers) and Carol will provide the icon template for each APP so that Fang can work on Contact's one. Thanks!
Flags: needinfo?(cawang)
(Assignee)

Updated

3 years ago
Target Milestone: 2.1 S8 (7Nov) → 2.1 S9 (21Nov)

Comment 6

3 years ago
I'll work on the design once Carol provide the template. Thanks!
Flags: needinfo?(fshih)
Target Milestone: 2.1 S9 (21Nov) → 2.2 S1 (5dec)
Target Milestone: 2.2 S1 (5dec) → 2.2 S2 (19dec)
Duplicate of this bug: 1109672
(Assignee)

Comment 8

3 years ago
Fang,

Any news about this bug. It's been a long time since it was opened

thanks
Flags: needinfo?(fshih)
Hi, 

I recheck this bug and figure out that for the Loop case, we can simply display a confirm window which shows "No contacts in the contact list". We couldn't change the string because the string was freeze at that time. Can we fix it now?

Fang is working on the icon for "no contacts" in Contacts APP and it's not related to this bug. 

Thanks!
Flags: needinfo?(fshih)
(Assignee)

Comment 10

3 years ago
Created attachment 8548039 [details] [review]
GH PR

only L10N changes
Attachment #8548039 - Flags: review?(francisco)
Comment on attachment 8548039 [details] [review]
GH PR

Tiny, tiny nit, looking good.
Attachment #8548039 - Flags: review?(francisco) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
(Assignee)

Comment 12

3 years ago
https://github.com/mozilla-b2g/gaia/commit/78c37d1c5396613b6f5cfbdce6e28d01e80b406d
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

3 years ago
Comment on attachment 8548039 [details] [review]
GH PR

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Incorrect message shown to the user when no contacts present in the contacts list
[User impact] if declined: Medium, inconsistent app will be perceived
[Testing completed]: Yes 
[Risk to taking this patch] (and alternatives if risky): No risk patch
[String changes made]: https://github.com/mozilla-b2g/gaia/pull/27346/files#diff-a8e39eba575534c9d35a2b692b6550e1R28
Attachment #8548039 - Flags: approval-gaia-v2.2?
status-b2g-v2.2: --- → affected
status-b2g-master: --- → fixed
Keywords: checkin-needed
Target Milestone: 2.2 S2 (19dec) → 2.2 S4 (23jan)

Updated

3 years ago
Attachment #8548039 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/88e0235f6a956b6b93f34fe9fe200b2e4b291c36
status-b2g-v2.2: affected → fixed
This bug has been verified as "pass" on latest Nightly build of Flame v2.2 by the STR in Comment 0.

Actual results: Pushing the icon to open contact list in Loop, it prompts "No contacts in your Contacts list" as expected.
See attachment: verified_v2.2.png
Reproduce rate: 0/10


Device: Flame v2.2 (verified) 
Build ID               20150630162500
Gaia Revision          bd386f346eb1591fddbc84bf034b22700e7e2a58
Gaia Date              2015-06-30 15:53:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f16c1125b9d6
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150630.200238
Firmware Date          Tue Jun 30 20:02:49 EDT 2015
Bootloader             L1TC000118D0


Note:
I am unable to log in the account successfully in Loop on latest Flame master, then I can verify this bug.
status-b2g-v2.2: fixed → verified
Created attachment 8628095 [details]
verified_v2.2.png


Note:
Loop version is "1.1.1d".
QA Whiteboard: [MGSEI-Triage+]
(In reply to Shally from comment #15)

> I am unable to log in the account successfully in Loop on latest Flame
> master, then I can verify this bug.

That issue was reported in Bug 1168173 - Flame: Cannot authenticate using Firefox account
According to "https://bugzilla.mozilla.org/show_bug.cgi?id=1168173#c8", it is 'WON'T FIX' since we're not supporting the Hello Firefox OS application anymore, so change status to "verified".
Status: RESOLVED → VERIFIED

Updated

2 years ago
Resolution: FIXED → WONTFIX

Updated

2 years ago
Resolution: WONTFIX → FIXED
You need to log in before you can comment on or make changes to this bug.