Closed Bug 1086605 Opened 7 years ago Closed 7 years ago

JavaScript error: chrome://messenger/content/editContactOverlay.js, line 166: TypeError: Components.interfaces.nsIPopupBoxObject is undefined [TEST-UNEXPECTED-FAIL | test-message-header.js | test-message-header.js::test_address_book_switch_disabled_on_con

Categories

(Thunderbird :: Mail Window Front End, defect)

All
Linux
defect
Not set
major

Tracking

(thunderbird36 fixed)

RESOLVED FIXED
Thunderbird 36.0
Tracking Status
thunderbird36 --- fixed

People

(Reporter: ishikawa, Assigned: ishikawa)

References

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

During the |make mozmill| test run of locally built DEBUG BUILD
of C-C TB, I saw the following errors.

TEST-START | /REF-COMM-CENTRAL/comm-central/mail/test/mozmill/message-header/test-message-header.js | test_address_book_switch_disabled_on_contact_in_mailing_list
Step Pass: {"function": "controller.click()"}
JavaScript error: chrome://messenger/content/editContactOverlay.js, line 166: TypeError: Components.interfaces.nsIPopupBoxObject is undefined
Step Pass: {"function": "controller.click()"}
Test Failure: a != b: 'closed' != 'open'.
TEST-UNEXPECTED-FAIL | /REF-COMM-CENTRAL/comm-central/mail/test/mozmill/message-header/test-message-header.js | test-message-header.js::test_address_book_switch_disabled_on_contact_in_mailing_list

The culprit of the failure seems to be:
JavaScript error: chrome://messenger/content/editContactOverlay.js, line 166: TypeError: Components.interfaces.nsIPopupBoxObject is undefined

I don't know why but |nsIPopupBoxObject| seems to be gone from 
the current M-C, and C-C ???

I could see the remnant of its former existence.
For example:
http://mxr.mozilla.org/mozilla/source/layout/xul/base/public/nsIPopupBoxObject.idl

but I don't find nsIPopupBoxObject.idl in C-C or M-C any more.

I still find it in comm-aurora, but not in mozilla-aurora.
Mozilla-beta has it.

What gives?

TIA
> I could see the remnant of its former existence.
> For example:
> http://mxr.mozilla.org/mozilla/source/layout/xul/base/public/
> nsIPopupBoxObject.idl
> 
> but I don't find nsIPopupBoxObject.idl in C-C or M-C any more.
> 
> I still find it in comm-aurora, but not in mozilla-aurora.
> Mozilla-beta has it.
> 
> What gives?

This is Bug 979835 - Port BoxObject to WebIDL

165     this.panel.popupBoxObject
166         .setConsumeRollupEvent(Components.interfaces
167                                          .nsIPopupBoxObject.ROLLUP_CONSUME);

As a wild guess (I am not an expert in this) try:

this.panel.boxObject.setConsumeRollupEvent(PopupBoxObject.ROLLUP_CONSUME);
Blocks: 979835
Keywords: regression
(In reply to Philip Chee from comment #1)
> > I could see the remnant of its former existence.
> > For example:
> > http://mxr.mozilla.org/mozilla/source/layout/xul/base/public/
> > nsIPopupBoxObject.idl
> > 
> > but I don't find nsIPopupBoxObject.idl in C-C or M-C any more.
> > 
> > I still find it in comm-aurora, but not in mozilla-aurora.
> > Mozilla-beta has it.
> > 
> > What gives?
> 
> This is Bug 979835 - Port BoxObject to WebIDL
> 
> 165     this.panel.popupBoxObject
> 166         .setConsumeRollupEvent(Components.interfaces
> 167                                         
> .nsIPopupBoxObject.ROLLUP_CONSUME);
> 
> As a wild guess (I am not an expert in this) try:
> 
> this.panel.boxObject.setConsumeRollupEvent(PopupBoxObject.ROLLUP_CONSUME);

Thank you for the tips.

I modified the source per the suggestion above.
Now C-C TB can proceed further in the test, *BUT*
it now encountered another error.

No error in June,
but sept 28.

TEST-START |
/REF-COMM-CENTRAL/comm-central/mail/test/mozmill/composition/test-attachment-reminder.js
| test_attachment_reminder_in_subject
Step Pass: {"function": "Controller.keypress()"}
Chrome file doesn't exist:
/REF-OBJ-DIR/objdir-tb3/dist/bin/chrome/toolkit/content/global/charsetOverlay.js
[26281] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result
0x80520012: file
/REF-COMM-CENTRAL/comm-central/mozilla/netwerk/base/src/nsFileStreams.cpp,
line 205
[26281] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result
0x80520012: file
/REF-COMM-CENTRAL/comm-central/mozilla/netwerk/base/src/nsFileStreams.cpp,
line 492
Failed to load
file:///REF-OBJ-DIR/objdir-tb3/dist/bin/chrome/toolkit/content/global/charsetOverlay.js
JavaScript strict warning: , line 0: TypeError: setting a property that
has only a getter
++DOCSHELL 0xaa85760 == 79 [pid = 26281] [id = 278]
++DOMWINDOW == 169 (0x52a8190) [pid = 26281] [serial = 768] [outer = (nil)]
++DOCSHELL 0x4f5ed30 == 80 [pid = 26281] [id = 279]
++DOMWINDOW == 170 (0x875d1c0) [pid = 26281] [serial = 769] [outer = (nil)]
++DOCSHELL 0xae5c530 == 81 [pid = 26281] [id = 280]
++DOMWINDOW == 171 (0x6ea6e90) [pid = 26281] [serial = 770] [outer = (nil)]
JavaScript strict warning: , line 0: TypeError: setting a property that
has only a getter
JavaScript strict warning: , line 0: TypeError: setting a property that
has only a getter
JavaScript strict warning: , line 0: TypeError: setting a property that
has only a getter
JavaScript strict warning: , line 0: TypeError: setting a property that
has only a getter
[26281] WARNING: NS_ENSURE_TRUE(nsContentUtils::GetCurrentJSContext())
failed: file
/REF-COMM-CENTRAL/comm-central/mozilla/docshell/base/nsDocShell.cpp,
line 9074
[26281] WARNING: NS_ENSURE_TRUE(nsContentUtils::GetCurrentJSContext())
failed: file
/REF-COMM-CENTRAL/comm-central/mozilla/docshell/base/nsDocShell.cpp,
line 9074
++DOMWINDOW == 172 (0x7d25f60) [pid = 26281] [serial = 771] [outer =
0x875d1c0]
[26281] WARNING: NS_ENSURE_TRUE(globalObject &&
globalObject->GetGlobalJSObject()) failed: file
/REF-COMM-CENTRAL/comm-central/mozilla/content/html/document/src/nsHTMLContentSink.cpp,
line 741
[26281] WARNING: Subdocument container has no frame: file
/REF-COMM-CENTRAL/comm-central/mozilla/layout/base/nsDocumentViewer.cpp,
line 2511
++DOMWINDOW == 173 (0x9d49d70) [pid = 26281] [serial = 772] [outer =
0x52a8190]
++DOMWINDOW == 174 (0x758a220) [pid = 26281] [serial = 773] [outer =
0x875d1c0]
[26281] WARNING: NS_ENSURE_TRUE(globalObject &&
globalObject->GetGlobalJSObject()) failed: file
/REF-COMM-CENTRAL/comm-central/mozilla/content/html/document/src/nsHTMLContentSink.cpp,
line 741
[26281] WARNING: Subdocument container has no frame: file
/REF-COMM-CENTRAL/comm-central/mozilla/layout/base/nsDocumentViewer.cpp,
line 2511
++DOMWINDOW == 175 (0x4ca8890) [pid = 26281] [serial = 774] [outer =
0x6ea6e90]
++DOMWINDOW == 176 (0x88b8f60) [pid = 26281] [serial = 775] [outer =
0x875d1c0]
[26281] WARNING: NS_ENSURE_TRUE(selection->GetRangeCount()) failed: file
/REF-COMM-CENTRAL/comm-central/mozilla/editor/libeditor/nsHTMLEditRules.cpp,
line 320
[26281] WARNING: NS_ENSURE_TRUE(sheet) failed: file
/REF-COMM-CENTRAL/comm-central/mozilla/editor/libeditor/nsHTMLEditor.cpp, line
2937
[26281] WARNING: NS_ENSURE_TRUE(aNode) failed: file
/REF-COMM-CENTRAL/comm-central/mozilla/editor/libeditor/nsEditor.cpp,
line 3384
[26281] WARNING: NS_ENSURE_TRUE(name) failed: file
/REF-COMM-CENTRAL/comm-central/mozilla/content/base/src/nsDOMAttributeMap.cpp,
line 416
++DOMWINDOW == 177 (0x890d210) [pid = 26281] [serial = 776] [outer =
0x52a8190]
ScrollInternal: mTopRowIndex = 0 mozilla::clamped()=0, maxTopRowIndex=0
mRowCount=0, mPageLength=0 aRow=0
Test Failure: Not a send error dialog; title=Write: (no subject)
[26281] WARNING: NS_ENSURE_TRUE(ps) failed: file
/REF-COMM-CENTRAL/comm-central/mozilla/editor/libeditor/nsHTMLEditor.cpp, line
2941
   ...

Eventually the test failed as above.

Please note the strange error line:

Failed to load
file:///REF-OBJ-DIR/objdir-tb3/dist/bin/chrome/toolkit/content/global/charsetOverlay.js

Using
I searched for the file charsetOverlay.js but it is not in C-C.
I searched for the string charsetOverlay.js and it is in
mail/components/compose/content/messengercompose.xul (View Hg log or Hg annotations)
    line 69 -- <script type="application/javascript" src="chrome://global/content/charsetOverlay.js"/>

Maybe another file that disappeared in the last three months or so?

I checked old log files and this error was not seen on June 25 local log.
My PC had a hardware hiccup and I could not much on TB during the summer,
and late September when I updated my source and re-ran the test, 
the above error line appeared and still persists until today.

If this missing file is not related to nsIPopupBoxObject, I think I should file a new bugzilla.

TIA
Summary: JavaScript error: chrome://messenger/content/editContactOverlay.js, line 166: TypeError: Components.interfaces.nsIPopupBoxObject is undefined → JavaScript error: chrome://messenger/content/editContactOverlay.js, line 166: TypeError: Components.interfaces.nsIPopupBoxObject is undefined [TEST-UNEXPECTED-FAIL | test-message-header.js | test-message-header.js::test_address_book_switch_disabled_on_con
This is the patch that worked for me.
Essentially the one suggested in hg patch form.

TIA
Attachment #8511436 - Flags: review?(bwinton)
> If this missing file is not related to nsIPopupBoxObject, I think I should
> file a new bugzilla.

For the missing chrome file problem,
I filed
Bug 1089025 - C-C TB: Chrome file doesn't exist: chrome/toolkit/content/global/charsetOverlay.js
Assignee: nobody → ishikawa
Comment on attachment 8511436 [details] [diff] [review]
Replacing nsIPopupBoxObject with PopupBoxObject.

Review of attachment 8511436 [details] [diff] [review]:
-----------------------------------------------------------------

Steeling this review. Tried it and works fine here too, so r=mkmelin
Thanks for the patch!
Attachment #8511436 - Flags: review?(bwinton) → review+
Status: NEW → ASSIGNED
(In reply to TBPL Robot from comment #33)
> submit_timestamp: 2014-10-25T16:18:59
> log:
> https://treeherder.mozilla.org/ui/logviewer.html#?repo=comm-
> central&job_id=1436
> repository: comm-central
> who: Pidgeot18[at]gmail[dot]com
> machine: t-w732-ix-016
> buildname: TB Windows 7 32-bit comm-central opt test mozmill
> revision: 0ea5fe2ba57c
> 
> TEST-UNEXPECTED-FAIL |
> C:\slave\test\build\mozmill\message-header\test-message-header.js |
> test-message-header.js::test_clicking_star_opens_inline_contact_editor
> TEST-UNEXPECTED-FAIL |
> C:\slave\test\build\mozmill\message-header\test-message-header.js |
> test-message-header.js::
> test_address_book_switch_disabled_on_contact_in_mailing_list
> TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during
> directory run
> TEST-UNEXPECTED-FAIL | C:\slave\test\build\mozmill\testLocalICS.js |
> testLocalICS.js::testLocalICS
> TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during
> directory run
> TEST-UNEXPECTED-FAIL | C:\slave\test\build\mozmill\testTodayPane.js |
> testTodayPane.js::testTodayPane
> TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during
> directory run

I am putting in checkin-needed keyword.

Just for clarification.

(1)
TEST-UNEXPECTED-FAIL |
> C:\slave\test\build\mozmill\message-header\test-message-header.js |
> test-message-header.js::test_clicking_star_opens_inline_contact_editor

This *IS FIXED* by the patch here.
The test was failing due to the problem mentioned in the original, and the patch
here fixed the issue.

(2) TEST-UNEXPECTED-FAIL | C:\slave\test\build\mozmill\testLocalICS.js | testLocalICS.js::testLocalICS
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run

(3)
TEST-UNEXPECTED-FAIL | C:\slave\test\build\mozmill\testTodayPane.js | testTodayPane.js::testTodayPane


Strange. I don't have test in (2) and (3) on local PC. I would re-check after refreshing the source.

TIA
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/209d0c9e55e6
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 36.0
(In reply to TBPL Robot from comment #44)
> submit_timestamp: 2014-10-25T18:10:08
> log:
> https://treeherder.mozilla.org/ui/logviewer.html#?repo=comm-
> central&job_id=1482
> repository: comm-central
> who: Pidgeot18[at]gmail[dot]com
> machine: tst-linux64-spot-1016
> buildname: Ubuntu VM 12.04 x64 comm-central opt test mozmill
> revision: 9012461955e4
> 
> TEST-UNEXPECTED-FAIL |
> /builds/slave/test/build/mozmill/composition/test-attachment-reminder.js |
> test-attachment-reminder.js::test_manual_attachment_reminder
> TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during
> directory run
> TEST-UNEXPECTED-FAIL |
> /builds/slave/test/build/mozmill/message-header/test-message-header.js |
> test-message-header.js::test_clicking_star_opens_inline_contact_editor
> TEST-UNEXPECTED-FAIL |
> /builds/slave/test/build/mozmill/message-header/test-message-header.js |
> test-message-header.js::
> test_address_book_switch_disabled_on_contact_in_mailing_list
> TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during
> directory run
> TEST-UNEXPECTED-FAIL |
> /builds/slave/test/build/mozmill/newmailaccount/test-newmailaccount.js |
> test-newmailaccount.js::test_show_tos_privacy_links_for_selected_providers
> TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during
> directory run
> command timed out: 7200 seconds without output running ['bash', '-c',
> u'../mozmill-virtualenv/bin/python runtestlist.py
> --binary=../thunderbird/thunderbird-bin
> --symbols-path=http://ftp.mozilla.org/pub/mozilla.org/thunderbird/tinderbox-
> builds/comm-central-linux64/1414264991/thunderbird-36.0a1.en-US.linux-x86_64.
> crashreporter-symbols.zip --list=mozmilltests.list'], attempting to kill

(In reply to ISHIKAWA, Chiaki from comment #34)
> (In reply to TBPL Robot from comment #33)
> > submit_timestamp: 2014-10-25T16:18:59
> > log:
> > https://treeherder.mozilla.org/ui/logviewer.html#?repo=comm-
> > central&job_id=1436
> > repository: comm-central
> > who: Pidgeot18[at]gmail[dot]com
> > machine: t-w732-ix-016
> > buildname: TB Windows 7 32-bit comm-central opt test mozmill
> > revision: 0ea5fe2ba57c
> > 
> > TEST-UNEXPECTED-FAIL |
> > C:\slave\test\build\mozmill\message-header\test-message-header.js |
> > test-message-header.js::test_clicking_star_opens_inline_contact_editor
> > TEST-UNEXPECTED-FAIL |
> > C:\slave\test\build\mozmill\message-header\test-message-header.js |
> > test-message-header.js::
> > test_address_book_switch_disabled_on_contact_in_mailing_list
> > TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during
> > directory run
> > TEST-UNEXPECTED-FAIL | C:\slave\test\build\mozmill\testLocalICS.js |
> > testLocalICS.js::testLocalICS
> > TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during
> > directory run
> > TEST-UNEXPECTED-FAIL | C:\slave\test\build\mozmill\testTodayPane.js |
> > testTodayPane.js::testTodayPane
> > TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during
> > directory run
> 
> I am putting in checkin-needed keyword.
> 
> Just for clarification.
> 
> (1)
> TEST-UNEXPECTED-FAIL |
> > C:\slave\test\build\mozmill\message-header\test-message-header.js |
> > test-message-header.js::test_clicking_star_opens_inline_contact_editor
> 
> This *IS FIXED* by the patch here.
> The test was failing due to the problem mentioned in the original, and the
> patch
> here fixed the issue.
> 
> (2) TEST-UNEXPECTED-FAIL | C:\slave\test\build\mozmill\testLocalICS.js |
> testLocalICS.js::testLocalICS
> TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during
> directory run
> 
> (3)
> TEST-UNEXPECTED-FAIL | C:\slave\test\build\mozmill\testTodayPane.js |
> testTodayPane.js::testTodayPane
> 
> 
> Strange. I don't have test in (2) and (3) on local PC. I would re-check
> after refreshing the source.
> 
> TIA

> 
> (2) TEST-UNEXPECTED-FAIL | C:\slave\test\build\mozmill\testLocalICS.js |
> testLocalICS.js::testLocalICS
> TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during
> directory run
> 
> (3)
> TEST-UNEXPECTED-FAIL | C:\slave\test\build\mozmill\testTodayPane.js |
> testTodayPane.js::testTodayPane
> 
> 
> Strange. I don't have test in (2) and (3) on local PC. I would re-check
> after refreshing the source.
> 
> TIA

These seem to be related to calendar?

/REF-COMM-CENTRAL/comm-central/calendar/test/mozmill/testTodayPane.js
/REF-COMM-CENTRAL/comm-central/calendar/test/mozmill/testLocalICS.js

I test only TB: 
my mozconfig contains
ac_add_options --enable-application=mail

and so can't say for sure what is going on for (2) and (3).

But if someone runs "DEBUG BUILD" of calendar, it is likely that we
can learn the cause of why these tests are failing.

TIA
(In reply to ISHIKAWA, Chiaki from comment #46)
> These seem to be related to calendar?

Yes, bug 1074645, which theoretically should be fixed next time m-i merges to m-c.
(In reply to Joshua Cranmer [:jcranmer] from comment #47)
> (In reply to ISHIKAWA, Chiaki from comment #46)
> > These seem to be related to calendar?
> 
> Yes, bug 1074645, which theoretically should be fixed next time m-i merges
> to m-c.

Thank you for the clarification. I had to look for "m-i" in MXR and TBPL and figured
m-i stands for mozilla-inbound. Oh, there are so many different repositories these days...
So I think I can safely ignore the two issues and leave them to bug 1074645.

TIA
You need to log in before you can comment on or make changes to this bug.