[2.1][l10n][Contacts] Multiple locales: The "Add Picture" string is truncated on "Add contact" screen.

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: YeojinC, Assigned: sergi)

Tracking

({regression})

unspecified
2.1 S7 (24Oct)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: LocRun2.1-2)

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8508793 [details]
Add_Picture.png

Description:
On "Add contact" screen, the "Add Picture" string is truncated in Catalan.

Repro Steps:
1) Updated Flame to Build ID: 20141021001201.
2) Set the language to Catalan.
3) Open Contacts app, and select the "+" icon.

Actual:
The "Add Picture" string is truncated in test language.

Expected:
The "Add Picture" string is NOT truncated and displayed properly in test language.

Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141021001201
Gaia: e458f5804c0851eb4e93c9eb143fe044988cecda
Gecko: ee86921a986f
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro frequency: 100%
See attached: screenshot
(Reporter)

Comment 1

3 years ago
This issue does NOT occur on Flame 2.0:

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141021000201
Gaia: 63b56a7a7453726b9e12ad1afe02c68c83c5aeca
Gecko: 40584eecdc75
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

The "Add Picture" string is NOT truncated and displayed properly in test language.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Keywords: regression
[Blocking Requested - why for this release]:
This is a pretty bad regression since the word "picture" is completely dropped, so sense is lost.
Asking for some UX help on this one!
Assignee: egamonal → nobody
blocking-b2g: --- → 2.1?
Component: ca / Catalan → Gaia::Contacts
Flags: needinfo?(firefoxos-ux-bugzilla)
Product: Mozilla Localizations → Firefox OS
We will need first UX input, to me it's not a blocker.
triage: shouldn't be blocking.
ni? Carrie for more input. Please go ahead and re-nom if UX has strong opinion.
blocking-b2g: 2.1? → -
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(cawang)
[Blocking Requested - why for this release]:

This actually happens on multiple critical Tako shipping locales AND is a regression, please consider blocking on this.
On all those locales, the word "picture" is missing, this means the whole sense of the string is lost. This is pretty bad
blocking-b2g: - → 2.1?
Summary: [2.1][l10n][Contacts] Catalan: The "Add Picture" string is truncated on "Add contact" screen. → [2.1][l10n][Contacts] Multiple locales: The "Add Picture" string is truncated on "Add contact" screen.
Duplicate of this bug: 1085467
Duplicate of this bug: 1087651
I think Fang worked on this issue on the other bug. ni? Fang to look into this one.
If the same problem keep happening in different locales, then I'd suggest replacing the string with an icon will be fine. Thanks!
Flags: needinfo?(cawang) → needinfo?(fshih)

Comment 9

3 years ago
Created attachment 8510168 [details]
Contact_Addcontact.png

We will redesign an icon for this in 2.2 since this same problem keeps happening in different locales. But for now, quick solution would be changing the font Size, I shrink the font size to 1.7rem to fit the space. Attached the mock up for reference. But there will be a new design to replace the text in the next version for sure. Thanks!
Flags: needinfo?(fshih)
triage: impact on various languages
blocking-b2g: 2.1? → 2.1+
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Target Milestone: --- → 2.1 S7 (24Oct)
Assignee: nobody → sergi.mansilla
Created attachment 8510959 [details] [review]
Github PR

The only way the text would fit entirely in Catalan is to shrink it to 1.1rem, not 1.7. Francisco, please find the PR in the attachment.

Thanks!
Attachment #8510959 - Flags: review?(francisco)
Comment on attachment 8510959 [details] [review]
Github PR

r+ easy fix. Thanks Sergi.
Attachment #8510959 - Flags: review?(francisco) → review+
Merged at 8fd4818cc9c95f9caa3128fc5293f43f83dab5de
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 14

3 years ago
Hi, Catalan l10nator here.
I confirm this is a regression: it did not happen in 2.0.
I am not sure how many languages are affected by the truncation, but I seriously doubt that making the Catalan string fit in the allotted space (by reducing the font size) will fix all the other locales.

Did anybody check?
(Reporter)

Comment 15

3 years ago
I checked the following languages on Flame 2.1:

Repro: Catalan, Czech, Russian, Slovak, Malay, Dutch, Bulgarian, Romanian, Indonesian, Xhosa
(The "Add Picture" string is truncated)

Not Repro: Brazilian Portuguese, Albanian, Basque, Galician, Greek, Hungarian, Polish,  Serbian Cyrillic, Serbian Latin, Turkish, Danish, Swedish, Spanish, Bengali from India, Croatian, Macedonian, Hindi, Afrikaans, Zulu
(The "Add Picture" string is NOT truncated)

Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141028001203
Gaia: a0174f7166745256aaca1cb3aa9f894033fbffa6
Gecko: 43bda3541f6b
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Delphine, should we add all of the missing localizers from the languages this bug was found on from comment 15?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris) → needinfo?(lebedel.delphine)
Comment on attachment 8510959 [details] [review]
Github PR

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Feature: new contacts redesign
[User impact] if declined:
Bad user experience
[Testing completed]:
Tested on master
[Risk to taking this patch] (and alternatives if risky):
Extremely low, just a css rule to make the font size smaller
[String changes made]:
None
Attachment #8510959 - Flags: approval-gaia-v2.1?(fabrice)
Attachment #8510959 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
(Reporter)

Comment 19

3 years ago
I verified that the font size is smaller on Flame 2.1. However, these languages are still truncated:

Bulgarian, Dutch, Russian, Xhosa

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141031001201
Gaia: f89c7b12c36572262c9ea76058694a139b1a8634
Gecko: 50d48f8a04c7
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(dharris)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Derek: Given the situation, please open separate bugs for Bulgarian, Dutch, Russian, Xhosa, CCing the localizers and asking them for a workaround since this bug unfortunately was not able to fix the situation in their locales. Thanks!
Flags: needinfo?(lebedel.delphine)
Derek: Given the situation, please open separate bugs for Bulgarian, Dutch, Russian, Xhosa, CCing the localizers and asking them for a workaround since this bug unfortunately was not able to fix the situation in their locales. Thanks!
Flags: needinfo?(dharris)
Ok I ill have 4 new bugs open for each of the languages you mentioned in comment 21.
Flags: needinfo?(dharris)

Comment 23

3 years ago
Verified the issue if fixed on 2.2 and 2.1

No truncation appears on the "Add Photo" message on Catalan language
As per comment 21, for for Bulgarian, Dutch, Russian, Xhosa, CCing languages will be opened separate bugs

Device: Flame 2.2 Master
BuildID: 20141105040206
Gaia: 7c9e7cabbde941b976e0e40a3a1d94e21aa9c5e9
Gecko: 62990ec7ad78
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Device: Flame 2.1 KK
BuildID: 20141105001204
Gaia: 154da5e17029a51002d5d9b7df39563d509edde6
Gecko: 3b0c3580a58d
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.