Closed Bug 1087035 Opened 7 years ago Closed 7 years ago

USSD "Session Expired" displayed instead of operator response

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(tracking-b2g:backlog, b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED DUPLICATE of bug 1077392
tracking-b2g backlog
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: xelawafs, Unassigned)

References

Details

Attachments

(2 files)

When you dial in a USSD code, gaia returns session expired instead of the message from the operator. If there's a menu though, it will display the menu but once you pick a selection from the menu to get the last response for that session, the session expires before receiving the message.

At times, there's a quick flash of the operator's message before "Session Expired" is displayed

Steps to reporoduce
1. Enter a Valid USSD code eg *200#
2. If *200# has a menu as a response, it's displayed which is ok
3. Select an item on the menu eg 1.
4. If this item leads to another menu, process 2 is repeated which is ok. How ever, if it gets the last message from the operator, the session expires without diplaying this message.

I'm on the nightly channel and I'm using a flame phone.
Sounds light a dup of bug 1057455, if you're on a recent nightly it should be fixed already. Which gecko/gaia version do you have?
Flags: needinfo?(xelawafs)
Hey Gabriele, I'm on the nightly channel version 2.2.

This still isn't working for me.
Flags: needinfo?(xelawafs)
(In reply to Alex Wafula from comment #2)
> This still isn't working for me.

OK, would you be able to share your logcat when this problem happens? First turn on RIL debugging information as described here:

https://wiki.mozilla.org/B2G/QA/Tips_And_Tricks#RIL_Debugging

Then run the steps necessary to reproduce this issue and grab the logcat.

CC'ing Hsin-Yi because she might be interested too.
Attached patch Dump USSD eventsSplinter Review
Also if you've got your own gaia build could you please apply this patch and install the modified dialer applications before grabbing the log? This will be helpful for me to diagnose the issue.
Attached file logcat.txt
*200*2*2# is the ussd code I'm trying to run
Unfortunately *200# code doesn't work on my SIM but looking at the log I think we're hitting the same issue as in bug 1077392. Namely we get a success message from the RIL with an empty |statusMessage| field. Since it's the last message in the session and it doesn't have a |statusMessage| we interpret it as a session-ended condition. I'm starting to think that we should behave differently in this situation... Possible by closing the UI without much ado? Hsin-Yi, this is pretty much the same problem as my question in bug 1077392 comment 9.
Flags: needinfo?(htsai)
Duplicate of this bug: 928810
Duplicate of this bug: 1098978
(In reply to Gabriele Svelto [:gsvelto] from comment #6)
> Unfortunately *200# code doesn't work on my SIM but looking at the log I
> think we're hitting the same issue as in bug 1077392. Namely we get a
> success message from the RIL with an empty |statusMessage| field. Since it's
> the last message in the session and it doesn't have a |statusMessage| we
> interpret it as a session-ended condition. I'm starting to think that we
> should behave differently in this situation... Possible by closing the UI
> without much ado? Hsin-Yi, this is pretty much the same problem as my
> question in bug 1077392 comment 9.
Please see my reply in bug 1077392, thank you!
Flags: needinfo?(htsai)
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
blocking-b2g: --- → backlog
feature-b2g: --- → 2.2?
Dear Gabriele,
Partner opened bug 1098978 which I dup to this one. Just wondering whether you think we can fix this in 2.0M? 
Thank you!
Flags: needinfo?(gsvelto)
I've just added attachment 8535794 [details] [review] in bug 1077392 which should fix this issue too. Alex, could you test your scenario with this patch applied and see if it fixes your problem? If it does then I'd like to dup this against bug 1077392 because I think they're the same.
Flags: needinfo?(gsvelto) → needinfo?(xelawafs)
Priority: -- → P2
hey Gabriele,

Unfortunately, I just lost my flame. I'll hopefully get hold of someone with one soon to test this.
Flags: needinfo?(xelawafs)
(In reply to Alex Wafula from comment #12)
> Unfortunately, I just lost my flame. I'll hopefully get hold of someone with
> one soon to test this.

OK, thanks for your help. I'll dup against bug 1077392 in the meantime, please reopen this bug if the fix for that one doesn't also solve this.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1077392
removing feature-b2g flag as the duplicate was landed.
feature-b2g: 2.2? → ---
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.