Closed Bug 1087195 Opened 5 years ago Closed 5 years ago

[Bluetooth] Add support for HFP, A2DP and AVRCP to Bluetooth daemon

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(feature-b2g:2.2+, b2g-v2.2 fixed)

RESOLVED FIXED
2.2 S2 (19dec)
feature-b2g 2.2+
Tracking Status
b2g-v2.2 --- fixed

People

(Reporter: tzimmermann, Assigned: tzimmermann)

References

Details

Attachments

(1 file, 1 obsolete file)

HFP support includes Gecko and daemon side.
Attached file Github tree for bluetoothd (obsolete) —
Comment on attachment 8509490 [details]
Github tree for bluetoothd

Updated Github tree:

  - send parameters of VOLUME_CMD_NTF as 8-bit values
Depends on: 1084257
No longer blocks: 1005934
feature-b2g: --- → 2.2+
Assignee: nobody → tzimmermann
Status: NEW → ASSIGNED
Summary: [Bluetooth] Add HFP support to Bluetooth daemon → [Bluetooth] Add support for HFP, A2DP and AVRCP to Bluetooth daemon
Duplicate of this bug: 1087196
Duplicate of this bug: 1087198
The remaining code for all our current profiles is not that much. So let's land this at once.
Attached file Github pull request
The patch set contains support for the remaining profiles: HFP, A2DP, and AVRCP.
Attachment #8509490 - Attachment is obsolete: true
Attachment #8528333 - Flags: review?(shuang)
There have been HAL changes for L that affect these profiles.  Please see bug 1102703.  Can we make the changes necessary for L as a part of fixing bug as well?
See Also: → 1102703
I'd like to not break up the patch set if possible, but support for L is on top of my list. Things seem to go slowly recently; I hope we can speed up landing a bit.
Comment on attachment 8528333 [details]
Github pull request

Updated pull request:

  - fixed a bug where the daemon was quit
(In reply to Thomas Zimmermann [:tzimmermann] [:tdz] from comment #8)
> I'd like to not break up the patch set if possible, but support for L is on
> top of my list. Things seem to go slowly recently; I hope we can speed up
> landing a bit.
After checking hfp/avrcp code serval times, i think we're good to land these patches. I noticed that AVRCP NTF opcode is different from ANDROID 18 to ANDROID 20 and that needs to added in patch [02] bug 1095488.
Comment on attachment 8528333 [details]
Github pull request

Updated pull request

  - added asserts
  - fixed assertions in bt-hf.c that tested for btsock_interface

I built this patch set on flame-kk, nexus-4, and flatfish.
Thanks a lot, Shawn!
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/platform_system_bluetoothd/commit/288db53ad77084bd44791add5e3a4c266a6e9c60
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S2 (19dec)
You need to log in before you can comment on or make changes to this bug.