[Ringtones] Songs are not added to ringtones list

RESOLVED FIXED in Firefox 35, Firefox OS v2.2

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: squib, Assigned: bent.mozilla)

Tracking

({regression})

unspecified
2.1 S7 (24Oct)
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(firefox33 wontfix, firefox34 wontfix, firefox35+ fixed, firefox36 fixed, b2g-v2.1 unaffected, b2g-v2.2 fixed)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Cloning because this is still happening for me on the latest Gecko/Gaia on a Flame (v188 firmware). Seems to happen with every file, regardless of format or whether it has album art.

+++ This bug was initially created as a clone of Bug #1076975 +++

Description:
When a user tries to add a song as a ringtone it will never appear in the list of ringtones as an option. This occurs wether the user adds the song through settings or the music app.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141001170320
2) Go to Setting > Sounds > Manage Tones
3) Click the "+" icon in the top right
4) Select a song and add it as a ringtone.
5) Observe list of ringtones options
  
Actual:
The song is never added as a ringtone option.
  
Expected: 
It is expected that the song is added as a ringtone option
  
Environmental Variables:
Device: Flame 2.2 Master (Shallow Flash)
BuildID: 20141001170320
Gaia: 191d805f4911628d37a8a90a1e23a6013995138f
Gecko: 2399d1ae89e9
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Repro frequency: 100%
See attached: video clip(http://youtu.be/4LO-1PQvCBM), logcat
I cannot reproduce this.
Created attachment 8510722 [details] [diff] [review]
Patch, v1

Ugh, the reason I couldn't reproduce was because apparently we don't run Nuwa on DEBUG builds.

<!!! !!! !!!/>

I was using the wrong ContentParent when Nuwa was cloning PBackground. Sheesh.
Assignee: nobody → bent.mozilla
Status: NEW → ASSIGNED
Attachment #8510722 - Flags: review?(khuey)
This goes back all the way to bug 956218.
status-firefox33: --- → affected
status-firefox34: --- → affected
status-firefox35: --- → affected
Comment on attachment 8510722 [details] [diff] [review]
Patch, v1

Approval Request Comment
[Feature/regressing bug #]: Bug 956218
[User impact if declined]: Optimized builds randomly crash.
[Describe test coverage new/current, TBPL]: Apparently QA sees this in smoketests, and others are working on adding automated coverage.
[Risks and why]: Low risk, this is obviously correct.
[String/UUID change made/needed]: None
Attachment #8510722 - Flags: approval-mozilla-aurora?
[Tracking Requested - why for this release]:

(In reply to ben turner [:bent] (use the needinfo? flag!) from comment #3)
> This goes back all the way to bug 956218.

Though since IndexedDB is the only in-tree consumer, and it was just added on aurora, I don't think this needs to be pushed back any further.
tracking-firefox35: --- → ?
Nuwa will hopefully run on DEBUG builds when bug 1050122 is fixed.
https://hg.mozilla.org/mozilla-central/rev/8f7a258843e4
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S7 (24Oct)
Duplicate of this bug: 1085536
Duplicate of this bug: 1080090
Attachment #8510722 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
status-firefox36: --- → fixed
tracking-firefox35: ? → +
https://hg.mozilla.org/releases/mozilla-aurora/rev/c11621d7a35c
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → fixed
status-firefox33: affected → wontfix
status-firefox34: affected → wontfix
status-firefox35: affected → fixed
You need to log in before you can comment on or make changes to this bug.