Calling a contact does not add the matching entry to call log

RESOLVED DUPLICATE of bug 1087464

Status

defect
RESOLVED DUPLICATE of bug 1087464
5 years ago
5 years ago

People

(Reporter: drs, Unassigned)

Tracking

unspecified
2.1 S8 (7Nov)

Firefox Tracking Flags

(blocking-b2g:2.2+)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Posted file Log
We are getting the attached log when hanging up. Whether or not this is related is unknown.
I had a closer look, and it's not really related to the last dialed number. Call log does not get updated consistently: some entries are being properly added, some are not. For instance, calling voicemail or an number not tied to a contact properly adds a new entry, but calling one contact do not.
blocking-b2g: --- → 2.2?
Summary: Last dialed number not being remembered correctly → Calling a contact does not add the matching entry to call log
Duplicate of this bug: 1083023
In bug 1083023 comment 1, I wasn't able to repro. I checked the following scenarios:
* Receive a phone call from an unknown number and drop
* Receive a phone call from an unknown number, pick up, and hang up on the same device.
* Receive a phone call from an unknown number, pick up, and hang up on the other device.
* Place a phone call to an unknown number and be dropped
* Place a phone call to an unknown number, be picked up, and be hanged up.
* Place a phone call to an unknown number, be picked up, and hanged up.
It would look like that a contact with a photo triggers the issue, while a contact without is fine.
Contact added with a photo a long time ago:
 - place a call,
 - wait for sound, and then hang up

This triggers the log from attachment 8508118 [details]

Contact added a long time ago, already in call log as the last call, add a picture now:
 - place a call,
 - wait for sound, hang up
 - No issue so far
 - switch to call log in dialer

This triggers the log from attachment 8508572 [details]
Following comment 6, I cannot access the call log anymore: Communications app gets killed, with similar IPDL errors  :(
Looks similar to bug 1063658. Ben do you have any idea on this ?
Flags: needinfo?(bent.mozilla)
triage: major issue that breaks user experience
blocking-b2g: 2.2? → 2.2+
Please check again with a nightly that includes the fix in bug 1087464.
Flags: needinfo?(bent.mozilla)
(Reporter)

Comment 11

5 years ago
Johan, could you try this with the better STR in comment 6? See also comment 10.
Flags: needinfo?(jlorenzo)
(In reply to ben turner [:bent] (use the needinfo? flag!) from comment #10)
> Please check again with a nightly that includes the fix in bug 1087464.

Thanks, that does fix the issue for me. I'm marking as a dupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(jlorenzo)
Resolution: --- → DUPLICATE
Duplicate of bug: 1087464
You need to log in before you can comment on or make changes to this bug.