Mochitest doesn't handle test files which don't start with 'test_'

RESOLVED FIXED in mozilla36

Status

()

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: jgilbert, Assigned: jgilbert)

Tracking

(Blocks 1 bug)

unspecified
mozilla36
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 2 obsolete attachments)

Assignee

Description

5 years ago
It's been (nearly) silently not running a couple tests because they don't match the desired filename format. Making this assert is bug 1087558.
Attachment #8509735 - Flags: review?(dglastonbury)
Assignee

Comment 1

5 years ago
Posted patch 0002-Fix-tests.patch (obsolete) — Splinter Review
Attachment #8509837 - Flags: review?(dglastonbury)
Why are you asking me to land something that has test failures on the Try run?

Also, what reftests were you expecting to fail from these patches? Or xpcshell. Or mochitest-bc. Etc. Try to consider that when deciding which test suites to run? :)
https://wiki.mozilla.org/Sheriffing/How:To:Recommended_Try_Practices
Keywords: checkin-needed
Assignee

Comment 4

5 years ago
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #3)
> Why are you asking me to land something that has test failures on the Try
> run?
> 
> Also, what reftests were you expecting to fail from these patches? Or
> xpcshell. Or mochitest-bc. Etc. Try to consider that when deciding which
> test suites to run? :)
> https://wiki.mozilla.org/Sheriffing/How:To:Recommended_Try_Practices

Hah, sorry. I forgot to remove checkin-needed.
https://hg.mozilla.org/mozilla-central/rev/265a63f3f5e1
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
Assignee

Comment 9

5 years ago
That was just the CLOBBER update.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee

Comment 10

5 years ago
I changed this, sorry!
Attachment #8509837 - Attachment is obsolete: true
Attachment #8512187 - Flags: review?(dglastonbury)
Clipboard failed. Backout commit for all three is https://hg.mozilla.org/integration/mozilla-inbound/rev/982fc6c2f76b
Flags: needinfo?(jgilbert)
I should probably add that https://treeherder.mozilla.org/ui/logviewer.html#?job_id=3344490&repo=mozilla-inbound occurred after one of the following pushes touched CLOBBER, so it's not just needs-clobber. 

These failures were on b2g mochitest-1, not the b2g mochitest-2 that your try runs ran.
Assignee

Comment 17

5 years ago
Ugh, not again.
Flags: needinfo?(jgilbert)
Assignee

Comment 18

5 years ago
Skip those tests, since B2G Desktop doesn't get WebGL contexts yet.
Assignee

Comment 19

5 years ago
Comment on attachment 8512188 [details] [diff] [review]
0003-Build-GetContextAttributes-from-mOptions-now-that-th.patch

This landed in bug 912196.
Attachment #8512188 - Attachment is obsolete: true
Backed out yet again, in https://hg.mozilla.org/integration/mozilla-inbound/rev/3a8b152acd9c, for causing a permacrash in Android 2.3 opt mochitest-10 in test_imagecapture.html, and permaorange in b2g emulator, opt mochitest-3 and debug mochitest-10, misfiled as bug 1090649.

Please do not under any circumstances push this again without either filing a bug about the way it needs a clobber and touching /CLOBBER as part of your push, or figuring out and fixing why it needs a clobber.

Please do not under any circumstances push this again without doing a "try: -b do -p all -u all -t none" try push (in theory you ought to be able to do -u mochitests, but that's merely theory, and I'm sick of seeing this turn the tree orange for seven or eight hours at a time).
Duplicate of this bug: 1090649
Assignee

Updated

5 years ago
Depends on: 1071217
Assignee

Comment 24

5 years ago
https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=4b00fca7e89e

Green except for some likely-intermittent oranges. I retriggered those. When I land again, I'll include a CLOBBER touch.
Assignee

Updated

5 years ago
Blocks: 1091822
Assignee

Comment 25

5 years ago
Is this clean? There are two intermittents that seem common. Neither is directly related to my patches.
https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=4b00fca7e89e

There's nothing left I can do other than periodically rebase and do a Try run until it happens to not cause problems.
Flags: needinfo?(philringnalda)
Sadly, I think that is what amounts to a clean run, though it rather neatly does point out that linux32 debug mochitest-e10s-2 doesn't even remotely come close to meeting the requirements to be visible, and Mullet 5 isn't far behind.

Fire away!
Flags: needinfo?(philringnalda)
https://hg.mozilla.org/mozilla-central/rev/10ec61ff9b6c
https://hg.mozilla.org/mozilla-central/rev/1bc2c5b8873a
https://hg.mozilla.org/mozilla-central/rev/6a96db9759b7
https://hg.mozilla.org/mozilla-central/rev/0c9087692248

These all landed with the wrong bug number, by the way. Please be more careful in the future.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Assignee

Comment 29

5 years ago
Hah, sorrry about that!
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.