Closed Bug 1087969 Opened 10 years ago Closed 9 years ago

e10s - Tab drag to window fails to paint content for new tab on first display

Categories

(Firefox :: General, defect)

x86_64
Windows 7
defect
Not set
normal
Points:
5

Tracking

()

RESOLVED DUPLICATE of bug 1127727
Tracking Status
e10s m6+ ---

People

(Reporter: jimm, Assigned: handyman)

References

Details

+++ This bug was initially created as a clone of Bug #1087966 +++

str:

1) open two e10s windows
2) drag a tab from one to the other

result: the tab drags out and attaches to the new window, however the new tab will have blank content until you flip between other tabs once.
Summary: Tab drag to window fails to paint content for new tab on first display → e10s - Tab drag to window fails to paint content for new tab on first display
Flags: firefox-backlog+
Assignee: nobody → davidp99
Points: --- → 5
Flags: qe-verify+
Assignee: davidp99 → dtownsend
Status: NEW → ASSIGNED
Iteration: --- → 39.2 - 23 Mar
There isn't any point in working on this until bug 1132072 has landed
Depends on: 1132072
Iteration: 39.2 - 23 Mar → 39.3 - 30 Mar
Iteration: 39.3 - 30 Mar → 40.1 - 13 Apr
FWIW, I don't just see the problem just on first display; the tab never paints, it just stays in the spinner.
Looks like this has regressed to behave worse. I'll try to find the time to dig into this more
Sounds like handyman might be close to a fix for this in bug 1127727
Depends on: 1127727
Just going to assign this to you handyman since you have this in hand.
Assignee: dtownsend → davidp99
Iteration: 40.1 - 13 Apr → 40.2 - 27 Apr
The proposed patch for bug 1127727 does handle this issue so I'm duping it.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Iteration: 40.2 - 27 Apr → ---
You need to log in before you can comment on or make changes to this bug.