Support custom icons in bookmarks and personal toolbar

VERIFIED FIXED in mozilla0.9.8

Status

SeaMonkey
Bookmarks & History
VERIFIED FIXED
16 years ago
4 years ago

People

(Reporter: David Hyatt, Assigned: Robert John Churchill)

Tracking

Trunk
mozilla0.9.8
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
Outgrowth of bug 32087.  This bug will cover the support of custom icons in 
bookmarks and on the personal toolbar.
(Reporter)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.8

Comment 1

16 years ago
*** Bug 109330 has been marked as a duplicate of this bug. ***

Comment 2

16 years ago
Plat: PC --> All, OS: w2k --> All
OS: Windows 2000 → All
Hardware: PC → All

Comment 3

16 years ago
Bookmark update notification has an option to change the bookmark icon when the 
site updates.  If a site with an icon updates, I think the update icon should 
be shown instead of the site icon.

Updated

16 years ago
Blocks: 109669

Updated

16 years ago
Blocks: 106328

Comment 4

16 years ago
*** Bug 110224 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
*** Bug 110740 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

16 years ago
Created attachment 59383 [details] [diff] [review]
Get favicons into bookmarks-window/personaltoolbar/bmk-sidebar/bmk-menu

David, here's a diff to get favicons into bookmarks, including the bookmarks
management window, bookmarks sidebar panel, personal toolbar, and bookmarks
toolbar menu.

Please give it a shot and see how it works for you. The only significant bug I
see is that if a web page doesn't have a favicon, sometimes the default
(CSS-ized) icons disappear from the personal toolbar and bookmarks sidebar
panel until content is forced to recreate (such as closing/opening a bookmark's
parent folder in the sidebar).
(Assignee)

Comment 7

16 years ago
Created attachment 59384 [details]
Screenshot of browser with favicons shown in various spots

Screenshot of browser with favicons shown in various spots
(Assignee)

Comment 8

16 years ago
Oops, forgot to mention:  CSS rules need to be added to FORCE favicons to be 
16x16 in size.  I wasn't sure of all the places where those rules would need to 
be added, so I leave it as an exercise.  :)

A good example of a web site with a huge favicon is:
  http://gicl.mcs.drexel.edu/people/sevy/airport/128bit.html

If you bookmark that URL without having 16x16 enforced, it'll wreak havoc.

Comment 9

16 years ago
Hmmm. Screenshot makes mre realize a strong negative impact of this: instead of
a the nice, cohesive "Modern" color scheme, the personal toolbar (especially)
becomes a hodgepodge of random colors and graphics a la Konqueror. :)
(Assignee)

Comment 10

16 years ago
Good evangelism goes a long way (IMHO).
(Reporter)

Comment 11

16 years ago
validate="never" won't work unless you patch the XBL for <menuitem> and
<treecell> to make sure that the validate attribute is inherited in to the
anonymous <image>.  

Also, rather than building the bookmarks code into tabbrowser, I think you could
probably just patch the URL bar code in navigator.js instead.  The reason I say
this is that you really should only update the bookmark icon on a success, i.e.,
when an onload handlers fires.  The proxy icon in the url bar already listens
for a successful onload of a favicon, so hooking in there will be easier.

Come by if you want me to show you exact spots in the code.
(Reporter)

Comment 12

16 years ago
Yes, we also need to patch all skins to enforce 16x16 sizes on the images.  I
had to do this with tabs and with the url bar.
(Reporter)

Comment 13

16 years ago
--> rjc
Assignee: hyatt → rjc
Status: ASSIGNED → NEW
(Assignee)

Comment 14

16 years ago
David, good thoughts, thanks!  I'll stop by tomorrow to chat... I'm at home 
today.
Status: NEW → ASSIGNED

Comment 15

16 years ago
Matthew Miller:
I added bug 112347 for possibility to turn off icons in personal toolbar.
(Assignee)

Comment 16

16 years ago
Created attachment 59966 [details] [diff] [review]
New diff - now observes pref, CSS styles on width/height, etc
Attachment #59383 - Attachment is obsolete: true
Comment on attachment 59966 [details] [diff] [review]
New diff - now observes pref, CSS styles on width/height, etc

r=ben@netscape.com
Attachment #59966 - Flags: review+

Comment 18

16 years ago
Hyatt, can you please tell me what you changed to force the icon size to 16px?

MultiZilla has problems with larger icons, like this one:

http://cryptome.org/bxa-bernstein.htm

We like to fix this, but our project lead is far away, as sniper.

Thanks in advance,
-Neil.

Comment 19

16 years ago
Ok, fixed after adding .tab-icon {...} to multiviews.css
(Assignee)

Comment 20

16 years ago
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 21

16 years ago
does "icons" in "View" and View->Show/Hide also resize now? Various checkmarks
there look huge and jagged on Linux.

Comment 22

16 years ago
This is "kind of working" in the 2001120108 win32 build.

Things like bookmarks to slashdot and CNN work, but http://www.dilbert.com don't.
(Assignee)

Comment 23

16 years ago
Checkmark bug:  # 113027

Favicon from  http://www.dilbert.com/  works for me.

Comment 24

16 years ago
Every time I start up Moz, they only appear on the personal toolbar once I visit
the site. They need to be kept around like IE does. It's kind of annoying,
distracting, and basically worthless (in that I can't depend on the icon cue to
find a bookmark) having them change back and forth like this.

Is there a pref to disable them in bookmarks/PT only, while keeping them in URL
bar/tabs?
(Reporter)

Comment 25

16 years ago
Jeremy, do you have your disk cache enabled?  

Comment 26

16 years ago
I get a Netscape icon on: http://www.dilbert.com/ 
Is that the same for you guys, or is it just me?

Comment 27

16 years ago
I also get a Netscape icon on http://www.dilbert.com/.

moz 2001120108, win98

Comment 28

16 years ago
> do you have your disk cache enabled?  

It is *enabled*, but set to 0k. Mem cache is set to 32M. I really hate disk
cache as it slows browsing down with disk IO, and I absolutely don't trust it to
give me 100% fresh content even after I quit and restart. Since stupid cache
settings like "Compare pages: Automatically" aren't documented at all, I have no
idea what's really going on.

Is there a way to get the icons stored in a seperate disk cache (like IE does),
disable them just in the bookmarks/pt, or is there any work being done towards
advanced, customizable caches (say, only having it store images, or icons, or
only 20% html and the rest > 50k images.)

Any one of those three would solve the problem, though the first is ideal (which
could be a specific form of the third's system)

Comment 29

16 years ago
On the question of the Netscape icon, that is what the server at 
www.dilbert.com is serving as /favicon.ico. Netscape Enterprise
servers ship with that icon in place (and no, it's not a conspiracy).

As for www.dilbert.com, I am getting variable success in showing that icon
in the UI. Sometimes it is only in the urlbar, sometimes it's in urlbar and 
sidebar bookmarks, but not in bookmarks menu, or in personal toolbar bookmarks 
folder, and sometimes it's in all four places.

There is definitely a problem with caching that icon. A request to GET 
/favicon.ico is being issued on every visit to that page (I can see this in a 
test proxy server). After some amount of chicken sacrifice, I can sometimes get 
it to stop requesting /favicon.ico, but regardless the caching does not persist 
between sessions, and the next time I start the browser, I will repeatedly 
attempt to GET /favicon.ico from www.dilbert.com.

In a mozilla build from 11/30 a.m., the browser was not attempting to GET it
on each visit to www.dilbert.com. However, it similarly wasn't persisting 
between sessions (it would again need to GET /favicon.ico after a browser 
restart).

I can duplicate all of the above behaviour also at http://www.salon.com/. 
However, in looking at the HTTP headers and the top-level document's content, I 
don't see anything that would obviously cause problems (although both Salon
and Dilbert serve documents with '<meta HTTP-EQUIV="Pragma" 
CONTENT="no-cache">').

At any rate, this should really be a separate bug. Coming up.

Comment 30

16 years ago
The other bug is bug 113102.

Marking this as verified, since it is implemented (modulo bugs). So file 
separate bugs (hopefully on topic) for specific problems.
Status: RESOLVED → VERIFIED

Comment 31

16 years ago
wait a second

My personal toolbar icons are 14x16 under the Modern skin, not 16x16

Latest nightly 201120108

Comment 32

16 years ago
I *have* disk cache enabled, and my bookmark/personal toolbar icons seem to
appear and disappear at random. Is there a separate bug for this already?

Comment 33

16 years ago
Yes, the disappearing icons are not 'cached', not even when 
the diskcache is turned on. See bug 113102.

Theme issue: setting width and height to 16px in menu.css of .menu-iconic-icon
will make all menu icons, such as checkboxes and radiobutton also 16x16.
Better is too use max-width to specify the maximum size:

.menu-iconic-icon {
    max-width: 16px !important;
    max-height: 16px !important;
    list-style-image: inherit;
}
(Assignee)

Comment 34

16 years ago
I agree that setting max-width & max-height is better than the current
situation, but it still is not the perfect solution... because intermixing of
the 7x7 default-style icons with the 16x16 favicons leads to weird alignments.

Comment 35

16 years ago
Better still is to set the menu-iconic-item height and width to 16px only to
those icons that are anonymous children of bookmark-item menuitems. And put the
style in a bookmarks .css file so other apps don't even see it.

Comment 36

16 years ago
Why is support for icons in bookmarks removed?
Product: Browser → Seamonkey

Updated

10 years ago
Depends on: 323508
You need to log in before you can comment on or make changes to this bug.