Closed Bug 1088099 Opened 5 years ago Closed 2 years ago

Make PiTFT touch events more reliable

Categories

(Firefox OS Graveyard :: General, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: cjones, Unassigned)

References

Details

Attachments

(2 files)

There are a few issues I noticed in light testing

 - the mouse cursor is being drawn during touches, which probably means the driver is incorrectly sending hover_move events

 - we don't seem to be getting absolute event coordinates ... if I tap at (x,y), the position of the cursor depends on my past history of relevant movement.  This weird for both touch *and* mouse devices.

 - sometimes the events seem to stop working.  I couldn't find an easy way to reproduce that

 - it's really really hard to generate tap and touchmove events.  Possibly related to something above.
Note: when this is fixed, I think we'll run into the next problem that gaia doesn't have "software" UI for the power button and home button.  That means to use those you'd need to keep a keyboard plugged in, which is kind of weird.

Gaia UI folks will probably have an opinion on the best way to add those, if they're currently absent.
software home button can be turned on in Settings -> Developer -> Software home button.
Perfect, thanks :).
The touch events are not correct for me at all as the piTFT is using a portrait orientation, while touch events are read as landscape?
PiTFT  seems to be reliable with these two changes :
1) A kernel patch from Notro to prevent touchscreen freeze
more on https://github.com/notro/fbtft/issues/82

2) Calibration by adding an Input Device Configuration for PiTFT.
Push stmpe-ts.idc file in /system/usr/idc/
This file  declare driver device for touchscreen, and set max x/y  as report by driver in debug mode

See attachments
Attached file stmpe-ts.idc
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.