Closed Bug 1001404 (fxos-rpi) Opened 9 years ago Closed 5 years ago

[meta] FxOS on RaspberryPi (RPi)

Categories

(Firefox OS Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: dvigneshwer, Unassigned)

References

(Depends on 2 open bugs)

Details

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/34.0.1847.116 Safari/537.36

Steps to reproduce:

this is not exactly a bug but a failure i was trying to boot firefox os in a raspberry pi board and was unsuccessful if any one else have tried it please help me out , i have an awesome cool embedded system using raspberry board if i could make edit firefox os to act as software for its control it will turn really awesome may be the first browser based OS to control embedded system also falls in category of Internet of things.


Actual results:

there were errors in it and as a result it did not boot up


Expected results:

it should have booted properly and worked .
(In reply to dvigneshwer from comment #0)
> this is not exactly a bug but a failure i was trying to boot firefox os in a
> raspberry pi board and was unsuccessful if any one else have tried it please
> help me out , i have an awesome cool embedded system using raspberry board
> if i could make edit firefox os to act as software for its control it will
> turn really awesome may be the first browser based OS to control embedded
> system also falls in category of Internet of things.

There's been a working version in the past:

http://www.raspberrypi.org/firefox-os-for-raspberry-pi/

You might want to contact the author to get more information about his port.
Changing title, turning this into metabug for RPi work. We still need to land the linuxgl patches, create an input layer, other stuff.
Summary: can we boot firefox os in a raspberry pi board? → FxOS on RaspberryPi (RPi)
Summary: FxOS on RaspberryPi (RPi) → [meta] FxOS on RaspberryPi (RPi)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Bug 1026919 makes some useful improvements to the ARM JIT backend that are relevant to the RPi. The jit-tests pass on the RPi with the changes noted in bug 1026919 and the compiler is much more robust and is expected to be useful compiling asm.js code.
Depends on: 1026919
I'm adding bug 1060721 to the dependencies because the Pi is ARMv6 based IIRC so that bug could affect it too.
Depends on: 1060721
We don't have a great way to track glitches in the FFOS/RPi graphics stack since it crosses multiple repositories.  I'll file bugs here and link to the constituent repos as appropriate.
For the sake of completeness, I should note that software-composited graphics exhibit some invalidation glitches (because that code isn't really tested AFAIK), but since that's intended to be a temporary workaround I'm not going to file bugs or spend time on the glitches.
(In reply to Chris Jones [:cjones] temporarily active; ni?/f?/r? if you need me from comment #7)
> For the sake of completeness, I should note that software-composited
> graphics exhibit some invalidation glitches (because that code isn't really
> tested AFAIK), but since that's intended to be a temporary workaround I'm
> not going to file bugs or spend time on the glitches.

I should also add that BasicCompositor always allocates a temporary surface that's 100% unnecessary, because gonk windows are double-buffered.  The extra copy will ding perf, but compositing on the non-NEON ARM seems to quite dominate that extra copy.  So sideshow of a sideshow etc.
Well, after a repo sync my serial console isn't interactive and adb doesn't want to talk to my RPi over ethernet.  Not really what I want to deal with right now, let's hope it's something dumb ...
We've gotten into something of a bad state here after updates over the weekend --- can't build for arm6 anymore, boot animation broken, gecko crashing relatively early in startup.  Not what I want to be dealing in now with limited remaining time, but hey, that's what happens when you don't have CI.
We have a path to unbreaking armv6 in bug 1085599, but for now we'll freeze to gecko/b7b2dc40de355add3634cc972fc31521a8daeed3 and gaia/457a54fc3200b80e4f5e1cd3acaa062309230732 .
My guess is that the glitchy graphics with BasicCompositor come from gonk using a double-buffered framebuffer, but gecko expecting a single-buffered window when BasicCompositor is being used.  We could work around this by keeping around a window "backbuffer" in gonk widgetry, and then having CompositorParent draw into that.  Gonk widget would then copy its back buffer to framebuffer.  This is pretty dead simple so I might look into it.  As a followup, we could accelerate that copy using a dead-dumb DMA unit like the RPi has support for on the ARM side.
Depends on: 1103281
The Raspberry Pi 2 has been announced and is available. It features a quad-core ARM A7 processor, the Broadcom BCM2836 900MHz SOC, and 1GB of RAM. This is a much more capable target for fxos, moving from an ARMv6 to ARMv7, and increasing RAM from 512MB to 1GB.
http://www.raspberrypi.org/raspberry-pi-2-on-sale/
Depends on: 1214249
No longer depends on: 1214249
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.