Closed Bug 1088540 Opened 7 years ago Closed 7 years ago

[e10s] Email link does not work

Categories

(Firefox :: Toolbars and Customization, defect)

x86
Windows 7
defect
Not set
normal
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 37
Iteration:
37.3 - 12 Jan
Tracking Status
e10s m5+ ---

People

(Reporter: martin, Assigned: enndeakin)

References

Details

Attachments

(1 file, 2 obsolete files)

Story
Open some Tabs & browse to some pages
Try to use items that need the current tab context
from the toolbar or "Additional Tools and Features" (in Toolbar)

Function will fail or miss the current displayed tab page context.

Tried built in:
Share This Page-> Result Nothing. Expected: Sharing selector should appear
Email Link -> Result Nothing      Expected: Default email program should start and show email with url

Tried Extension:
Nightly Testers Tool - Insert Build ID into textbox (when textbox is active in current Tab - Result: Dialog offering to copy to clipboard 
Expected Result: BuildID should be added to textbox

I suspect that all these issues are probably caused by the same root cause.

Reproducible: Always on BuildID Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141023030203 CSet: 88adcf8fef83
tracking-e10s: --- → ?
Blocks: e10s
Component: General → Toolbars and Customization
Duplicate of this bug: 1088710
Assignee: nobody → mconley
Don't know what changed but share this page works for me now on build ID
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141111030203 CSet: cbe6afcae26c

Works:
Share this Page (only tried with facebook)

Does not work:
Email Page (fails)
Error in browser console:
>
17:03:11.868 "[CustomizableUI]" TypeError: aWindow is null
Stack trace:
MailIntegration.sendLinkForWindow@chrome://browser/content/browser.js:15294:5
CustomizableWidgets<.onCommand@resource:///modules/CustomizableWidgets.jsm:943:7
CustomizableUIInternal.handleWidgetCommand@resource://app/modules/CustomizableUI.jsm:1362:11

Nightly Testers Tool still can not insert its string into (this) texbox.
<
Flags: firefox-backlog+
This seems to be several bugs.

1. Sharing was fixing by bug 915547.
2. Email link is fairly simple to fix. I will attach a patch.
3. The Tester tools bug is essentially caused by 921935.
Attached patch Fix Email Link (obsolete) — Splinter Review
Attachment #8544699 - Flags: review?(mconley)
Attached patch Fix Email Link (obsolete) — Splinter Review
Oops, wrong patch
Attachment #8544699 - Attachment is obsolete: true
Attachment #8544699 - Flags: review?(mconley)
Attachment #8544700 - Flags: review?(mconley)
Comment on attachment 8544700 [details] [diff] [review]
Fix Email Link

Review of attachment 8544700 [details] [diff] [review]:
-----------------------------------------------------------------

This misses CustomizableWidgets' implementation of the email link button (it did say "toolbar items" in the summary...).

It also seems to me that if we're updating this anyway, we should just pass gBrowser.selectedBrowser. The MailIntegration method can take a browser and use a sendMessage with the url being browser.currentURI.spec and the title being browser.contentTitle. That avoids the CPOW and doesn't need any additional message passing, AFAICT. Would that work?
Attachment #8544700 - Flags: review?(mconley) → review-
Nightly Testers Tool works now on:
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:37.0) Gecko/20100101 Firefox/37.0 ID:20150106030201 CSet: 2a193b7f395c
Inserted the above string directyl into the text box. 
so one less issue to fix.
Email Link Function works also on:
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:37.0) Gecko/20100101 Firefox/37.0 ID:20150106030201 CSet: 2a193b7f395c

Ie: 
Click email Link Icon, Email Program opens with link pasted into draft email
Assignee: mconley → enndeakin
Attachment #8544700 - Attachment is obsolete: true
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8545355 - Flags: review?(gijskruitbosch+bugs)
Hi Neil, can you provide a point value.
Iteration: --- → 37.3 - 12 Jan
Flags: qe-verify?
Flags: needinfo?(enndeakin)
Points: --- → 2
Flags: needinfo?(enndeakin)
Comment on attachment 8545355 [details] [diff] [review]
Fix Email Link, v2

Review of attachment 8545355 [details] [diff] [review]:
-----------------------------------------------------------------

Ship it!
Attachment #8545355 - Flags: review?(gijskruitbosch+bugs) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/e38e801acf7b

The tester tools issue still exists. I can file a separate bug.
Summary: [e10s] Toolbar Items do not get context for current tab → [e10s] Email link does not work
https://hg.mozilla.org/mozilla-central/rev/e38e801acf7b
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 37
Duplicate of this bug: 1099959
@ comment 22 : Did you file a new bug for the testers tool? If so what bug number is it?

Just tested email link on Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:38.0) Gecko/20100101 Firefox/38.0 ID:20150123093302 CSet: a6bbabebed2f

Works for me now.
I filed bug 1125897 on the testers tool issue.
Confirming this is fixed using Firefox 37 beta 6 (build ID: 20150316202753) and latest Nightly, build ID: 20150318030202 on Windows 7 32-bit.
Status: RESOLVED → VERIFIED
Flags: qe-verify? → qe-verify+
You need to log in before you can comment on or make changes to this bug.