[v2.2] Fix test_dialer_make_call jenkins failure

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: RobertC, Assigned: RobertC)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
test_dialer_make_call started failing on Jenkins with the following failure:

Traceback (most recent call last):
File "/var/jenkins/1/workspace/flame-kk-319.b2g-inbound.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/marionette_test.py", line 264, in run
testMethod()
File "/var/jenkins/1/workspace/flame-kk-319.b2g-inbound.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/tests/functional/dialer/test_dialer.py", line 22, in test_dialer_make_call
self.assertEqual('normal', self.data_layer.current_audio_channel)
AssertionError: 'normal' != u'none'

Test needs to be updated.
(Assignee)

Comment 1

4 years ago
Created attachment 8510951 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25488

Because of the patch in Bug 1079810 the audio channel is no longer initialized when we launch the phone app.

It looks like there was additional power consumption caused by the audio channel being initialized by default.
Attachment #8510951 - Flags: review?(viorela.ioia)
Attachment #8510951 - Flags: review?(jlorenzo)
Comment on attachment 8510951 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25488

This one-line patch is exactly the fix we need.
Attachment #8510951 - Flags: review?(jlorenzo) → review+
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Per 1079810 comment 49, we need to uplift the modification to 2.1 too. Can you do it Viorela?
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → fixed
Flags: needinfo?(viorela.ioia)
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #4)
> Per 1079810 comment 49
Per bug 1079810 comment 49
(Assignee)

Comment 6

4 years ago
I will uplift the fix once the PR from bug 1079810 comment 49 is merged.
Flags: needinfo?(viorela.ioia)
Bug 1079810 comment 49 is an actual 2.1 commit.
(Assignee)

Comment 8

4 years ago
The test on v2.1 is a bit different from master, this is why it isn't failing.

I uplifted the test change in Bug 1011000.
The PR from here does not need to be uplifted because the test change contains the fix.
You need to log in before you can comment on or make changes to this bug.