Closed Bug 108860 Opened 20 years ago Closed 20 years ago

Javascript treemenu doesn't work in mozilla 0.9.4

Categories

(Core :: JavaScript Engine, defect)

x86
Windows 98
defect
Not set
major

Tracking

()

VERIFIED INVALID

People

(Reporter: wtff, Assigned: rogerl)

References

()

Details

To run the testcase for this bugreport, you can download the zip file from
https://spares.airbus.com/treemenu.zip

After extracting the archive, open the tree.html file with several browsers and
compare the result.
Mozilla 0.9.4 expands all menu nodes and it is impossible to collapse and expand
them.
On all other browsers, this javascript-menu works fine. This includes NS4.*,
IE4.*, IE5.* and IE6.*

I also tried out changing the mozilla's sqirks mode to offial mode by adding the
w3c doctype at the beginning of the html page, but the behaviour doesn't change.
Reporter:
Can you please retest this with a current build.
This bug is invalid with your old build. 
(Please use the the latest nightly builds if you report a bug [but we accept
also the latest milestone=0.9.5])
Invalid.

  if (doc.all)
    browserVersion = 1 //IE4
  else
    if (doc.layers)
      browserVersion = 2 //NS4
    else
      browserVersion = 0 //other 

This code will set browserVersion to 0 in Mozilla since we do not support either
of those non-standard DOMs.  The JS then proceeds to do nothing if
browserVersion is 0.  The JS needs to be updated to handle the standard W3C DOM
(which is supported by IE5/IE6 and Mozilla).
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
Marking Verified - 
Status: RESOLVED → VERIFIED
Blocks: 1090488
No longer blocks: 1090488
You need to log in before you can comment on or make changes to this bug.