Closed Bug 1089324 Opened 5 years ago Closed 2 years ago

Man page contains obsolete information suite/app/seamonkey.man.in the "simple shell script" doesn't exist any more.

Categories

(SeaMonkey :: Build Config, defect)

x86_64
Linux
defect
Not set

Tracking

(seamonkey2.57esr fixed)

RESOLVED FIXED
seamonkey2.57
Tracking Status
seamonkey2.57esr --- fixed

People

(Reporter: shill, Assigned: frg)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 SeaMonkey/2.30
Build ID: 20141013232806

Steps to reproduce:

suite/app/seamonkey.man.in contains obsolete information

https://hg.mozilla.org/comm-central/file/072eb34fcd1f/suite/app/seamonkey.man.in

.SH USAGE
\fB@MOZ_APP_NAME@\fR is a simple shell script that will set up the environment for
the actual executable, \fB@MOZ_APP_NAME@-bin\fR.

Nowadays, both "seamonkey" and "seamonkey-bin" are actual binaries.
$ file seamonkey-2.30/seamonkey*
seamonkey-2.30/seamonkey:     ELF 64-bit LSB  executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.18, BuildID[sha1]=0c01e630d0328b96c4c4dfc261d3b824f31e7ace, stripped
seamonkey-2.30/seamonkey-bin: ELF 64-bit LSB  executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.18, BuildID[sha1]=0c01e630d0328b96c4c4dfc261d3b824f31e7ace, stripped

Also (possibly a second, minor, bug) I am led to understand that "seamonkey-bin"
is intended to be a copy of "seamonkey", but in fact, they are slightly different:

$ diff -u <( objdump -xds seamonkey ) <( objdump -xds seamonkey-bin )
--- /dev/fd/63	2014-10-26 01:45:51.553832179 +0200
+++ /dev/fd/62	2014-10-26 01:45:51.553832179 +0200
@@ -1,6 +1,6 @@
 
-seamonkey:     file format elf64-x86-64
-seamonkey
+seamonkey-bin:     file format elf64-x86-64
+seamonkey-bin
 architecture: i386:x86-64, flags 0x00000112:
 EXEC_P, HAS_SYMS, D_PAGED
 start address 0x00000000004036b0
@@ -127,7 +127,7 @@
                   ALLOC
  27 .comment      0000003d  0000000000000000  0000000000000000  000186b0  2**0
                   CONTENTS, READONLY
- 28 .gnu_debuglink 00000014  0000000000000000  0000000000000000  000186ed  2**0
+ 28 .gnu_debuglink 00000018  0000000000000000  0000000000000000  000186ed  2**0
                   CONTENTS, READONLY
 SYMBOL TABLE:
 no symbols
@@ -6352,8 +6352,8 @@
  0020 61742034 2e342e36 2d332900 4743433a  at 4.4.6-3).GCC:
  0030 2028474e 55292034 2e372e33 00         (GNU) 4.7.3.   
 Contents of section .gnu_debuglink:
- 0000 7365616d 6f6e6b65 792e6462 67000000  seamonkey.dbg...
- 0010 ed4f52df                             .OR.            
+ 0000 7365616d 6f6e6b65 792d6269 6e2e6462  seamonkey-bin.db
+ 0010 67000000 ed4f52df                    g....OR.        
 
 Disassembly of section .init:


This may just be a quirk of how both binaries are built (instead of one being a copy of the other).

Why not just build only one binary?
OS: Windows 7 → Linux
suite/app/Makefile.in defines
https://hg.mozilla.org/comm-central/file/072eb34fcd1f/suite/app/Makefile.in

libs:: 
	cp -p $(MOZ_APP_NAME)$(BIN_SUFFIX) $(DIST)/bin/$(MOZ_APP_NAME)-bin$(BIN_SUFFIX)


but it looks like seamonkey-bin is ultimately not generated by this rule...
Perhaps the name of the file is embedded in the code because ...
The difference is 8 bytes = twice the length of "-bin".
Component: Build Config → Help
Summary: Man page contains obsolete information → Man page contains obsolete information suite/app/seamonkey.man.in the "simple shell script" doesn't exist any more.
This is clearly not a bug in the Help viewer/Seamonkey help files, so I'm bumping this back to build config.
Component: Help → Build Config
Why does it even have two identical binaries?  Why isn't one a link to the other?
Anything new here?
See Also: → 1288966
In house cleaning mode :)

The man seems not to be include in the package and is also not localized. Not sure if this is a good idea to include it.
Assignee: nobody → frgrahl
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8944766 - Flags: review?(iann_bugzilla)
Comment on attachment 8944766 [details] [diff] [review]
1089324-Manpage.patch

r=me, is there another bug for making sure the man page content is up to date?
Flags: needinfo?(frgrahl)
Attachment #8944766 - Flags: review?(iann_bugzilla) → review+
Blocks: 1444737
> is there another bug for making sure the man page content is up to date?

Filed bug 1444737 for further changes. Help or even just input what needs changed welcome.
Flags: needinfo?(frgrahl)
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/3d883f9f14a9
Fix SeaMonkey man pages and include them in the Linux package. r=IanN
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Seamonkey2.57
You need to log in before you can comment on or make changes to this bug.