Open Bug 1089344 Opened 6 years ago Updated 6 years ago

No images to speak of in Facebook newsfeeds and profiles (Works in Firefox and in mail notifications)

Categories

(SeaMonkey :: UI Design, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(firefox36 unaffected, firefox-esr31 unaffected, seamonkey2.33 affected)

Tracking Status
firefox36 --- unaffected
firefox-esr31 --- unaffected
seamonkey2.33 --- affected

People

(Reporter: tonymec, Unassigned)

References

Details

(Keywords: regression)

Attachments

(4 files)

Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0 SeaMonkey/2.33a1 ID:20141025003001 c-c:0ea5fe2ba57c m-c:e37231060eb4

This did not happen in yesterday's nightly. (2014-10-24)
Doesn't work in Safe Mode either.
Do the STR in Bug 1082680 apply in your case?

Bug 1082680 - If gfx.direct2d.use1_1 set to true i not see all graphics elements on web page
…and most images on Facebook profiles and newsfeeds are blank too. Images in email notifications are OK. I've seen the same bug on other sites; it's hard to tel what makes the difference.

Let's have a look at the stdout/stderr log… hm, there are a lot "javascript strict warnings" for fbstatic-a.akamaihd.net (which is one of the Facebook hosts); also many undecipherable lines ending in "no module at" plus a hex value.

This is an hourly build,
Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0 SeaMonkey/2.33a1 ID:20141026091016 c-c:57ec66cb59ab m-c:289ce72324ce
compiled without symbols. I have its crashreporter-symbols.zip but in this case I don't know what to look for in it, and of course it is too big for a Bugzilla attachment.

I'll attach today's log, who knows? Maybe someone can get some useful info out of it.
Attached file stdout/stderr log
(mid-air collision) I'l check those STR but first, let me not lose the clipboard.
I have no preferences defined (neither defaulted nor user-set) with any name starting in gfx.di
After defining a new pref of that name (with value true) and reloading a Facebook page I see no change. Let's restart SeaMonkey to see if it makes a difference…
(In reply to Tony Mechelynck [:tonymec] from comment #8)
> After defining a new pref of that name (with value true) and reloading a
> Facebook page I see no change. Let's restart SeaMonkey to see if it makes a
> difference…

It doesn't. Conclusion: This is not bug 1082680.
(In reply to Tony Mechelynck [:tonymec] from comment #8)
> After defining a new pref of that name (with value true) and reloading a
> Facebook page I see no change. Let's restart SeaMonkey to see if it makes a
> difference…

with value _false_ actually. Typed one instead of the other into Bugzilla.
Summary: No Facebook avatars (Works in Firefox) → No images to speak of in Facebook newsfeeds and profiles (Works in Firefox and in mail notifications)
In groups (both open and closed ones) I can see the top banner. Not in profiles. Avatars and posted images I can't see in either. I can see them in the mailer, but of course there the images are zoomed out.
You need to log in before you can comment on or make changes to this bug.