'page icon' linking is sensitive to capitalisation (case)

VERIFIED FIXED

Status

SeaMonkey
UI Design
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: Michael Nahrath, Assigned: David Hyatt)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
<http://www.buhev.de/index.html> is a frameset definition file.

In its 'head' element there is a definition for a page icon:
<link rel="SHORTCUT ICON" href="http://www.buhev.de/img/favicon.ico">

The framed pages don't have a linked reference to an icon.

According to the resolved bug #32087 this icon should be displayed in the URL
bar and in the tab, but only the generic flag-icon is displayed.

In my understanding if there are multiple resources displayd at once (typically
 in a framed situation) the <link rel="icon" ...> reference of the topmost
frameset (that one that gives the URL in the URL bar) should be used and all
others should be ignored.

There have been discussion about the frameset issue in bug #2800 and #87428, but
i can't remember what the final solution was.

Greeting, Michi

P.S.:  This might as well be an issue of capitalisation...
(Reporter)

Comment 1

16 years ago
After more testing: The frameset is not the problem. 

It is only capitalisation.

<link rel="shortcut icon" ...> is OK whereas <link rel="SCHORTCUT ICON" ...> is
ignored.

Compare <http://www.buhev.de/seiten/archiv.html> to
<http://www.buhev.de/seiten/archiv-test01.html>!

This is especially problematic because multiple tutorials 
(eg. <http://www.favicon.com/#linkTag> and
<http://msdn.microsoft.com/workshop/Author/dhtml/howto/ShortcutIcon.asp>) give
their example with capitalized attribute value. 

Most web authors simply cut&pasted it from these locations.
Summary: 'page icon' linked in the frameset file is ignored → 'page icon' linking is sensitive to capitalisation
(Assignee)

Comment 2

16 years ago
I fixed this tonight.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
*** Bug 109032 has been marked as a duplicate of this bug. ***
QA Contact: sairuh → claudius

Updated

16 years ago
Summary: 'page icon' linking is sensitive to capitalisation → 'page icon' linking is sensitive to capitalisation (case)
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.