Update context-menu.js, selection.js & panel.js metadata to work in SeaMonkey

RESOLVED DUPLICATE of bug 1023661

Status

Add-on SDK
General
RESOLVED DUPLICATE of bug 1023661
4 years ago
4 years ago

People

(Reporter: lemon_juice, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
This is very similar to Bug 1071048 that was successfully applied to the sdk to allow compatibility of Ghostery with SeaMonkey.

This bug is about including SeaMonkey in the metadata of the following files:

sdk/context-menu.js
sdk/selection.js
sdk/panel.js

These modules appear to work fine in SeaMonkey if they aren't blocked by the metadata definition that does not include SeaMonkey in the engine list. Enabling them to work will increase SeaMonkey compatibility with Firefox extensions based on the addon sdk. For example, extensions QrCodeR and Awesome Screenshot Plus both work fine in SeaMonkey (by only adding SeaMonkey ID to install.rdf) if the above sdk modules are allowed to run. Potentially, there may be more extensions that will benefit from this and in such cases addon authors may easily add SeaMonkey support with minimal amount of work.

In bug 1071048 it was suggested that SeaMonkey should not be added explicitly to the engine list because the sdk devs do not officially support or test sdk on SeaMonkey. Therefore, I suggest marking it in the code that SeaMonkey is not officially supported like this (context-menu.js):

module.metadata = {
  "stability": "stable",
  "engines": {
    // TODO Fennec support Bug 788334
    "Firefox": "*",
    "SeaMonkey": "*"  // SeaMonkey is not officially supported!
  }
};

Of course, any other indication of no official support for SeaMonkey would be fine. Since it looks like the engine list can't be removed altogether in these cases (because then Fennec would become automatically included in the rule) we need to add a separate entry for SeaMonkey.
(Reporter)

Comment 1

4 years ago
Oh, I think I was a bit late as I didn't notice the work on this has already progressed in bug 1023661 recently.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1023661
You need to log in before you can comment on or make changes to this bug.