Closed Bug 1090571 Opened 5 years ago Closed 2 years ago

[Calendar] Lagged response when selecting/deselecting multiple calendars

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(tracking-b2g:+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 affected)

RESOLVED WONTFIX
tracking-b2g +
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected

People

(Reporter: rmead, Assigned: gaye)

References

()

Details

(Keywords: polish, regression, Whiteboard: [2.1-exploratory-3][polish])

Attachments

(1 file)

Attached file Flame2.2logcat.txt
Description:
If you have multiple calendars, and you rapidly switch them on/off, the check mark icons next to the calendar name lags and blinks a few times.
   
Prereq: Have at least 4 calendars added to 'Calendar' app.

Repro Steps:
1) Update a Flame device to BuildID: 20141028040202
2) Tap the 'Calendar' app
3) Tap the Drawer icon(3 horizontal bars)
4) Quickly tap all the calendars and observe the check mark in the right hand column
  
Actual:
The check mark will appear and disappear a few times.
  
Expected: 
The check mark will either appear or disappear once.
  

Flame 2.1(319mb)(KitKat Base)(Full Flash)

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141028040202
Gaia: 6a7fb482a03c5083ef79b41e7b0dfab27527cd04
Gecko: a255a234946e
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

  
Repro frequency: 100%
See attached: logcat, video clip - http://youtu.be/4aYI9rxPHDA
This bug does NOT occur on Flame 2.1 (319mb) and Flame 2.0 (319mb)

If you have multiple calendars linked to the Calendar app and you quickly enable/disable them, the check mark appears/disappears as it normally should.

Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141028001203
Gaia: a0174f7166745256aaca1cb3aa9f894033fbffa6
Gecko: 43bda3541f6b
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141028000202
Gaia: 5e532a84e762b1bb6231756182cf1465671a061e
Gecko: 124f0bed1700
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 32.0 (2.0)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
I posted wrong environment variable header in comment 0. It should read:

Flame 2.2(319mb)(KitKat Base)(Full Flash)

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141028040202
Gaia: 6a7fb482a03c5083ef79b41e7b0dfab27527cd04
Gecko: a255a234946e
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Nominating this to block 2.2. This is very confusing to the end user, as it is not clear whether or not the proper calendars have been selected or deselected.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
QA Contact: jmercado
Cause:  Bug 1023664 seems to be the cuase of this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20140903134226
Gaia: dd47e0df260ac41010c623604e0c67921d3a8fb4
Gecko: 03665e187d8c
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 35.0a1 (2.2) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20140903141823
Gaia: 2991746d61bae865f6e0c0dfacda07ae3c2f2fbd
Gecko: 5bdf9e64ca84
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 35.0a1 (2.2) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: dd47e0df260ac41010c623604e0c67921d3a8fb4
Gecko: 5bdf9e64ca84

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: 2991746d61bae865f6e0c0dfacda07ae3c2f2fbd
Gecko: 03665e187d8c

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/dd47e0df260ac41010c623604e0c67921d3a8fb4...2991746d61bae865f6e0c0dfacda07ae3c2f2fbd
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Caused by Bug 1023664 - can you take a look Gareth
Blocks: 1023664
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(gaye)
QA Contact: jmercado
triage: not blocking but will mark this as priority and will follow up on the regression window in comment 4.
blocking-b2g: 2.2? → ---
tracking-b2g: --- → +
Keywords: polish
Whiteboard: [2.1-exploratory-3] → [2.1-exploratory-3][polish]
Assignee: nobody → gaye
Flags: needinfo?(gaye)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.