Debugger pauses execution but is useless until kickstarted

RESOLVED DUPLICATE of bug 1075676

Status

()

Firefox
Developer Tools: Debugger
RESOLVED DUPLICATE of bug 1075676
4 years ago
4 years ago

People

(Reporter: jaws, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 8513057 [details]
Screencast of bug

STR:
Open a webpage
Place a breakpoint in the content JS
Reload the page
The breakpoint is hit

Expected results:
The state at the breakpoint can be viewed, and you can step to the next line of code.

Actual results:
The debugger shows a "pause" icon, but you can't step forward or view state.
You must click on the "pause" icon to get it to switch to "play", and then the debugger will auto-pause on that breakpoint again.

See attached screencast.
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #0)
> Created attachment 8513057 [details]
> Screencast of bug
> 
> STR:
> Open a webpage
> Place a breakpoint in the content JS
> Reload the page
> The breakpoint is hit
> 
> Expected results:
> The state at the breakpoint can be viewed, and you can step to the next line
> of code.
> 
> Actual results:
> The debugger shows a "pause" icon, but you can't step forward or view state.
> You must click on the "pause" icon to get it to switch to "play", and then
> the debugger will auto-pause on that breakpoint again.
> 
> See attached screencast.

Thanks for reporting this Jared. This looks like a frontend bug. My suspicion is that the frontend doesn't properly update it's paused state when the breakpoint is hit, so it thinks the page is still running. Pressing the pause icon puts the UI in the paused state, after which you should be able to continue as normal.

We have a dedicated meta bug for all bugs related to breakpoints, so I'm putting this bug there.
Blocks: 1074182
Actually, this fits better as a frontend bug, since the fix needs to be made there.
Blocks: 1074592
No longer blocks: 1074182
And turns out that bug 1075676 is about the same issue.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1075676
You need to log in before you can comment on or make changes to this bug.