All users were logged out of Bugzilla on October 13th, 2018

UI glitches when scrolling the Menu Panel

RESOLVED DUPLICATE of bug 1169331

Status

()

RESOLVED DUPLICATE of bug 1169331
4 years ago
a year ago

People

(Reporter: cornel_ionce, Unassigned)

Tracking

({regression})

Trunk
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox33 unaffected, firefox34 affected, firefox35 affected, firefox36 affected, firefox37 affected)

Details

Attachments

(2 attachments)

Created attachment 8513447 [details]
UI glitches.gif.gif

Reproduced on:
- latest Nightly, build ID: 20141029030207
- latest Aurora, build ID: 20141029004001
- Firefox 34 beta 4, build ID: 20141027152126


STR:
1. Open Firefox
2. Click on the Menu Panel and enter Customize Mode.
3. Drag several items into the Menu Panel and exit Customize Mode.
4. Resize the window until the Menu Panel will display a scrollbar.
5. Click on the Menu Panel and scroll it.

Expected Results:
The Menu Panel is correctly scrolled and items are displayed correctly.

Actual Results:
Several UI glitches can be seen during scrolling.

Notes:
This issue affects Windows only, it does not reproduce on MAC OS X 10.9.5 and Ubuntu 12.04.
It does *not* reproduce on Firefox 33.0.2, build ID: 20141027150301

Comment 1

4 years ago
Can you reproduce with OMTC and/or hardware acceleration turned off? Can you attach the about:support graphics output of the machine you're seeing this on?
Component: Theme → Untriaged
Flags: needinfo?(cornel.ionce)
Product: Firefox → Core
Created attachment 8513475 [details]
graphics.txt

I can reproduce this with OMTC and HWA disabled. 
I've reproduced this on two different machines so I'll attach the graphics info for both of them.
Flags: needinfo?(cornel.ionce)

Updated

4 years ago
Flags: needinfo?(gijskruitbosch+bugs)

Comment 3

4 years ago
I can't reproduce this on Windows 8, at least... can you find a regression window?
status-firefox33: --- → unaffected
status-firefox34: --- → affected
status-firefox35: --- → affected
status-firefox36: --- → affected
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(cornel.ionce)
Last good nightly: 20140731030206
First bad nightly: 20140801030201

Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=005424a764da&tochange=104254bd1fc8
Flags: needinfo?(cornel.ionce)
Keywords: regression
QA Contact: cornel.ionce
status-firefox37: --- → affected

Comment 5

3 years ago
It was fixed for me on Win7 somewhere between 40 and 41. Do you confirm?
Flags: needinfo?(cornel.ionce)
This seems to be indeed fixed as I'm no longer seeing this neither in Firefox 41, nor latest 44.0a1 Nightly. Tested with 3 different machines and the issue is not reproducing.

Closing as WFM. Thanks!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(cornel.ionce)
Resolution: --- → WORKSFORME

Comment 7

3 years ago
Okay. I actually was going to track down the actual fix, but I have no spare time. I think that bug 1133558 is the same issue, and also was fixed. Can't close it since I got no feedback there
Also, ESR 38 is affected, so somebody may want to apply that patch to ESR w/o waiting 4.5 months
Blocks: 1133558

Comment 8

3 years ago
I bisected (eventually)
No longer blocks: 1133558
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1169331
Moving from Core::Untriaged to Core::General https://bugzilla.mozilla.org/show_bug.cgi?id=1407598
Component: Untriaged → General
You need to log in before you can comment on or make changes to this bug.