Closed Bug 1133558 Opened 7 years ago Closed 6 years ago

Div with horizontal scroll displays text blurred while scrolling, stays for seconds

Categories

(Firefox :: Untriaged, defect)

35 Branch
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 1169331
Tracking Status
firefox40 --- affected
firefox41 --- unaffected
firefox42 --- unaffected
firefox43 --- unaffected
firefox-esr38 --- affected

People

(Reporter: y.ateya, Unassigned, NeedInfo)

Details

(Whiteboard: [DUPEME])

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150125222008

Steps to reproduce:

While browsing this page:

https://github.com/asimov-deploy/asimov-deploy/wiki

in section "Deploy Agent Configuration". I was scrolling the scrollable the div horizontally.

I am using Ubuntu 14.04 x64 bit


Actual results:

The text in the div blurs while scrolling (hold mouse over horizontal scroll bar), and is kept blurred for seconds after releasing the mouse.
See the attached screen shot.


Expected results:

Test should appear clear.
Severity: normal → minor
Does it happen
* in safe mode (https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode)?
* with a Nightly build https://nightly.mozilla.org/ (use a new profile: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles)?


Also, which video driver are you using?  Please post the Graphics section from about:support
Flags: needinfo?(y.ateya)
Summary: Div with horizontal scroll displays text blurred while scrolling → Div with horizontal scroll displays text blurred while scrolling, stays for seconds
* Graphics section in about:config
Graphics
Adapter Description	Intel Open Source Technology Center -- Mesa DRI Intel(R) Sandybridge Mobile
Device ID	Mesa DRI Intel(R) Sandybridge Mobile
Driver Version	3.0 Mesa 10.3.0
GPU Accelerated Windows	0/1 Basic
Vendor ID	Intel Open Source Technology Center
WebGL Renderer	Intel Open Source Technology Center -- Mesa DRI Intel(R) Sandybridge Mobile
windowLayerManagerRemote	false
AzureCanvasBackend	cairo
AzureContentBackend	cairo
AzureFallbackCanvasBackend	none
AzureSkiaAccelerated	0


* Yes, same wrong behavior in safe mode.
* Same wrong behavior when using new profile on same Firefox version.



**Problem fixed** when using new profile on nightly build (38.0a1). Thanks.
Flags: needinfo?(y.ateya)
(In reply to y.ateya from comment #2)
> 
> **Problem fixed** when using new profile on nightly build (38.0a1). Thanks.

This problem has been driving us crazy with our web based EMR.  For us the problem is *NOT* fixed in 38 ESR.  And this is with using no plugins, no extensions, a fresh profile, and default settings.  I have a video that clearly illustrates the issue for us with vertical scrolling "smearing" parts of the screen, but I can't post it because it contains confidential data.  I do have a still screenshot I will attach with the sensitive data obliterated.

I am not sure if this is the same bug, but it sounds similar and I can't find any other bug as close as this one.
This still shot shows how sections can pause and "smear" vertically when scrolling.  Linux Firefox 38 ESR.  

When this section appears (section A) in the browser, grabbing the scroll bar and moving up and down will corrupt the display, making what appears to be strange bars, smeared areas, or blank areas and usually will remain that way for up to 4 seconds before the screen is updated properly.  This problem will continue until some other MDS section in the app (left side) is selected, then the problem immediately disappears. And the problem will not occur if another section is then selected (including A). However, the problem will return if you exit that part of the web interface and pull up an MDS again.

I had to red-out/redact the confidential information for the screenshot.
Sorry, I have additional information I meant to post, above...

This "smearing/pause" bug was not a problem in Firefox 24.  We noticed it when we upgraded to Firefox 35 (yes, I know that was a big jump). So I started testing every version and narrowed it down to breaking in Firefox 28 and OK in Firefox 27.  So I then downloaded and tested in every daily build- it was OK up through Dec 8 2013 version and broke on the Dec 9 2013 build. Unfortunately, it is only affecting the Linux version and not MS-Windows version of Firefox. Confirmed not working properly in RHEL 6.1, Fedora 17, and Fedora 20 (three different physical machines) in Firefox 28 through 38.
Do you still have this issue? If yes, please do the following:

1. Open this URL in new tab:    data:text/html,<body onclick="test;test;test;test;test;test;test;test;test;test;test;test;test;test;test;test;test;test;test;test;test;test;">
2. Open Devtools(Ctrl+Shift+I), click "Inspector" tab.
3. Press (ev) button  [watch video]
4. Try to scroll up and down to see if you have the same glitch as on the video

If you do:   Now we have STR. I suggested these steps because it's reproducible every time for me.
Install Nightly and try the same steps.   https://nightly.mozilla.org/
Flags: needinfo?(crxssi)
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → Unspecified
Hardware: x86_64 → Unspecified
Whiteboard: [DUPEME]
Depends on: 1090935
This was fixed in bug 1169331. Feel free to reopen if you still see this issue on Firefox 41+
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1169331
No longer depends on: 1090935
You need to log in before you can comment on or make changes to this bug.