[ringtones] JavaScriptError: (17) TypeError: this._source is undefined

RESOLVED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Ringtones
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: squib, Assigned: squib)

Tracking

unspecified
2.1 S8 (7Nov)
x86_64
Windows 7
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(b2g-v2.0 fixed, b2g-v2.0M fixed, b2g-v2.1 fixed, b2g-v2.2 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
This broke from bug 1043762. I also fixed a regression from bug 1048673 because I happened to notice it while mucking about in here. Not much else to say here. Have an error log:

https://taskcluster-artifacts.s3-us-west-2.amazonaws.com/JgYe6YLmTA2mFQL0nDv-xg/5/public/logs/live_backing.log?AWSAccessKeyId=AKIAIZOQG4W6WG3PH3RQ&Expires=1414606736&Signature=bQHsTYkRGTZR0uizGxZ5yxDU1Rw%3D
(Assignee)

Comment 1

4 years ago
Created attachment 8513700 [details] [review]
Fix it
Assignee: nobody → squibblyflabbetydoo
Status: NEW → ASSIGNED
Attachment #8513700 - Flags: review?(dflanagan)
Comment on attachment 8513700 [details] [review]
Fix it

looks good to me
Attachment #8513700 - Flags: review?(dflanagan) → review+
(Assignee)

Comment 3

4 years ago
Landed: https://github.com/mozilla-b2g/gaia/commit/37089e0173b957b8dd950e330db21b4ba7e2b481
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Flags: in-testsuite+
(Assignee)

Comment 4

4 years ago
Comment on attachment 8513700 [details] [review]
Fix it

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1043762, bug 1048673
[User impact] if declined: Previewing ringtones can break if you hide the ringtones app and return to it; also, without this patch, the tree is red
[Testing completed]: Backed by existing marionette tests
[Risk to taking this patch] (and alternatives if risky): Low-risk
[String changes made]: None
Attachment #8513700 - Flags: approval-gaia-v2.1?
Attachment #8513700 - Flags: approval-gaia-v2.0?

Comment 5

4 years ago
(In reply to Jim Porter (:squib) from comment #4)
> Comment on attachment 8513700 [details] [review]
> Fix it
> 
> [Approval Request Comment]
> [Bug caused by] (feature/regressing bug #): bug 1043762, bug 1048673
> [User impact] if declined: Previewing ringtones can break if you hide the
> ringtones app and return to it; also, without this patch, the tree is red
> [Testing completed]: Backed by existing marionette tests
> [Risk to taking this patch] (and alternatives if risky): Low-risk
> [String changes made]: None

Bhavana, we need your help to uplift this. it will also fix bug 1087200.
Flags: needinfo?(bbajaj)
Attachment #8513700 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Thanks fabrice!
Flags: needinfo?(bbajaj)

Updated

4 years ago
Attachment #8513700 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+

Updated

4 years ago
Blocks: 1087200
v2.1: https://github.com/mozilla-b2g/gaia/commit/8b18b80210c558c1140a52842a8cf4e082f25b3d
status-b2g-v2.1: --- → fixed
status-b2g-v2.2: --- → fixed
Target Milestone: --- → 2.1 S8 (7Nov)
Needs rebasing for v2.0 uplift.
status-b2g-v2.0: --- → affected
Flags: needinfo?(squibblyflabbetydoo)
(Assignee)

Comment 9

4 years ago
If possible, please grant 2.0 approval for bug 1048673. Then we won't need rebasing (and 2.0 will be slightly less broken).
Flags: needinfo?(squibblyflabbetydoo)
status-b2g-v2.0M: --- → fixed
You need to log in before you can comment on or make changes to this bug.