Closed Bug 1091334 Opened 7 years ago Closed 7 years ago

[FFOS2.0][Woodduck][BT] The music played in BT headset will be paused when insert in and out a wired headset.

Categories

(Firefox OS Graveyard :: Gaia::Music, defect)

defect
Not set
normal

Tracking

(b2g-v2.0 affected, b2g-v2.0M wontfix, b2g-v2.1 unaffected, b2g-v2.2 unaffected)

RESOLVED DUPLICATE of bug 1083129
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- wontfix
b2g-v2.1 --- unaffected
b2g-v2.2 --- unaffected

People

(Reporter: sync-1, Unassigned)

References

Details

PR Reporter:邢艳
 contact:0752-2639551(61551)
 		
  DEFECT DESCRIPTION:
 >The music played in BT headset will be paused when insert in and out a wired headset.
 
  REPRODUCING PROCEDURES:
 1.Open BT and connected with a BT stereo headset;
 2.Play a music and the sound is in BT headset normally, then insert a wired headset and the sound of music still in BT headset normally;
 3.Insert out the wired headset ,then the music in BT headset paused.--KO
 
 PS:1.Soul3.5 FF和手机目前行为一致;
 2.安卓的设计机制是,连上蓝牙耳机声音在蓝牙耳机播放,此时插入有线耳机声音在有线耳机播放,再拔出有线耳机声音回到蓝牙耳机播放,整个过程不会出现声音暂停。
 
  EXPECTED BEHAVIOUR:
 >The sound should played in wired headset after insert it in, or the sound always play in BT headset and there is no paused.
  
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
Hi Norry,
qawanted for Woodduck 2.0M and Flame 2.0. Thanks!
Flags: needinfo?(fan.luo)
Keywords: qawanted
Priority: P2 → --
Hi Shawn,
Is the current behavior dy design? Thanks!
Flags: needinfo?(shuang)
Blocks: Woodduck
This should consult with UX and Music application owner. ni Jenny/Music owner.
Flags: needinfo?(shuang) → needinfo?(dkuo)
I would say this is a duplicate of bug 1083129, Josh, please close it if I am right for this, thanks.
Flags: needinfo?(jelee)
Flags: needinfo?(dkuo)
QA Contact: ckreinbring
Hi Josh,
In latest Flame 2.0 version, there is no voice when we play music or adjust volume or other operations, and the media function on woodduck is not needed to test. So the bug is not verified.
Flags: needinfo?(fan.luo)
The bug repros on Flame 2.0 engineering with shallow flash.  However, I suspect that is because we don't yet have a 2.0 build for today.
Actual result: When a headset is plugged in while music is playing through a Bluetooth headset, music will continue playing through the Bluetooth headset though it will be a little quieter.  When the plugged in headset is unplugged then the music is paused and cannot be heard through the Bluetooth headset.

BuildID: 20141030181855
Gaia: 7b8df9941700c1f6d6d51ff464f0c8ae32008cd2
Gecko: 82a6ed695964
Platform Version: 32.0
Firmware Version: V188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

--------------------------------------------------------------------------------------------------------

The bug does not repro on Flame 2.2 or Flame 2.1 ungineering on shallow flash.  However, I was able to repro it on a Flame 2.2 build from yesterday.
Actual result: When a headset is plugged in while music is playing through a Bluetooth headset, the music will stop playing through the Bluetooth headset and start playing through the plugged in headset.  When the plugged in headset is unplugged, the music will resume playing through the Bluetooth headset.  

Flame 2.2
BuildID: 20141031062029
Gaia: a07994714f0552f89801d6097982308d8b0a1ee1
Gecko: 21fbf1e35090
Platform Version: 36.0a1
Firmware Version: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Flame 2.1
BuildID: 20141031025654
Gaia: 224dfde17af943b583aa0a97936343c7267c7996
Gecko: 12a56ce89cb9
Platform Version: 34.0
Firmware Version: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
blocking-b2g: --- → 2.0M?
Triage:
Minor issue. Will not fix in 2.0M but future release has been fix with bug 1083129
Status: NEW → RESOLVED
blocking-b2g: 2.0M? → ---
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1083129
You need to log in before you can comment on or make changes to this bug.