mozilla.org needs a favicon.ico

RESOLVED FIXED

Status

www.mozilla.org
General
--
enhancement
RESOLVED FIXED
17 years ago
6 years ago

People

(Reporter: mw, Assigned: Dawn Endico)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(13 attachments)

(Reporter)

Description

17 years ago
Per request by Gervase Markham in <3BEAD43B.9000207@mozilla.org>. Let the 
proposals roll in!
(Reporter)

Comment 1

17 years ago
Created attachment 57101 [details]
The Beast as 16x16 (favicon.ico)

This is my proposal -- the grining Beast of Mozilla, of course.

Comment 2

17 years ago
Created attachment 57141 [details]
another 16x16 icon (png)

Comment 3

17 years ago
Created attachment 57173 [details]
better icon (not truncated on the left)

mozilla do have ears... :o)

Comment 4

17 years ago
Created attachment 57177 [details]
Revolution font "M" icon

A lower case M in the Revolution font, like in the banner.

Comment 5

17 years ago
CCing Gerv because he asked for the bug to be created. It's only fair to spam
him as well.

Making a diff is somewhat harder, since we're not 100% sure what format we'll
end up with in the end. Using a GIF or PNG is good, but then no IE users will
ever see it. Yet again we're in a situation where we can do something IE can't.
But, the code in the end would be:

<LINK REL="SHORTCUT ICON" HREF="http://www.mozilla.org/favicon.XXX">

with the XXX as the final file's extention.

Comment 6

17 years ago
Created attachment 57184 [details]
Animated FavIcon M clock-sweep to Dino and back

This is an animated FavIcon since Mozilla can make use of multiple formats.
This is the Revolution font "m" transitioning in a clock-sweep to the red
Mozilla Dino, and then progressing back to the "m" with a clock sweep so the
animation is smooth.

Comment 7

17 years ago
Don't forget b.m.o (ant?), bonsai (tree icon?), tinderbox (fire?), lxr (??)

Comment 8

17 years ago
Eek.  Animated favicons are a new evil we've unleashed, and I'd rather we
didn't encourage them.  Moving 'things' at the visual periphery distract
the eye and mind from content.
Please - no animated favicons.

Gerv

Comment 10

17 years ago
There's an opportunity here to "blame lou" and add <blink> support to animated
favicons!

Comment 11

17 years ago
Created attachment 57245 [details]
Made from Giovanni's icons - 1

Comment 12

17 years ago
Created attachment 57246 [details]
Made from Giovanni's icons - 2

I have these two icons as favicons at

http://www.geocities.com/pratiksolanki/index.html
http://www.geocities.com/pratiksolanki/howto.html

Comment 13

17 years ago
Created attachment 57415 [details]
staying with the theme from the side

Comment 14

17 years ago
Created attachment 57419 [details]
moz-branding 'm' from the spinner (221 bytes)

The 'm' from the mozilla-branded moz chrome.

Comment 15

17 years ago
Created attachment 57420 [details]
filled m

I thought too about the "moz-branding" 'm'. The problem is that the  'm' can be
hardly recognized in such a degraded 16x16 icon.
The icon I have attached is a filled 'm' like the one on the bottom left corner
of the windows but larger.
Nevertheless, I still prefer the funnier and colorful attachment 57173 [details].

btw, the selected icon should also replace the search engine icon.

Comment 16

17 years ago
Created attachment 57422 [details]
same as 57415 but in png

Comment 18

17 years ago
I do like that icon concept, though in this
particular implementation the m is rendered
too 'fat' for my liking.  I prefer the proportions
of the icon used in the component bar -- in fact
if someone were to rip the 'm' icon from the
component bar wholesale, pad it out to 16x16
and submit that, it'd get my vote.

Comment 19

17 years ago
Created attachment 57597 [details]
Star Logo (png)

I have always been partial to the star logo...
(Assignee)

Comment 20

17 years ago
Marking fixed. I used a png image instead of /favicon.ico so unix
(and mac?) can use the image in toolbars (bug 109037)

<LINK REL="icon" HREF="images/mozilla-16.png" TYPE="image/png">


Used image contributed by Hideki Itoh <hide@pixture.com> a while ago
for something else.

Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 21

17 years ago
I don't rate that choice overly highly -- it suffers
from the problem that many favicons have, which is
that it simply looks like an indistinct blob.  But
beggars can't be choosers, as they say...

Comment 22

17 years ago
Suggestion, update the "about:" URL to include the icon.

Comment 23

17 years ago
Agreed, the filled "m" submission is clear at that resolution, the unfilled "m"
suffers from aliasing.

Suggest that it's skinnable.
(Assignee)

Comment 24

17 years ago
neither "about:" nor "about:mozilla" are on the web site. They are both
checked in to the tree and distributed with the browser.

Comment 25

17 years ago
The white background doesn't look so good. Perhaps the background colour should
be changed to be transparent or to match colour of the modern theme tabs? Or
would this look bad with classic, or in the location bar? 

Comment 26

17 years ago
I understand that "about:..." content is local, that's why a local res: URL can
be used to point to a local resource (e.g. a skin resource) instead of an HTTP
URL for the icon.

Comment 27

17 years ago
...for those browsers without the local "res:" icon, then the "http:" URL could
be used.  A little javascript could test to check for the local file first.

OK, OK, I'm over-engineering.  Slap me.
(Assignee)

Comment 28

17 years ago
You should all use my machine which has a white url bar in both skins.
I'll work on an image with a transparent bg.
Created attachment 57678 [details]
Mozilla-16 image with transparent background
(Assignee)

Comment 30

17 years ago
Daniel, thanks! that looks pretty good!


for the rest of you... it could be worse:
http://qualm.mi.org/mozilla/de-bug.html

Comment 31

17 years ago
Cor lumme that's disgusting.  =)

Comment 32

17 years ago
Pure transparency will result in bad contrast on different backgrounds.

Have a look at <http://www.subotnik.net/tmp/icons/mozilla.html>! It places thre
icons on different background colours (this is important at least for skinnability).

The first icon ist todays <http://mozilla.org/images/mozilla-16.png> with white
background.
The second is attachement 57678.
The third has a transparent background but I added a half-transparent shining
around the image. 

Remember: The cool stuff about PNG is alpha transparency. Let's use it!

Updated

17 years ago
Blocks: 110294
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.