[FFOS2.0][Download][DRM]MS prompt "Download Error" when download FL video file.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Browser
P2
normal
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:-, b2g-v2.0 wontfix, b2g-v2.0M wontfix, b2g-v2.1 wontfix, b2g-v2.2 wontfix)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created an attachment (id=993708)
 image
 
 DEFECT DESCRIPTION:
 MS prompt "Download Error" when download FL video file.
 
 REPRODUCING PROCEDURES:
 1.Launch http://imps.tcl-ta.com/liuqiong/drm/ForwardLock/Video/Binary/Index5.html;
 2.Click any video,then MS prompt "Download Error"(see the attach).===>KO
 3.From the RDF,we can notice MS support video type like 3gpp and mp4.
 
 Note:
 x-wap-profile: http://www-ccpp.tcl-ta.com/files/ALCATELOneTouch4023D.xml
 
 EXPECTED BEHAVIOUR:
 Should download normally.
 
 Phone:61695
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:100%
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

3 years ago
Created attachment 8514869 [details]
image

Comment 2

3 years ago
Hi Evelyn, Hi Gary,
Could you please help to check the problem? Thanks!
Blocks: 1054172, 1080481
blocking-b2g: --- → 2.0M?
status-b2g-v2.0: --- → affected
status-b2g-v2.0M: --- → affected
Flags: needinfo?(gchen)
Flags: needinfo?(ehung)
I'm not sure what kind of types we support for download in DRM case. 
Blake, do you know this?

also set qawanted for branch check and reference device check.
Flags: needinfo?(gchen)
Flags: needinfo?(ehung)
Flags: needinfo?(bwu)
Keywords: qawanted

Comment 4

3 years ago
Hi Norry,
qawanted for Woodduck 2.0M and Flame 2.0/2.1 Thanks!
Flags: needinfo?(fan.luo)

Updated

3 years ago
See Also: → bug 1093425
Created attachment 8517163 [details]
Verify.png

(In reply to Josh Cheng [:josh] from comment #4)
> Hi Norry,
> qawanted for Woodduck 2.0M and Flame 2.0/2.1 Thanks!

Hi Josh,
This bug can be reproed on Woodduck 2.0M and Flame 2.0/2.1

Attached: Logcatverify.txt& Verify.png
Found time: 21:59
Rate: always

Flame 2.0 Build:
Gaia-Rev        fe2167fa5314c7e71c143a590914cbf3771905a8
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/093de6b632c5
Build-ID        20141104160207
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141104.192428
FW-Date         Tue Nov  4 19:24:39 EST 2014
Bootloader      L1TC00011880
------------------------------
Woodduck version:
Gaia-Rev        6dea064f6872a42657297621807d6d35453a7e7b
Gecko-Rev       9b8934fbb515c7ac026ecf0557d44feec888c4ef
Build-ID        20141105050313
Version         32.0
Device-Name     soul35
FW-Release      4.4.2
FW-Incremental  1415135123
FW-Date         Wed Nov  5 05:05:45 CST 2014
-----------------------------
Flame 2.1 new build:
Gaia-Rev        8b0cf889ae0d48a9eb7ecdcb9b67590de45cc5e5
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/388b03efe92d
Build-ID        20141104001202
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141104.033411
FW-Date         Tue Nov  4 03:34:22 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(fan.luo)
Created attachment 8517164 [details]
Logcatverify.txt
status-b2g-v2.1: --- → affected
Flags: needinfo?(jocheng)
Keywords: qawanted

Comment 7

3 years ago
Dear Blake, We need your advice. Thanks!
Flags: needinfo?(jocheng)
Sorry. I am not familiar with downloading FL video files.
Hi Anthony, 
Could you help us on this?
Thanks!
Flags: needinfo?(bwu) → needinfo?(ajones)
David - do you know who to direct this to?
Flags: needinfo?(ajones) → needinfo?(dflanagan)
Our Forward Lock DRM implementation only supports images and audio files. Video files have been explicitly out of scope from the very earliest discussions of this feature.

The point of creating the FL app in gaia was to demonstrate that we could implement forward lock drm with adequate security and without adding DRM to gecko. Partners who need to extend the forward lock mechanism can do so based on our example.

Support for short videos should be reasonably straightforward to add, following the existing code for music files.  The implementation supports ringtones and songs. Songs are downloaded and then stored in an encrypted form on the sdcard. The music app has special code for requesting the decryption key and decrypting the songs as needed. The same thing could be done for short videos, but only if the file size was small enough to be decrypted in memory, since we don't have a way to do streaming decryption.

In any case, I suggest that this is a WONTFIX bug and reflects a failure of communication between us and our partners. It should not have come as a late surprise that we do not support forward lock for videos.
Flags: needinfo?(dflanagan)
Thanks for the detailed explanation. I'll be able to remind people if/when this comes up again.

Comment 12

3 years ago
Per comment 10. Resolved with "Wontfix"
Thanks David. Thanks Anthony.
Status: NEW → RESOLVED
blocking-b2g: 2.0M? → -
Last Resolved: 3 years ago
status-b2g-v2.0: affected → wontfix
status-b2g-v2.0M: affected → wontfix
status-b2g-v2.1: affected → wontfix
status-b2g-v2.2: --- → wontfix
Resolution: --- → WONTFIX
(Reporter)

Comment 13

3 years ago
ok,thanks.please close this bug.
You need to log in before you can comment on or make changes to this bug.