Remove initializeProfile from automation.py.in

RESOLVED DUPLICATE of bug 1177780

Status

Testing
General
RESOLVED DUPLICATE of bug 1177780
3 years ago
3 years ago

People

(Reporter: jgriffin, Assigned: Harsh, Mentored)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug][lang=python])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
This method has no consumers:

http://dxr.mozilla.org/mozilla-central/search?q=initializeProfile&case=false
(Assignee)

Updated

3 years ago
Assignee: nobody → harshjha2006
(Assignee)

Comment 1

3 years ago
Can you please paste the repository link?
I have worked with git/github before but never with Hg, I hope commands are almost the same.
Thanks!
Flags: needinfo?(jgriffin)
(Reporter)

Comment 2

3 years ago
They're similar, but different.  :)  See https://developer.mozilla.org/en-US/docs/Mercurial for a guide.
Flags: needinfo?(jgriffin)
(Assignee)

Comment 3

3 years ago
Hi Jonathan, please paste the code repo link. Thanks!
Flags: needinfo?(jgriffin)
(Reporter)

Comment 4

3 years ago
http://hg.mozilla.org/mozilla-central/

Note this repo is ~1 GB.
Flags: needinfo?(jgriffin)
(Assignee)

Comment 5

3 years ago
Created attachment 8517875 [details] [diff] [review]
bug-1092340.patch
Attachment #8517875 - Flags: review?(jgriffin)
(Reporter)

Comment 6

3 years ago
thanks for the patch!  pushed to try: https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=52cfa71a61c4
(Reporter)

Comment 7

3 years ago
Comment on attachment 8517875 [details] [diff] [review]
bug-1092340.patch

Review of attachment 8517875 [details] [diff] [review]:
-----------------------------------------------------------------

try looks good!  Can you give this a commit message in the format described at https://developer.mozilla.org/en-US/docs/Mercurial_FAQ#Commit_Message_Conventions ?  I can then land it.
Attachment #8517875 - Flags: review?(jgriffin) → review-
Harsh, can you finish up this patch with a commit message?

When that is uploaded, I would be happy to run it through try server again, and then get it landed
Flags: needinfo?(harshjha2006)
(Assignee)

Comment 9

3 years ago
Hi Jonathan,
Is there a way to add a commit message to an existing patch?

Thanks.
Flags: needinfo?(harshjha2006) → needinfo?(jgriffin)
Harsh,

you can take the patch, import it into your queue and push it so it is active.  Then do a 'hg qrefresh -e' and that will take you to an editor where you can out the comment.

A typical comment for this bug would be:
Bug 1092340 - Remove initializeProfile from automation.py.in. r=jgriffin


Also make sure you have your user setup correctly in hg, or edit the patch with 'hg qrefresh -u "Harsh <harshjha2006@gmail.com>"

Of course you can chose the specific name you prefer.
Flags: needinfo?(jgriffin)

Comment 11

3 years ago
Hi, is this bug still being worked on? I'm new and this looks like a good first bug.
Flags: needinfo?(jgriffin)
Looks like it's already gone.
(Reporter)

Comment 13

3 years ago
This was just fixed as part of another bug, but thanks for asking!
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jgriffin)
Resolution: --- → DUPLICATE
Duplicate of bug: 1177780
You need to log in before you can comment on or make changes to this bug.