[Contacts] Search for family name duplicates the term and appends to the name of the contact

RESOLVED DUPLICATE of bug 1092559

Status

Firefox OS
Gaia::Contacts
RESOLVED DUPLICATE of bug 1092559
3 years ago
3 years ago

People

(Reporter: Phani, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8515515 [details]
Screenshot from 2014-11-01 19:10:22.png

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.120 Safari/537.36

Steps to reproduce:

Search for the term that matches the last name of ur contact.


Actual results:

It matches the second name and appends it to the name of the contact.


Expected results:

Just show the matched and filter contacts accordingly.
(Reporter)

Updated

3 years ago
Summary: [Contacts] Second name matches and the search term and appends it to the end → [Contacts] Search for family name duplicates the term and appends to the name of the contact
(Reporter)

Comment 1

3 years ago
Created attachment 8515637 [details] [review]
patch
Attachment #8515637 - Flags: review?(francisco)

Comment 2

3 years ago
Hey Phani!

I was about opening a bug for this but I'm glad you already made a patch.

Just one thing, please modify your pull request so it only has one commit with the number and title of the bug as commit message. Otherwise the patch could be rejected.

Thanks!
Flags: needinfo?(pasupulaphani)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1092559

Updated

3 years ago
Flags: needinfo?(pasupulaphani)
Comment on attachment 8515637 [details] [review]
patch

Cleaning r? as this bug has been resolved as duplicated of other one
Attachment #8515637 - Flags: review?(francisco)
You need to log in before you can comment on or make changes to this bug.