Closed Bug 1092840 Opened 5 years ago Closed 3 years ago

[SMS] Received SMS aren't appended to the log

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: andre.jaenisch, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.120 Safari/537.36

Steps to reproduce:

After encoutering bug #1092838 I asked my wife to send me a SMS to my Alcatel OneTouch Fire running FirefoxOS v1.3.
I received it after some minutes.


Actual results:

A SMS preview is shown in the notifcation overlay (pulling down from the top).
When opening the SMS app, no content appears.


Expected results:

The new SMS is appended to the SMS log in the SMS app.
I can see the SMS received under v1.1.

May be a duplicate to bug #982150.
Hey Andre,

is it possible, by chance, that you get a logcat entry while the bug is happening? You'll need to enable "debugging: adb" and "console: enabled" in the settings' developer menu.
Unfortunately there is near zero chance that we can fix this in v1.3 for you :/ what you can try is flash latest version of SMS on the branch v1.3 from mozilla repository, in case this comes from a modification by Alcatel. The version of the SMS app on the branch v1.4 should work on a Firefox OS v1.3 phone too, so you can try this as well. 

You'll be able to move from the v1.3 version to the v1.4 version without any data issue because the SMS data is stored in Gecko, not in the application.
:julienw I'm looking after the logcat (`adb logcat` for a connected device via USB?) this evening (about 5 hours from now).

Flashing is sadly no option to me.
I dislike cancelling my guarantee (lasts one more year) just to fix a minor bug.
I was rather looking for someone confirming my issue and raise awareness to look after it in 1.4+.

When I flash Hamachi I'll go straight forward to 2.x series :)

Do you happen to know some partners at Alcatel and could ask them to look into this? I can imagine they are going to receive post …
Nothing meaningful in the logcat :(

This is a quite serious bug, the SMS application is not usable with this bug.

Do you have the issue with all recipients?
I'll have to check that.
Meanwhile another user confirmed the issue (I'm not alone o/).

I reached Alcatel via Mail and they recommend a factory reset or an upgrade with Touch Upgrade Tool [0][1].
Which road would you take?

After all it won't resolve the problem for the majority of our customers…

[0] http://support.alcatelonetouch.com/global-en/upgradeSoftware
[1] http://www.alcatelonetouch.com/global-en/support/faq/fota.html Q3
Clearly I think it needs to be dealt with Alcatel.

I'd try the ugprade first, and the factory reset then if it still doesn't work... but you'll lose your data.
(crossing fingers)
Still not upgraded, but I observed, that on first-messages, the SMS appears.

That is, I received an SMS from my TelCo telling me I missed a call - and I can see it!
Concerning data: It isn't that bad, since I back upped my data one or two weeks ago before upgrading from v1.1. Only that few pictures I took need to be saved.
Ok, this sounds like an issue that Alcatel had in their first version, but I think they fixed the issue (basically, they took a patch without the fix that fixed a regression). You should definitely try to upgrade.

There is another bug about this but I don't find it right now...
So this is strange. I haven't upgraded yet, FYI.

When I delete a SMS, I can see the more recent ones!
… until I go back and enter the contact's SMS again.

So something in the view part must go wrong …
Flags: needinfo?(felash)
I'm sorry Andre, it's difficult to think correctly with the bug that you still have if you don't upgrade :/

Just a last question though: does everything looks ok (I mean: no missing messages) when you forcibly kill the app and launch it again?
Flags: needinfo?(felash)
Mass closing of Gaia::SMS bugs. End of an era :(
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
Mass closing of Gaia::SMS bugs. End of an era :(
You need to log in before you can comment on or make changes to this bug.