[FFOS2.0][Woodduck][Dialer]The default value of number and name match is not 7.

RESOLVED INVALID

Status

Firefox OS
Gaia
P2
normal
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
DEFECT DESCRIPTION:
 The default value of number and name match is not 7.
 
 REPRODUCING PROCEDURES:
 1.Create one contact A=0211234567,dial out,B display
 2.Dial 1234567 out -> MS display 1234567(K.O)
 
 EXPECTED BEHAVIOUR:
 MS should display A.
 
 The default value of number and name match is 7.
 
 
 
 CONTACT INFO (Name,Phone number):
 name:xingming.yin(xingming.yin.hz.com)
 phone: +86 18575256796

Comment 1

3 years ago
I think the correct STR are as below:

 1. Create one contact Name A with number 0211234567
 2. Dial out to A
 3. Dial 1234567 out 

Expected result
 MS should display A instead of 1234567.

@Norry, 
Can you repo this? Thanks!
Flags: needinfo?(fan.luo)
Keywords: qawanted

Updated

3 years ago
Blocks: 1054172
Based on Comment 1 I am seeing this behavior in all my branch checks.

When I create a contact A with the phone number 0211234567, and then I verify the number is shown by tapping and calling that number. But if I dial 1234567, I see A: 0211234567 as a suggested contact but instead 1234567 is called and displayed.

Tested with Shallow Flash on 319mb using Engineering builds

This bug repro's on Flame KK builds: Flame 2.2 KK, Flame 2.1 KK, Flame 2.0 KK

Actual Results: Dialing 1234567 does dial and display 1234567 instead of the Contact A with 0211234567

Repro Rate: 10/10

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141103040034
Gaia: bc168c17474dabbcceaa349e9bc7c95654435aec
Gecko: 5999e92e89ff
Version: 36.0a1 (2.2) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141103043136
Gaia: ea6f9f10b2d537256cf8e6494e934e5c409e995e
Gecko: af1037f2ed76
Version: 34.0 (2.1) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20141030181855
Gaia: 7b8df9941700c1f6d6d51ff464f0c8ae32008cd2
Gecko: 82a6ed695964
Version: 32.0 (2.0) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
(In reply to Josh Cheng [:josh] from comment #1)
> I think the correct STR are as below:
> 
>  1. Create one contact Name A with number 0211234567
>  2. Dial out to A
>  3. Dial 1234567 out 
> 
> Expected result
>  MS should display A instead of 1234567.
> 
> @Norry, 
> Can you repo this? Thanks!

Hi Josh, I can repro this bug on Flame 2.1/2.0 and woodduck. And when I input 1234567, it will give a suggested numbert: A 0211234567 as comment 2 says.

Flame 2.1 build :
Gaia-Rev        903f6805ec3959c6bdb84d44100981dbac3903cb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/f3d1ad0fcd64
Build-ID        20141103161201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141103.194014
FW-Date         Mon Nov  3 19:40:25 EST 2014
Bootloader      L1TC00011880
----------------
Flame 2.0 build:
Gaia-Rev        fe2167fa5314c7e71c143a590914cbf3771905a8
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/241e51806687
Build-ID        20141103160206
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141103.194240
FW-Date         Mon Nov  3 19:42:51 EST 2014
Bootloader      L1TC00011880
----------------
Woodduck build info:
Gaia-Rev        dd7dc2002ee180e578d3a7898c9a856245019fff
Gecko-Rev       ee1a5e900589cfb51827010127e24befbabd8043
Build-ID        20141104050313
Version         32.0
Device-Name     soul35
FW-Release      4.4.2
FW-Incremental  1415048724
FW-Date         Tue Nov  4 05:05:45 CST 2014
Flags: needinfo?(fan.luo)
Created attachment 8516515 [details]
Verify.3gp
Created attachment 8516516 [details]
logcatVerify.txt

Comment 6

3 years ago
Thank you Cody. Thank you Norry.

Hi Evelyn, Hi Gary,
Can you help to check this issue? Thanks!
blocking-b2g: --- → 2.0M?
Flags: needinfo?(gchen)
Flags: needinfo?(ehung)
This is by design. Close it first feel free to re-open it if anyone has concern.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(gchen)
Flags: needinfo?(ehung)
Resolution: --- → INVALID
(Reporter)

Comment 8

3 years ago
Will mozilla alter this design in the future?

Updated

3 years ago
QA Contact: croesch
blocking-b2g: 2.0M? → ---

Comment 9

3 years ago
(In reply to GaryChen [:GaryChen][:PYChen][:陳柏宇] from comment #7)
> This is by design. Close it first feel free to re-open it if anyone has
> concern.

Will mozilla alter this design in the future?

Comment 10

3 years ago
(In reply to xingming.yin from comment #9)
> (In reply to GaryChen [:GaryChen][:PYChen][:陳柏宇] from comment #7)
> > This is by design. Close it first feel free to re-open it if anyone has
> > concern.
> 
> Will mozilla alter this design in the future?

That is possible but currently we do not have plan to re-design it.
(Reporter)

Comment 11

3 years ago
此pr的兄弟pr已被
 feiyan.zhang进行postponed操作,原因是mozilla对此功能暂不支持。
 请关闭。
 
 (兄弟pr地址http://bugzilla.tcl-ta.com/show_bug.cgi?id=817191)
 
  ------- Comment #1 From Feiyan, ZHANG(WMD PIC HZ VAL--TCT) 2014-11-07 08:20:49 [reply] -------
 
 FFOS2.0 STYLE,无明确改善计划,postponed it.
You need to log in before you can comment on or make changes to this bug.