Closed Bug 1093208 Opened 10 years ago Closed 9 years ago

[e10s] Cannot save image

Categories

(Core Graveyard :: File Handling, defect)

36 Branch
x86_64
All
defect
Not set
normal

Tracking

(e10sm4+, firefox38 affected)

RESOLVED FIXED
Tracking Status
e10s m4+ ---
firefox38 --- affected

People

(Reporter: aurelien, Assigned: mrbkap)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141103030205

Steps to reproduce:

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Nightly version: 36.0a1 (2014-11-03)

Steps to reproduce:

1) Enable e10s experimental feature
2) Navigate to https://mozorg.cdn.mozilla.net/media/img/home/voices/mozilla-wordmark-white.png
3) Download the image


Actual results:

The image cannot be downloaded with the keyboard shortcut (command + S), the context or File menu (Save as).

The keyboard shortcut does not open the file explorer whereas with the the menu, I can choose a folder and a name for the file. But it's not downloaded.
Confirmed in 36.0a1 (2014-11-03) Win 7 x64
Blocks: e10s
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: Untriaged → File Handling
Product: Firefox → Core
Assignee: nobody → mrbkap
tracking-e10s: --- → m4+
I get this on OS X too, even with bugzilla attachments. I can only download the file using the context menu "Save As", but not by Cmd-S or the File menu.
OS: Linux → All
I can't save any page at all.
Probably a variant of this:
New Profile
Browse to a Page containing images
I used www.heise.de
right click on an image
select "Save Image As"
in the save dialog navigate to different directory
Click save

Result: File is not saved

Result File should be saved

Errors in Browser Console:
00:27:40.085 [Exception... "Unexpected error"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource://gre/modules/DownloadLastDir.jsm :: DownloadLastDir.prototype.setFile :: line 173"  data: no] Promise-backend.js:873:0
00:27:40.086 Error: operation not possible on dead CPOW <unknown>

Reproducible: Always on Windows 7 Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141116030212 CSet: a52bf59965a0
Addition to comment 4 : Tested with E10 off, file saves ok, no errors in Browser Console

To every body else: What errors do you see in the Browser Console?
(In reply to martin from comment #5)
> To every body else: What errors do you see in the Browser Console?
"TypeError: window.content is null browser.xul:1:0", 36.0a1 (2014-11-16), e10s ON, Win 7 x64
Addition to comment 4 :
I still see the errors in browser console, but saving an image to a different directory works for me now.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141118144012 CSet: 084441e904d1
> Steps to reproduce:
> 
> 1) Enable e10s experimental feature
> 2) Navigate to
> https://mozorg.cdn.mozilla.net/media/img/home/voices/mozilla-wordmark-white.
> png
> 3) Download the image
> 
> 
> Actual results:
> 
> The image cannot be downloaded with the keyboard shortcut (command + S), the
> context or File menu (Save as).
> 
> The keyboard shortcut does not open the file explorer whereas with the the
> menu, I can choose a folder and a name for the file. But it's not downloaded.

WFM, latest nightly, win7
WFM too
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:37.0) Gecko/20100101 Firefox/37.0 ID:20141216030203 CSet: b836016d82b5
Linux only?
Nope, it works now on Linux, too.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
That's working now, thank you.
Hi guys,

The following might be useful...

I am still unable to dowload images (latest nightly on debian linux 64bit, fresh reset, e10s enabled). 

When I try to download an image, the image to download appears in the downloads list, but with unknown size, and stays there forever without downloading.

Nothing in the browser console, but this in the terminal that launched firefox:

WARNING: content window passed to PrivateBrowsingUtils.isWindowPrivate. Use isContentWindowPrivate instead (but only for frame scripts).
pbu_isWindowPrivate@resource://gre/modules/PrivateBrowsingUtils.jsm:25:14
internalPersist@chrome://global/content/contentAreaUtils.js:381:19
continueSave@chrome://global/content/contentAreaUtils.js:328:5
internalSave/<@chrome://global/content/contentAreaUtils.js:301:7
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:867:23
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:746:7
this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:688:3

If I close the browser, however, and reopen it, and click the "restore last session" button, the ongoing image download is resumed and succeeds. No more message in the terminal.

I tried this with several different websites and different image formats.

Cheers
Yorik
When I try to save an image, I hit bug 1122525.
38.0a1 (2015-02-10) Win 7
(In reply to Yorik van Havre from comment #13)
>
> I am still unable to dowload images (latest nightly on debian linux 64bit,
> fresh reset, e10s enabled). 
>
> [...]
> 
> If I close the browser, however, and reopen it, and click the "restore 
> last session" button, the ongoing image download is resumed and succeeds. 
> No more message in the terminal.

I'm seeing the same problem as Yorik. I'm on Windows 2012 R2 x64, latest nightly, freshly reset, E10S enabled.
This is being reported as not working on latest trunk (38) builds in the #QA channel.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I get this - 

[Exception... "It's illegal to pass a CPOW to native code arg 2 [nsIWebBrowserPersist.saveURI]"  nsresult: "0x80570036 (NS_ERROR_XPC_CANT_PASS_CPOW_TO_NATIVE)"  location: "JS frame :: chrome://global/content/contentAreaUtils.js :: internalPersist :: line 422"  data: no]
WFM in latest nightly:
Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
WFM too now! Thanks for the fix, mozilla heroes!
Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Based on comment 20 and comment 21 resolving as worksforme.
Status: REOPENED → RESOLVED
Closed: 10 years ago9 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: