If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[e10s] about:addons doesn't load after restart

RESOLVED DUPLICATE of bug 1085813

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1085813
3 years ago
3 years ago

People

(Reporter: Florent Fayolle, Unassigned)

Tracking

36 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141103030205

Steps to reproduce:

After enabling the E10S option, I have got issues with loading pages. Most of the issues I got are not reproducible, but here is a STR:
0. Ensure you have e10s enabled (using Nightly of 2014-11-03).
1. Load about:addons
2. Restart Firefox


Actual results:

A throbber appears, but the page is never displayed.

Florent
(Reporter)

Updated

3 years ago
Blocks: 516752
Fayolle, I can't reproduce this bug, but it sounds like bug 1085813. Does about:addons reload for you if you have other tabs opened or if about:addons is the left-most tab? What add-ons do you have installed?

Updated

3 years ago
Flags: needinfo?(fayolle-florent)
(Reporter)

Comment 2

3 years ago
> Fayolle,

(My first name is actually Florent :) ).

> I can't reproduce this bug, but it sounds like bug 1085813

You're right. It is close to this bug, yes:
1. If the about:addons page is the left-most one, the bug doesn't happen
2. It is true for all of the about:... pages

However, it also happens when I have multiple tabs while restoring (at the contrary of the other bug).

> What add-ons do you have installed?

- Restartless restart
- Firebug 3.0a1 (https://github.com/firebug/firebug.next/ )
- And a bunch of disabled addons (should I list them?)

Florent
Flags: needinfo?(fayolle-florent)
Thanks, Florent. (Sorry! :)

The other bug also affects multiple tabs; I only mentioned one in that bug to simplify the steps to reproduce. I'm going to close this bug as a duplicate of bug 1085813, unless you think there is a difference I am missing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1085813
(Reporter)

Comment 4

3 years ago
> Thanks, Florent. (Sorry! :)

Oh, don't be :).

> I'm going to close this bug as a duplicate of bug 1085813, unless you think there is a difference I am missing.

OK, I am CC'ing myself, so I will be aware when it is fixed and see if it solves my issue too.

Florent
You need to log in before you can comment on or make changes to this bug.