crash when reading a mail

VERIFIED DUPLICATE of bug 126987

Status

VERIFIED DUPLICATE of bug 126987
17 years ago
10 years ago

People

(Reporter: bugzilla, Assigned: mscott)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I just recieved a spam mail that every time I read it I crash.

build 20011109

TB 37794259M
TB 37793982H
(Reporter)

Comment 1

17 years ago
This crash is due to a faulty msf file, I'm pretty sure. The cause of the 
faulty msg file in bug 109321.

Somehow this is what happening:
- Reading a mail generated bug 109321
- mozilla generated a faulty msf file because of bug 109321
- when reading the mail again mozilla tries to load the cached message from the 
msf file and crash causing this bug
Depends on: 109321

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: crash

Comment 2

17 years ago
well, we don't cache messages in .msf files, and bug 109321 has nothing to do
with .msf files, so I'm a bit confused how you've decided .msf files are
involved. We load cached files from the memory cache, which has nothing to do
with .msf files.
(Reporter)

Comment 3

17 years ago
Could you check if these TalkBack are all the same:
TB 37794259M
TB 37793982H
TB 3785754X
TB 3785786Z

how I reproduce my bug:
Basicly wheneven I select the message I crash. If I exit mozilla, delete 
the .msf file then I dont crash the first time I select the message. If I then 
restart mozilla and select the message I crash every time I select the message.
That why I said id had something to do with the .msf file.
(Reporter)

Comment 4

17 years ago
ups. wrong talkback numbers before. Here are the correct ones:
TB37794259M
TB37793982H
TB3785971X
TB3785919W
TB3785786Z

If I open the blank message in a new window and select Edit Msg as new I also 
crash. That's TB3785754X
nsImapMailFolder::NormalEndMsgWriteStream
[d:\builds\seamonkey\mozilla\mailnews\imap\src\nsImapMailFolder.cpp, line 3661]
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 106]
EventHandler [d:\builds\seamonkey\mozilla\xpcom\proxy\src\nsProxyEvent.cpp, line
516]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 309]
main1 [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1366]
main [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1701]
WinMain [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1719]
WinMainCRTStartup()
KERNEL32.DLL + 0xd326 (0x77e8d326) 
(Reporter)

Comment 6

17 years ago
dupe of 126987 which has a bit more info

*** This bug has been marked as a duplicate of 126987 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

17 years ago
No longer depends on: 109321

Comment 7

17 years ago
Verified as dup and it has been fixed.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.