Peculiar build failure on Travis CI which may point to an out of date jasmine-jquery

RESOLVED DUPLICATE of bug 1096257

Status

Tree Management
Treeherder
P3
normal
RESOLVED DUPLICATE of bug 1096257
3 years ago
3 years ago

People

(Reporter: jfrench, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

3 years ago
So, I've been getting a CI failure this morning on a pretty innocuous PR:
https://github.com/mozilla/treeherder-ui/pull/258

This is the build, and failure:
https://travis-ci.org/mozilla/treeherder-ui/builds/39845306
"TypeError: jasmine.Matchers is undefined
at /home/travis/build/mozilla/treeherder-ui/webapp/test/vendor/jasmine-jquery.js:530"

The closest error I've come across is this, which looks somewhat similar and implied an out of date jasmine-jquery:
https://github.com/miniJs/miniBoilerplate/issues/9

Our version of jasmine-jquery is 1.5.3
https://github.com/mozilla/treeherder-ui/blob/master/webapp/test/vendor/jasmine-jquery.js#L4

The folks above updated to a new version, to address the problem.

I'm curious if other people are experiencing the same CI failure on their own PRs? I'm unclear why it cropped up all of a sudden. Perhaps its exposed by the ng-cloak directive being used in my PR.

I've triggered my PR build twice to be sure, and I saw the error both times.
(Reporter)

Comment 1

3 years ago
I just had the same CI failure on a different, but similarly minor PR. I assume there must be some recent change with the Travis configuration, infra, repo or env.
https://travis-ci.org/mozilla/treeherder-ui/builds/39986462
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1096257
You need to log in before you can comment on or make changes to this bug.