Closed Bug 1093366 Opened 7 years ago Closed 7 years ago

[3rd party][MarketPlace]App cannot be closed from card view

Categories

(Firefox OS Graveyard :: General, defect)

defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v2.0 fixed, b2g-v2.0M fixed, b2g-v2.1 unaffected, b2g-v2.2 unaffected)

RESOLVED FIXED
2.2 S1 (5dec)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed
b2g-v2.0M --- fixed
b2g-v2.1 --- unaffected
b2g-v2.2 --- unaffected

People

(Reporter: ver4ffos, Assigned: etienne)

References

Details

(Whiteboard: [3rd Party][LibGLA, TD 122332, Delta02, C-Comment])

Attachments

(2 files)

59 bytes, text/plain
Details
46 bytes, text/x-github-pull-request
alive
: review+
Details | Review
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141102030204

Steps to reproduce:

Flame device

1. Search Music graph app in market place and install.
2. Open music graph app from market place or homescreen.
3. search and play some music.
4. Long press home button.
5. Close Music graph app from cardview.
6. Check card view again and close Music Graph app(can be repeated many times)
7. From homescreen try to launch Music graph.


Actual results:

1. At step 6, Music Graph app is not closed. Every-time app is shown in card view.
2. At step 7 app is not launched. Device needs to restart. 


Expected results:

App should be closed properly, should not be shown in card view.
App should be launched again properly.
Attached file youtube link
Whiteboard: [3rd Party][LibGLA, TD 122332, Delta02, C-Comment]
Hi Etienne, would you mind helping with this to check if this is a card view defect?
to be noted, this happened on Flame 2.0.
Thank you very much !
Flags: needinfo?(etienne)
Assignee: nobody → etienne
Flags: needinfo?(etienne)
Attached file Gaia PR
easy one :)
Attachment #8522949 - Flags: review?(alive)
Comment on attachment 8522949 [details] [review]
Gaia PR

\O/
Attachment #8522949 - Flags: review?(alive) → review+
Should we land this on 2.0? Is it for a partner branch?
blocking-b2g: --- → 2.0?
Hi ver4ffos,

Could you please help us check if App cannot be closed from card view only happened for certain specific apps ? or only on Music graph app ? 


thank you very much!
Flags: needinfo?(ver4ffos)
Dear Rachelle,

I found this issue only with Music graph app.
I have checked many other apps but did not happened.
Flags: needinfo?(ver4ffos) → needinfo?(ryang)
Hi ver4ffos,

thank you very much for your confirmation.
Flags: needinfo?(ryang)
[Triage] de-nom for 2.0 considering current phase, however should land to m/c for future releases.

@Etienne: Much appreciate for your effort on it! I think partner can get the patch and integrate by themselves but we tend to minimize the change on 2.0, instead please help put in on m/c for the future SWs. Thank you!
blocking-b2g: 2.0? → ---
It's already fixed on master. So should we close this?
blocking-b2g: --- → 2.0+
eitenne, can you please submit an approval for 2.0/2.1 here ?
Flags: needinfo?(etienne)
See Also: → 1093381
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8522949 [details] [review]
Gaia PR

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: some apps can break the cardview when they're closed (because the WindowManager errors while closing)
[Testing completed]: the STRs from the bug + the basic card view scenarios
[Risk to taking this patch] (and alternatives if risky): very low
[String changes made]: none
Flags: needinfo?(etienne)
Attachment #8522949 - Flags: approval-gaia-v2.0?
Attachment #8522949 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+
What about v2.1? Also, where's the changeset link for master?
Flags: needinfo?(etienne)
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #13)
> What about v2.1? Also, where's the changeset link for master?

Sorry for the confusion, this fix is 2.0 only.
When I said "already fixed" on master I meant by another patch (probably bug 1039519).
Blocks: Woodduck
You need to log in before you can comment on or make changes to this bug.