[2.0] [fxa] Users logged into Firefox Accounts on a FxOS 2.0 phone should not have to log into Marketplace

RESOLVED DUPLICATE of bug 1073098

Status

Marketplace
Integration
P1
normal
RESOLVED DUPLICATE of bug 1073098
3 years ago
3 years ago

People

(Reporter: dbialer, Assigned: ashort)

Tracking

2014-Q3
x86
Mac OS X
Points:
---

Details

(Reporter)

Description

3 years ago
Users logged into their Firefox Account on FxOS 2.0 devices should not have to log into Firefox Accounts in Marketplace since they are already logged in.

I expect you may already know this but did not see a bug file.  So this may be a dupe.

The main (currently only) benefit of Firefox Accounts for Marketplace is to be pre-logged in to Marketplace after the first run experience.

On Marketplace Stage.
To reproduce:
1. On the Settings->Firefox Accounts Menu, create a new account or log into an existing account.
2. Open Marketplace.  
3. Setting menu should show you already logged in on gear menu.
(Reporter)

Updated

3 years ago
Priority: -- → P1

Comment 1

3 years ago
It will never work on 2.0 because the permissions were not made available until 2.1: bug 1028398.

Logging in automatically through Firefox Accounts on the phone requires either us to be a packaged app or to find a way to work around the iframed issue (which Allen is working on). It was decided to move that into a separate milestone because we could not meet the deadline of landing Firefox Accounts for 2.1 (a month or two ago).

We made a new milestone bug here to track that: bug 1088604.

Updated

3 years ago
Blocks: 1088604
No longer blocks: 1007956

Updated

3 years ago
Assignee: nobody → ashort
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1073098
You need to log in before you can comment on or make changes to this bug.