If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Signing in to the phone doesn't log you into marketplace

RESOLVED FIXED in 2014-10-07

Status

Marketplace
Consumer Pages
P1
critical
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: krupa, Assigned: krupa)

Tracking

2014-10-07
x86
Gonk (Firefox OS)
Points:
---

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Connectivity: wifi
SIM used: grameenphone
Gaia/device: 2.0 (latest eng)/Flame

Precondition:
User has dev packaged app installed

steps to reproduce:
1. Go to the Settings app on your flame device
2. Sign into a verified fxA account
3. Launch Dev packaged app
4. Navigate to Settings page

expected behavior:
Users who are logged into the phone are automatically logged into marketplace


actual behavior:
Logging into the phone doesn't log you into dev.
(Assignee)

Comment 1

3 years ago
Created attachment 8495421 [details]
screencast

Updated

3 years ago
Assignee: nobody → ashort
https://github.com/mozilla/fireplace/commit/595f9223
Target Milestone: --- → 2014-10-07

Updated

3 years ago
Priority: -- → P1

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 3

3 years ago
I am still able to reproduce this issue using my Flame device, FxOS 2.1
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

3 years ago
Assignee: ashort → krupa.mozbugs

Comment 4

3 years ago
We aren't going to have this for the first pass of FxA, but when we become a real packaged app. Moving to that tracker.
Blocks: 897156
No longer blocks: 1007956

Updated

3 years ago
Blocks: 1088604
No longer blocks: 897156
Depends on: 897156

Updated

3 years ago
No longer depends on: 897156
https://github.com/mozilla/zamboni/commit/f7fcb5e97af5a02504f8c04a1d7192cf7e360ac0

Behind 'native-firefox-accounts' waffle, currently switched on for marketplace-dev.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Duplicate of this bug: 1093367
You need to log in before you can comment on or make changes to this bug.